Bug 106723 - [CI] GLK: igt@kms_vblank@pipe-[abc]* - fail - Failed assertion: wait_vblank(fd, &vbl) == 0
Summary: [CI] GLK: igt@kms_vblank@pipe-[abc]* - fail - Failed assertion: wait_vblank(f...
Status: CLOSED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Karthik B S
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-30 12:59 UTC by Martin Peres
Modified: 2019-05-31 10:38 UTC (History)
1 user (show)

See Also:
i915 platform: GLK
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-05-30 12:59:07 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_53/fi-glk-j4005/igt@kms_vblank@pipe-a-wait-idle-hang.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_53/fi-glk-j4005/igt@kms_vblank@pipe-b-wait-forked-busy.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_53/fi-glk-j4005/igt@kms_vblank@pipe-c-wait-idle.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_53/fi-glk-j4005/igt@kms_vblank@pipe-a-query-forked-busy-hang.html

[...]
	
(kms_vblank:2401) CRITICAL: Test assertion failure function vblank_query, file ../tests/kms_vblank.c:284:
(kms_vblank:2401) CRITICAL: Failed assertion: wait_vblank(fd, &vbl) == 0
(kms_vblank:2401) CRITICAL: Last errno: 22, Invalid argument
(kms_vblank:2401) CRITICAL: error: -22 != 0


https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_53/fi-glk-j4005/igt@kms_flip@busy-flip.html

(kms_flip:1596) CRITICAL: Test assertion failure function run_test_step, file ../tests/kms_flip.c:776:
(kms_flip:1596) CRITICAL: Failed assertion: __wait_for_vblank(TEST_VBLANK_BLOCK, o->pipe, 1, 0, &reply) == 0
(kms_flip:1596) CRITICAL: Last errno: 22, Invalid argument
Subtest busy-flip failed.
Comment 1 Martin Peres 2018-05-30 13:01:06 UTC
This seems to be a regression introduced in drmtip_53, so bumping the priority.
Comment 2 Francesco Balestrieri 2018-06-01 07:19:52 UTC
This is seen in more than 20 testcases based on cibuglogger. Proposing to highest.
Comment 3 Francesco Balestrieri 2018-06-12 12:27:10 UTC
Last seen 2 days, 10 hours ago. 6 / 66 runs (9.1%)
Comment 4 Francesco Balestrieri 2018-07-03 11:53:56 UTC
Last seen on drmtip_68 (1 week, 5 days / 146 runs ago)
Comment 5 Martin Peres 2018-07-03 11:59:13 UTC
(In reply to Francesco Balestrieri from comment #4)
> Last seen on drmtip_68 (1 week, 5 days / 146 runs ago)

It used to be reproducible every single run until drmtip_68, then nothing for multiple runs. So let's close it!
Comment 6 Francesco Balestrieri 2018-07-03 12:34:33 UTC
Closing, thanks
Comment 8 Martin Peres 2018-08-28 14:22:15 UTC
Lowering the priority because this may not have been a regression introduced by drmtip_53, but may be just timing-sensitive.
Comment 9 Martin Peres 2019-01-14 12:53:58 UTC
When this issue is seen, it is seen multiple times per drmtip run. The affected drmtip runs are affected so far are: 135-133, 129, 127, 93-91, 68-53. This really suggests that this is timings-related.

In average, there are 15.5 runs of silence between periods of detection. So that means we would need to wait at least 155 drmtip runs (until drmtip_290) before we can have a reasonable expectation that this is fixed.

Let's see where this goes!
Comment 10 Lakshmi 2019-05-31 10:38:09 UTC
(In reply to Martin Peres from comment #9)
> When this issue is seen, it is seen multiple times per drmtip run. The
> affected drmtip runs are affected so far are: 135-133, 129, 127, 93-91,
> 68-53. This really suggests that this is timings-related.
> 
> In average, there are 15.5 runs of silence between periods of detection. So
> that means we would need to wait at least 155 drmtip runs (until drmtip_290)
> before we can have a reasonable expectation that this is fixed.
> 
> Let's see where this goes!

Current drmtip run is 296.
No new occurrences since drmtip 135, closing this bug as WORKSFORME.
Comment 11 CI Bug Log 2019-05-31 10:38:17 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.