Bug 106737 - Mouse and touchpad pointer movement is too slow
Summary: Mouse and touchpad pointer movement is too slow
Status: RESOLVED DUPLICATE of bug 106785
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/libinput (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Peter Hutterer
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-30 17:53 UTC by Tony Houghton
Modified: 2018-06-04 00:03 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Houghton 2018-05-30 17:53:45 UTC
My hardware is a Lenovo Thinkpad Carbon X1 4th gen, but as mouse and touchpad both seem to be affected I don't think this is hardware-specific.

When running GNOME on Xorg the pointer moves more slowly than in Wayland. This means I have to adjust my settings when switching between Xorg and Wayland, but even if I turn them up to maximum they're still slower than my desired speed in Xorg.

I'm using Arch Linux with the following package versions, but I first noticed the problem a long time ago, and I think I was using Debian at the time:

xf86-input-libinput 0.27.1-1
xorg-server 1.20.0-2
libinput 1.10.7-1
Comment 1 Peter Hutterer 2018-05-30 22:46:55 UTC
Hidpi screen? Fedora has the DPIScale option in xorg-x11-drv-libinput as a distribution-specific patch but we don't otherwise have a good solution for upstream yet.
Comment 2 Tony Houghton 2018-06-01 10:44:15 UTC
It is hidpi. That's a good point; it had occurred to me earlier, but I forgot to mention it in my bug report. Thanks for the tip-off about Fedora, I'll see if I can get their patch or something similar working in Arch.
Comment 3 Peter Hutterer 2018-06-04 00:03:46 UTC
Closing this as dupe of 106785 now, given that one has the more descriptive summary, thanks.

*** This bug has been marked as a duplicate of bug 106785 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.