Bug 1068 - kbd driver fails to load on Solaris
Summary: kbd driver fails to load on Solaris
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/Keyboard (show other bugs)
Version: git
Hardware: x86 (IA32) Solaris
: high normal
Assignee: Alan Coopersmith
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 890
  Show dependency treegraph
 
Reported: 2004-08-13 07:43 UTC by Alan Coopersmith
Modified: 2005-08-12 00:15 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Coopersmith 2004-08-13 07:43:17 UTC
Xorg will no longer start on Solaris since the "keyboard" driver has been
deprecated and disabled by default, but the "kbd" driver fails to load.
Comment 1 Kevin E. Martin 2004-08-13 07:51:37 UTC
The simple fix is, of course, to re-enable the deprecated keyboard driver on
Solaris by defining UseDeprecatedKeyboardDriver to YES.  However, it would be
good if someone could look into this one to determine where the problem is in
the new kbd driver.
Comment 2 Kristian Høgsberg 2004-08-13 08:01:35 UTC
The new driver is not supported on Solaris at all, it only consists of stubs in
os-support/sunos/sun_io.c.  It shouldn't be too much work to get it running,
most of the code can be copied from the old driver into the stubs.

It's probably too late at this point, I was thinking that this work could happen
between now and the next release.  This was the primary reason for keeping the
old driver in the tree.
Comment 3 Alan Coopersmith 2004-08-13 09:13:41 UTC
Right - changing the define is the 5 minute fix, but I was also working on
porting the code for Solaris.  If I can't get that done by the code freeze, I'll
change
the #define.
Comment 4 Alan Coopersmith 2004-08-13 14:32:22 UTC
After working on this some more, I don't think kbd support for Solaris will be
ready for the code freeze for this release.  Since bug 1070 will fix the 
immediate problem (server can't start because it has no keyboard driver), 
I've removed this from the blocker list for the 6.8.0 release and will work on
getting Solaris kbd driver support ready to go into head after the 6.8.0 release
is branched off so that it can be tested and debugged for the next release.
Comment 5 Adam Jackson 2005-07-01 18:43:05 UTC
any progress here?
Comment 6 Alan Coopersmith 2005-07-03 14:24:39 UTC
Still need to finish this up and commit soon...
Comment 7 Alan Coopersmith 2005-08-13 10:15:51 UTC
Done!  (Just one day short of a year since the bug was filed!  How time flies...)

CVSROOT:	/cvs/xorg
Module name:	xc
Changes by:	alanc@gabe.freedesktop.org	05/08/12 17:11:28

Log message:
  2005-08-12  Alan Coopersmith  <alan.coopersmith@sun.com>
  
  	* programs/Xserver/hw/xfree86/os-support/sunos/Imakefile:
  	Add LintTarget()
  
  	* programs/Xserver/hw/xfree86/os-support/sunos/sun_io.c:
  	* programs/Xserver/hw/xfree86/os-support/sunos/sun_kbd.c:
  	* programs/Xserver/hw/xfree86/os-support/sunos/sun_kbd.h:
  	* programs/Xserver/hw/xfree86/os-support/sunos/sun_kbdEv.c:
  	Bugzilla #1068 <https://bugs.freedesktop.org/show_bug.cgi?id=1068>
  	Port Solaris keyboard code to work with kbd driver.
  
  	Also incorporated "audio bell" feature from Xsun keyboard DDX
  	to play bell tones via /dev/audio (specified via
  	Option "BellDevice" "/dev/audio" in keyboard device options).

Modified files:
      ./:
        ChangeLog 
      xc/programs/Xserver/hw/xfree86/os-support/sunos/:
        Imakefile sun_io.c sun_kbd.c sun_kbdEv.c 
Added files:
      xc/programs/Xserver/hw/xfree86/os-support/sunos/:
        sun_kbd.h 
  
  Revision      Changes    Path
  1.1204        +16 -0     xc/ChangeLog
  1.7           +1 -0      xc/programs/Xserver/hw/xfree86/os-support/sunos/Imakefile
  1.4           +115 -23   xc/programs/Xserver/hw/xfree86/os-support/sunos/sun_io.c
  1.6           +587 -65   xc/programs/Xserver/hw/xfree86/os-support/sunos/sun_kbd.c
  1.8           +15 -23   
xc/programs/Xserver/hw/xfree86/os-support/sunos/sun_kbdEv.c



Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.