Bug 106865 - [GLK] piglit.spec.ext_framebuffer_multisample.accuracy stencil tests fail
Summary: [GLK] piglit.spec.ext_framebuffer_multisample.accuracy stencil tests fail
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Nanley Chery
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 106156 mesa-18.2
  Show dependency treegraph
 
Reported: 2018-06-08 16:52 UTC by Clayton Craft
Modified: 2018-08-31 20:24 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Clayton Craft 2018-06-08 16:52:30 UTC
This seems to only affect HD600 (2x6), and not HD605 (3x6).


List of failing tests:

piglit.spec.ext_framebuffer_multisample.accuracy 6 depth_draw small depthstencil
piglit.spec.ext_framebuffer_multisample.accuracy 8 stencil_draw small depthstencil
piglit.spec.ext_framebuffer_multisample.accuracy 6 stencil_draw small depthstencil
piglit.spec.ext_framebuffer_multisample.accuracy 8 depth_resolve small
piglit.spec.ext_framebuffer_multisample.accuracy 6 stencil_resolve small depthstencil
piglit.spec.ext_framebuffer_multisample.accuracy 4 stencil_draw small depthstencil
piglit.spec.ext_framebuffer_multisample.accuracy 16 stencil_draw small depthstencil
piglit.spec.ext_framebuffer_multisample.accuracy 16 depth_draw small depthstencil
piglit.spec.ext_framebuffer_multisample.accuracy 2 stencil_resolve small depthstencil
piglit.spec.ext_framebuffer_multisample.accuracy 6 stencil_draw small
piglit.spec.ext_framebuffer_multisample.accuracy all_samples stencil_draw small
piglit.spec.ext_framebuffer_multisample.accuracy 2 depth_draw small depthstencil
piglit.spec.ext_framebuffer_multisample.accuracy all_samples depth_draw small depthstencil
piglit.spec.ext_framebuffer_multisample.accuracy all_samples stencil_resolve small
piglit.spec.ext_framebuffer_multisample.accuracy 4 depth_draw small depthstencil
piglit.spec.ext_framebuffer_multisample.accuracy all_samples depth_draw small
piglit.spec.ext_framebuffer_multisample.accuracy all_samples stencil_draw small depthstencil
piglit.spec.ext_framebuffer_multisample.accuracy 4 stencil_resolve small depthstencil
piglit.spec.ext_framebuffer_multisample.accuracy 4 depth_resolve small depthstencil
piglit.spec.ext_framebuffer_multisample.accuracy all_samples stencil_resolve small depthstencil




Output from one of the failing tests:

/tmp/build_root/m64/lib/piglit/bin/ext_framebuffer_multisample-accuracy 6 depth_draw small depthstencil -auto -fbo
Pixels that should be unlit
  count = 126470
  Perfect output
Pixels that should be totally lit
  count = 131408
  RMS error = 0.141088
The error threshold for unlit and totally lit pixels test is 0.010323
Pixels that should be partially lit
  count = 4266
  RMS error = 0.077997
The error threshold for partially lit pixels is 0.206460
Comment 1 Denis 2018-06-14 09:22:26 UTC
Hi Clayton, could you please clarify GPU models, marked as "HD600 (2x6), and not HD605 (3x6)?
I wanna dig into this, but not sure whether I have needed configurations.
Comment 3 Nanley Chery 2018-08-17 17:46:21 UTC
A common theme among these failing tests is that they all have the "small" option enabled.
Comment 4 Nanley Chery 2018-08-20 21:14:47 UTC
Running the tests with INTEL_DEBUG=sync causes them to pass.
Comment 5 Nanley Chery 2018-08-20 22:29:26 UTC
INTEL_DEBUG=reemit is similarly useful.(In reply to Nanley Chery from comment #4)
> Running the tests with INTEL_DEBUG=sync causes them to pass.

INTEL_DEBUG=reemit is similarly useful.
Comment 6 Nanley Chery 2018-08-21 23:19:02 UTC
Hacking to driver to disable push constants also makes the tests pass.
Comment 7 Kenneth Graunke 2018-08-23 03:21:33 UTC
You don't even need to re-emit everything, just re-emitting 3DSTATE_PUSH_CONSTANT_ALLOC_* fixes it.
Comment 8 Andrés Gómez García 2018-08-24 15:45:11 UTC
Nanley, Kenneth, any news on this bug ?

Notice that I've extenced the Release Candidates period for 18.2 in order to get room for fixing blockers from bug 107457.

If you don't think this can be solved in a reasonable period of time we should target for 18.3 and warn in the release notes about this known bug.

Please, let me know as soon as possible.
Comment 9 Andrés Gómez García 2018-08-24 15:46:25 UTC
Additionally, which is the reason for blocking mesa-18.2 ? If this is a regression, do we have a bisect of it?
Comment 10 Nanley Chery 2018-08-24 23:38:17 UTC
(In reply to Andrés Gómez García from comment #8)
> Nanley, Kenneth, any news on this bug ?
> 
> Notice that I've extenced the Release Candidates period for 18.2 in order to
> get room for fixing blockers from bug 107457.
> 
> If you don't think this can be solved in a reasonable period of time we
> should target for 18.3 and warn in the release notes about this known bug.
> 
> Please, let me know as soon as possible.

Hi Andrés,

Thank you for the extra time. We have a fix for this bug going through CI and I will send it out to the list shortly.
Comment 11 Nanley Chery 2018-08-25 00:49:58 UTC
The fix for this bug (and mitigation for the issue) is on the list:
https://patchwork.freedesktop.org/patch/245950/
Comment 12 Nanley Chery 2018-08-29 20:41:52 UTC
v2: https://patchwork.freedesktop.org/patch/246461/
Comment 13 Nanley Chery 2018-08-30 23:34:19 UTC
Thank you for the report. This should be fixed by:

commit 4a57b997092851a2c5e170bb1b58787524006704 
Author: Nanley Chery <nanley.g.chery@intel.com>
Date:   Wed Aug 22 10:43:32 2018 -0700

    i965/gen7_urb: Re-emit PUSH_CONSTANT_ALLOC on some gen9
Comment 14 Nanley Chery 2018-08-31 20:24:11 UTC
Looks like I actually failed to push the fix. It's upstream now and the commit is 904c2a617d86944fbdc2c955f327aacd0b3df318 .


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.