Bug 106882 - glxinfo and eglinfo reports error on mesa 18.1.x
Summary: glxinfo and eglinfo reports error on mesa 18.1.x
Status: NEW
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 18.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-11 12:07 UTC by siyanmao.sec
Modified: 2018-09-17 02:19 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
strace output of eglinfo (18.07 KB, text/plain)
2018-06-11 12:13 UTC, siyanmao.sec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description siyanmao.sec 2018-06-11 12:07:44 UTC

    
Comment 1 siyanmao.sec 2018-06-11 12:13:44 UTC
Created attachment 140117 [details]
strace output of eglinfo
Comment 2 siyanmao.sec 2018-06-11 12:26:04 UTC
distribution: archlinux
kernel: 4.16.13
mesa version: 18.1.x
GPU: intel i5 6500 (Intel Corporation HD Graphics 530)
motherboard: ASRock H110M-HDV

how to reproduce:
0. run xserver and xterm
1. run glxinfo or eglinfo in xterm
2. eglinfo shows "eglinfo: eglInitialize failed" and glxinfo shows "couldn't find RGB GLX visual or fbconfig"

downgrade mesa and mesa-vdpau to 18.0.4 seems solve this problem.
Comment 3 Denis 2018-06-12 12:03:13 UTC
hi! I have fresh installed manjaro 
Kernel 4.14.48-2
Xfce windows env

Tested on mesa-18.1.1 (latest from repo) - works fine.
Downgraded to 18.1.0 - also looks good.

Installing 4.16.14-2 Kernel to try
Comment 4 Denis 2018-06-12 16:19:57 UTC
checked on 4.16.14-2 kernel - also works fine.
But - I have SKL GT 520 now. Will try to check on 530
Comment 5 siyanmao.sec 2018-06-12 16:37:06 UTC
I have tried same softwares (latest from repo) on another PC:
archlinux 
kernel: 4.16.13
mesa and mesa-vdpau: 18.1.1
sddm 0.17.0 
plasma-desktop 5.12.5

GPU: HD 4600 GT2 (Intel i5 4690)

It works fine.

I will try latest testing kernel (4.17) later.
Comment 6 Denis 2018-08-29 08:41:07 UTC
hi. Did you try with a new kernel?
Comment 7 siyanmao.sec 2018-09-17 02:19:05 UTC
Sorry I have forgot this (

I have tried latest kernel and mesa in archinux repo, and same problem occured. 
mesa 18.2.0-1
mesa-vdapu 18.2.0-1
linux 4.18.6.arch1-1

Downgrade mesa and mesa-vdapu to 18.0.4-1 works fine.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.