Bug 106978 - [CI][SHARDS] igt@kms_frontbuffer_tracking@(fpcpsr|psr)-* - incomplete - no good logs
Summary: [CI][SHARDS] igt@kms_frontbuffer_tracking@(fpcpsr|psr)-* - incomplete - no go...
Status: RESOLVED MOVED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-20 14:00 UTC by Martin Peres
Modified: 2019-11-29 17:47 UTC (History)
1 user (show)

See Also:
i915 platform: ICL, SKL
i915 features: display/PSR


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-06-20 14:00:42 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_67/fi-skl-6700hq/igt@kms_frontbuffer_tracking@psr-1p-offscren-pri-indfb-draw-pwrite.html

Unfortunately, the logs don't contain anything that looks useful to me:

<0>[  416.098437] perf_pmu-1635    5.... 383392595us : reset_all_global_seqno.part.5: bcs0 seqno 0 (current 0) -> 0
<0>[  416.098473] perf_pmu-1635    5.... 383392598us : reset_all_global_seqno.part.5: vcs0 seqno 0 (current 0) -> 0
<0>[  416.098509] perf_pmu-1635    5.... 383392601us : reset_all_global_seqno.part.5: vecs0 seqno 0 (current 0) -> 0
<0>[  416.098545] perf_pmu-1635    5.... 383392691us : i915_gem_wait_for_idle: flags=3 (locked)
<0>[  416.098581] perf_pmu-1635    5.... 383392903us : i915_gem_wait_for_idle: flags=3 (locked)
<0>[  416.098616] perf_pmu-1635    5.... 383392994us : i915_gem_wait_for_idle: flags=3 (locked)
<0>[  416.098651] gem_exec-1638    2.... 383507823us : i915_gem_wait_for_idle: flags=3 (locked)
<0>[  416.098685] gem_exec-1638    2.... 383508318us : i915_gem_wait_for_idle: flags=3 (locked)
<0>[  416.098722] gem_exec-1638    2.... 383508320us : reset_all_global_seqno.part.5: rcs0 seqno 0 (current 0) -> 0
<0>[  416.098759] gem_exec-1638    2.... 383508501us : reset_all_global_seqno.part.5: bcs0 seqno 0 (current 0) -> 0
<0>[  416.098796] gem_exec-1638    2.... 383508507us : reset_all_global_seqno.part.5: vcs0 seqno 0 (current 0) -> 0
<0>[  416.098832] gem_exec-1638    2.... 383508527us : reset_all_global_seqno.part.5: vecs0 seqno 0 (current 0) -> 0
<0>[  416.098868] gem_exec-1638    2.... 383535719us : i915_gem_wait_for_idle: flags=3 (locked)
<0>[  416.098903] kms_fron-1646    5.... 383679597us : i915_gem_wait_for_idle: flags=3 (locked)
<0>[  416.098938] kms_fron-1646    5.... 383734604us : i915_gem_unpark: 
<0>[  416.098974] kms_fron-1646    5.... 383734880us : i915_request_add: bcs0 fence 45f:1
<0>[  416.099011] kms_fron-1646    5.... 383734882us : i915_request_add: marking kms_frontbuffer[1646]/0 as active
Comment 4 CI Bug Log 2019-02-04 16:23:18 UTC
A CI Bug Log filter associated to this bug has been updated:

{- SKL ICL: igt@kms_frontbuffer_tracking@(fbc)?psr-* - incomplete -}
{+ SKL ICL: igt@kms_frontbuffer_tracking@(fbc)?psr-* - incomplete +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_205/fi-icl-u3/igt@kms_frontbuffer_tracking@psr-2p-scndscrn-cur-indfb-draw-mmap-gtt.html
* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_206/fi-icl-u3/igt@kms_frontbuffer_tracking@psr-2p-scndscrn-cur-indfb-draw-mmap-gtt.html
Comment 5 CI Bug Log 2019-04-10 16:09:22 UTC
A CI Bug Log filter associated to this bug has been updated:

{- SKL ICL: igt@kms_frontbuffer_tracking@(fbc)?psr-* - incomplete -}
{+ SKL ICL: igt@kms_frontbuffer_tracking@(fbc)?psr-* - incomplete +}

New failures caught by the filter:


* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_251/fi-icl-u3/igt@kms_frontbuffer_tracking@fbcpsr-2p-scndscrn-indfb-msflip-blt.html
Comment 6 CI Bug Log 2019-04-16 06:23:46 UTC
A CI Bug Log filter associated to this bug has been updated:

{- SKL ICL: igt@kms_frontbuffer_tracking@(fbc)?psr-* - incomplete -}
{+ SKL ICL: igt@kms_frontbuffer_tracking@(fbc)?psr-* - incomplete +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_253/fi-icl-u2/igt@kms_frontbuffer_tracking@fbcpsr-2p-primscrn-indfb-pgflip-blt.html

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_253/fi-icl-y/igt@kms_frontbuffer_tracking@psr-2p-primscrn-shrfb-msflip-blt.html
Comment 7 Martin Peres 2019-04-23 11:24:11 UTC
Bumping the priority to high, since we get incompletes from time to time and since PSR/FBC is now enabled by default on gen9.
Comment 8 James Ausmus 2019-04-24 23:09:09 UTC
Looks like this might be GEM related - got one pstore log that ends in a GEM wait_for_idle on rcs0 - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_253/fi-icl-y/pstore15-1517155641_Panic_1.log
Comment 9 Jani Saarinen 2019-05-15 03:57:09 UTC
u2, u3, re-icl-u and shards have now updated BIOS( ICLSFWR1.R00.3175.A00.1904261428 04/26/2019). To be seen if we see issues after updates.
Comment 10 Jani Saarinen 2019-05-25 07:28:29 UTC
Update: u2/u3/re/ and half of the shards now on BIOS ICLSFWR1.R00.3183.A00.1905020411 05/02/2019
Comment 11 Francesco Balestrieri 2019-06-03 05:09:20 UTC
While this continues happening, the GEM error hasn't appeared for a while according to another thread of discussion. I'm removing GEM from the component list.
Comment 12 Mika Kahola 2019-06-27 12:00:16 UTC
Test definition

kms_frontbuffer_tracking tests tracking mechanisms and its related features such as framebuffer compression (FBC), panel self refresh (PRS) and display refresh rate switching (DRRS).

User impact

Worst case scenario for a user is black or frozen screen. One may experience flickering too. 

Reproduction rate

Currently 15.4%

#assessment
Comment 13 Martin Peres 2019-11-29 17:47:48 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/intel/issues/123.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.