Bug 107015 - The GPU Vega 56 randomly hang while I playing in the Mad Max game
Summary: The GPU Vega 56 randomly hang while I playing in the Mad Max game
Status: RESOLVED MOVED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-24 14:55 UTC by mikhail.v.gavrilov
Modified: 2019-11-19 08:42 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg (123.41 KB, text/plain)
2018-06-24 14:56 UTC, mikhail.v.gavrilov
no flags Details
place 1 (430.20 KB, image/jpeg)
2018-06-24 14:58 UTC, mikhail.v.gavrilov
no flags Details
place 2 (470.98 KB, image/jpeg)
2018-06-24 14:58 UTC, mikhail.v.gavrilov
no flags Details
place 3 (730.83 KB, image/jpeg)
2018-06-24 14:58 UTC, mikhail.v.gavrilov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description mikhail.v.gavrilov 2018-06-24 14:55:49 UTC
$ inxi -bM
System:    Host: localhost.localdomain Kernel: 4.18.0-0.rc0.git9.1.fc29.x86_64 x86_64 bits: 64
           Desktop: Gnome 3.29.2 Distro: Fedora release 29 (Rawhide)
Machine:   Device: desktop System: Gigabyte product: Z87M-D3H serial: N/A
           Mobo: Gigabyte model: Z87M-D3H serial: N/A UEFI: American Megatrends v: F11 date: 08/12/2014
Battery    hidpp__0: charge: N/A condition: NA/NA Wh
CPU:       Quad core Intel Core i7-4770 (-MT-MCP-) speed/max: 3699/3900 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Vega 10 XT [Radeon RX Vega 64]
           Display Server: wayland (X.org 12 ) drivers: modesetting,fbdev,vesa Resolution: 3840x2160@59.98hz
           OpenGL: renderer: Radeon RX Vega (VEGA10, DRM 3.26.0, 4.18.0-0.rc0.git9.1.fc29.x86_64, LLVM 6.0.1)
           version: 4.5 Mesa 18.1.2
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
Drives:    HDD Total Size: 16241.0GB (24.7% used)
Info:      Processes: 415 Uptime: 4:20 Memory: 17322.8/32036.9MB Client: Shell (bash) inxi: 2.3.56 


[26824.860113] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx timeout, last signaled seq=12904377, last emitted seq=12904379
[26824.860141] [drm] GPU recovery disabled.
[26869.094908] sysrq: SysRq : Show Blocked State
[26869.095021]   task                        PC stack   pid father
[26869.095488] kworker/u16:0   D12040 10033      2 0x80000000
[26869.095511] Workqueue: events_unbound commit_work [drm_kms_helper]
[26869.095514] Call Trace:
[26869.095519]  ? __schedule+0x2e2/0xb00
[26869.095525]  ? dma_fence_default_wait+0x231/0x370
[26869.095527]  schedule+0x2f/0x90
[26869.095529]  schedule_timeout+0x35c/0x520
[26869.095533]  ? find_held_lock+0x34/0xa0
[26869.095538]  ? mark_held_locks+0x57/0x80
[26869.095550]  ? _raw_spin_unlock_irqrestore+0x4b/0x60
[26869.095555]  ? dma_fence_default_wait+0x231/0x370
[26869.095557]  dma_fence_default_wait+0x25d/0x370
[26869.095560]  ? dma_fence_release+0x160/0x160
[26869.095564]  dma_fence_wait_timeout+0x4f/0x270
[26869.095568]  reservation_object_wait_timeout_rcu+0x236/0x4e0
[26869.095635]  amdgpu_dm_do_flip+0x112/0x350 [amdgpu]
[26869.095678]  amdgpu_dm_atomic_commit_tail+0x6f2/0xd00 [amdgpu]
[26869.095723]  commit_tail+0x3d/0x70 [drm_kms_helper]
[26869.095727]  process_one_work+0x27d/0x650
[26869.095746]  worker_thread+0x3c/0x390
[26869.095752]  ? process_one_work+0x650/0x650
[26869.095755]  kthread+0x120/0x140
[26869.095758]  ? kthread_create_worker_on_cpu+0x70/0x70
[26869.095763]  ret_from_fork+0x3a/0x50

This hangs occurred in different places, see screenshots.
But every time when I overplayed, I could not reproduce hang again, unlike this issue (https://bugs.freedesktop.org/show_bug.cgi?id=106877) the game Rise of the Tomb Raider the hang is reproduced 100%.
Comment 1 mikhail.v.gavrilov 2018-06-24 14:56:08 UTC
Created attachment 140299 [details]
dmesg
Comment 2 mikhail.v.gavrilov 2018-06-24 14:58:10 UTC
Created attachment 140300 [details]
place 1
Comment 3 mikhail.v.gavrilov 2018-06-24 14:58:34 UTC
Created attachment 140301 [details]
place 2
Comment 4 mikhail.v.gavrilov 2018-06-24 14:58:56 UTC
Created attachment 140302 [details]
place 3
Comment 5 Timothy Arceri 2019-02-12 11:49:22 UTC
Is this still a problem with recent Mesa/kernel?
Comment 6 Martin Peres 2019-11-19 08:42:00 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/amd/issues/427.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.