Bug 107100 - xserver 1.20 crash on EnterVT
Summary: xserver 1.20 crash on EnterVT
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 109806 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-07-03 10:52 UTC by Emilio Pozuelo Monfort
Modified: 2019-03-11 09:25 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xserver log (52.83 KB, application/x-trash)
2018-07-03 10:55 UTC, Emilio Pozuelo Monfort
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emilio Pozuelo Monfort 2018-07-03 10:52:09 UTC
Hi,

I found a reproducible crash on xserver 1.20, with Intel gfx and the modesetting driver. Just switching to another VT, then coming back crashes the server:

[   213.548] (II) AIGLX: Resuming AIGLX clients after VT switch
[   213.560] (EE) modeset(0): failed to set mode: Invalid argument
[   213.560] (EE) 
Fatal server error:
[   213.560] (EE) EnterVT failed for screen 0

This is with systemd 239, linux 4.16.16 from Debian unstable. I have an external screen connected via DP through the thinkpad X230's docking station.
Comment 1 Emilio Pozuelo Monfort 2018-07-03 10:55:23 UTC
Created attachment 140448 [details]
xserver log
Comment 2 Emilio Pozuelo Monfort 2018-07-12 14:57:26 UTC
(In reply to Emilio Pozuelo Monfort from comment #0)
> This is with systemd 239, linux 4.16.16 from Debian unstable. I have an
> external screen connected via DP through the thinkpad X230's docking station.

This doesn't happen when the laptop is undocked (i.e. no external display connected).
Comment 3 GitLab Migration User 2018-12-13 22:40:04 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/542.
Comment 4 Maarten Lankhorst 2019-03-11 09:25:57 UTC
*** Bug 109806 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.