Bug 107156 - earth tessellation bug
Summary: earth tessellation bug
Status: RESOLVED DUPLICATE of bug 107276
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-08 11:35 UTC by ximik
Modified: 2018-07-23 08:57 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
earth tessellation bug (3.24 MB, image/png)
2018-07-08 11:35 UTC, ximik
Details
earth tessellation bug (3.25 MB, image/png)
2018-07-08 11:37 UTC, ximik
Details
earth tessellation bug (3.54 MB, image/png)
2018-07-08 11:38 UTC, ximik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ximik 2018-07-08 11:35:54 UTC
Created attachment 140505 [details]
earth tessellation bug

Some surfaces with tessellation are separated from the earth for some distance. The bug is encountered on the map r290x with the latest open mesa-git driver. the bug appeared in early June, in git driver versions at the end of May there was no bug. apitrace can not be done, Far Cry 5  throws an error too long to load.
Comment 1 ximik 2018-07-08 11:37:26 UTC
Created attachment 140506 [details]
earth tessellation bug
Comment 2 ximik 2018-07-08 11:38:27 UTC
Created attachment 140507 [details]
earth tessellation bug
Comment 3 Timothy Arceri 2018-07-09 00:21:02 UTC
Are you able to do a git bisect to find the commit that caused the issue?
Comment 4 ximik 2018-07-09 13:41:25 UTC
No, in the Arch repository there is only the last  Mesa-git  driver. a rollback to the old version is not possible, and on a stable version of the driver, DXVK does not work.
Comment 5 Timothy Arceri 2018-07-11 23:48:04 UTC
Here are some really quick instructions for building mesa and bisecting the issue.

Get and Build RADV:
-------------------

git clone https://gitlab.freedesktop.org/mesa/mesa.git

cd mesa

sudo dnf builddep mesa (this is how you get the mesa build deps on Fedora not sure how you would do that on Arch)

sudo mkdir /opt/xorg
sudo chown youruserid /opt/xorg

./autogen.sh --prefix=/opt/xorg --with-dri-drivers="" --enable-gles1 --enable-gles2 --enable-shared-glapi --with-gallium-drivers="" --with-vulkan-drivers=radeon --with-egl-platforms=x11,drm  --enable-gbm --enable-glx-tls --enable-dri3

make -j4 && make install

Use your built version of RADV:
-------------------

Add the following to ~/.bashrc and logout and back in (Remember to remove this if you want to switch back to your system version of RADV)

# User specific aliases and functions
export VK_ICD_FILENAMES=/opt/xorg/share/vulkan/icd.d/radeon_icd.x86_64.json

Bisecting the issue:
--------------------

Here is a simple intro to git bisect http://webchick.net/node/99

The hardest part will probably be finding a commit that works. From there it should be straight forward. Maybe start with the 18.1 branchpoint 	6754c2e83d79f93b3a4c8 (that was the end of april)

Good luck.
Comment 6 ximik 2018-07-12 12:42:17 UTC
after installing a stable version of this bug disappeared.
mesa 18.1.3-1
Comment 7 Samuel Pitoiset 2018-07-12 12:51:40 UTC
Really nice, thanks! Closing.
Comment 8 Timothy Arceri 2018-07-12 22:21:33 UTC
(In reply to Samuel Pitoiset from comment #7)
> Really nice, thanks! Closing.

I don't think that's right. I don't think the bug was even in the 18.1 release to begin with going by the dates given in the initial report. ximik are you able to bisect? Is this still a problem in git?
Comment 9 ximik 2018-07-13 08:22:47 UTC
this problem appeared in the git version of the driver in early June. before that I used version 18.0 stable. but DXVK stopped working with it, so I updated to version git. in the middle of May everything was stable. and in late May or early June a bug appeared. Yes, the bug is only in the git version of the driver.
Comment 10 Gregor Münch 2018-07-23 08:57:41 UTC

*** This bug has been marked as a duplicate of bug 107276 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.