Bug 107174 - [CI][SKL][IOMMU] drv_selftests fail with i915: probe of 0000:00:02.0 failed with error -5
Summary: [CI][SKL][IOMMU] drv_selftests fail with i915: probe of 0000:00:02.0 failed w...
Status: CLOSED DUPLICATE of bug 107189
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-10 07:32 UTC by Tomi Sarvela
Modified: 2018-07-18 22:58 UTC (History)
1 user (show)

See Also:
i915 platform: SKL
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomi Sarvela 2018-07-10 07:32:43 UTC
Continuing with the series of "Initial findings" with Intel-GFX-CI and i915 selftests.

SKL with IOMMU enabled fail the following tests with:
i915: probe of 0000:00:02.0 failed with error -5

drv_selftest@live_contexts
drv_selftest@live_evict
drv_selftest@live_execlists
drv_selftest@live_hangcheck
drv_selftest@live_hugepages
drv_selftest@live_objects
drv_selftest@live_requests

Example trace:

[  269.607978] Setting dangerous option live_selftests - tainting kernel
[  269.857336] i915 0000:00:02.0: [drm:i915_gem_init [i915]] Failed to initialize GPU, declaring it wedged!
[  269.965442] i915: probe of 0000:00:02.0 failed with error -5

Full traces:

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4460/fi-skl-iommu/igt@drv_selftest@live_hangcheck.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4460/fi-skl-iommu/igt@drv_selftest@live_sanitycheck.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4460/fi-skl-iommu/igt@drv_selftest@live_objects.html
Comment 1 Chris Wilson 2018-07-10 13:04:44 UTC
Note piglit isn't throwing a hissy fit due to i915 probe failing, but the

i915 0000:00:02.0: [drm:i915_gem_init [i915]] Failed to initialize GPU, declaring it wedged!

which was suppressed in

commit 8cff1f4a3ca58ab426f224b4bd6af61c1a9976ab
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Mon Jul 9 14:48:58 2018 +0100

    drm/i915: Remove function details from device error messages
    
    Error messages are intended to be addressed to the user; be clear,
    succinct, instructive and unambiguous. Adding the function name to
    that message does not add any information the user requires and in
    the process makes the message less clear.
    
    E.g.
    
    [  245.539711] i915 0000:00:02.0: [drm:i915_gem_init [i915]] Failed to initialize GPU, declaring it wedged!
    
    becomes
    
    [  245.539711] i915 0000:00:02.0: Failed to initialize GPU, declaring it wedged!
    
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Acked-by: Rodrigo Vivi <rodrigo.vivi@intel.com>
    Link: https://patchwork.freedesktop.org/patch/msgid/20180709134858.12446-1-chris@chris-wilson.co.uk

So even though we still are flooding dmesg with a KERN_ERR message, piglit isn't flagging anything wrong in dmesg. Go piglit, go!
Comment 2 Chris Wilson 2018-07-11 14:45:12 UTC

*** This bug has been marked as a duplicate of bug 107189 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.