Bug 107258 - [CI][BAT] igt@drv_selftest@live_guc - dmesg-warn - *ERROR* MMIO: GuC action 0x10 failed with error
Summary: [CI][BAT] igt@drv_selftest@live_guc - dmesg-warn - *ERROR* MMIO: GuC action 0...
Status: CLOSED WONTFIX
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Jakub Bartmiński
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-17 08:33 UTC by Martin Peres
Modified: 2018-11-01 18:46 UTC (History)
6 users (show)

See Also:
i915 platform: CFL, KBL
i915 features: firmware/guc


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Chris Wilson 2018-07-17 08:46:34 UTC
The spam is a regression from

commit 13295bd887d07a9d904401808f41a8d35946d8c2
Author: Michal Wajdeczko <michal.wajdeczko@intel.com>
Date:   Mon May 28 17:16:18 2018 +0000

    drm/i915/guc: Don't read SOFT_SCRATCH(15) on MMIO error
    
    SOFT_SCRATCH(15) is used by GuC for sending MMIO GuC events to host and
    those events are now handled by intel_guc_to_host_event_handler_mmio().
    
    We should not try to read it on MMIO action error as 1) we may be using
    different set of registers for GuC MMIO communication, and 2) GuC may
    use CTB mechanism for sending events to host.
    
    While here, upgrade error message to DRM_ERROR.
    
    Signed-off-by: Michal Wajdeczko <michal.wajdeczko@intel.com>
    Cc: Michel Thierry <michel.thierry@intel.com>
    Cc: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
    Cc: Chris Wilson <chris@chris-wilson.co.uk>
    Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Link: https://patchwork.freedesktop.org/patch/msgid/20180528171618.10436-1-michal.wajdeczko@intel.com
Comment 2 Dhinakaran Pandiyan 2018-07-19 20:17:49 UTC
Raising the priority to high as it spams every run.
Comment 3 Dhinakaran Pandiyan 2018-07-19 20:53:46 UTC
*** Bug 107186 has been marked as a duplicate of this bug. ***
Comment 4 Chris Wilson 2018-09-05 10:49:44 UTC
*** Bug 107837 has been marked as a duplicate of this bug. ***
Comment 5 Chris Wilson 2018-09-21 13:58:10 UTC
CI disabled guc submission, so no longer being triggered.
Comment 6 Lakshmi 2018-10-23 12:54:41 UTC
Chris, this issue has occurred again
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5007/fi-apl-guc/igt@drv_selftest@live_guc.html
Comment 7 Chris Wilson 2018-10-23 13:02:31 UTC
The test has been removed so it won't happen again.

commit e346a991f42ca2a397166ac73445832966aa8968
Author: Daniele Ceraolo Spurio <daniele.ceraolospurio@intel.com>
Date:   Wed Oct 17 17:46:05 2018 -0700

    drm/i915/guc: drop negative doorbell alloc selftest


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.