Bug 107324 - Radeon driver fails to install with modprobe: ERROR: could not insert 'radeon': Invalid argument
Summary: Radeon driver fails to install with modprobe: ERROR: could not insert 'radeon...
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2018-07-21 20:00 UTC by jamesstewartmiller
Modified: 2019-11-19 09:33 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

dmesg output with radeon inserted via modprobe (84.79 KB, text/plain)
2018-07-23 07:24 UTC, jamesstewartmiller
no flags Details
results log from ubuntu firmware checking tool (201.94 KB, text/x-log)
2018-07-23 07:26 UTC, jamesstewartmiller
no flags Details

Description jamesstewartmiller 2018-07-21 20:00:48 UTC
Hi, on the following:
Advanced Micro Devices, Inc. [AMD/ATI] RV770/M98L [Mobility Radeon HD 4850]
 on a 2009 imac running kubuntu 18.04 and kde 16.04 and kernel:
I'm having no luck obtaining anything but the vesa driver.
The addition of nomodeset to the kernel parameters (booting from refind with no grub) is necessary to get a graphical desktop.  If I leave modesetting on, the screen blacks out as the mode is changed.  If I turn it off I get the vesa but an error is reported that there is no ums available in the radeon module.
This has occurred on kde neon clean install and kubuntu.

Many thanks.
Comment 1 jamesstewartmiller 2018-07-21 20:08:46 UTC
sudo modprobe radeon gives
modprobe: ERROR: could not insert 'radeon': Invalid argument
I have tried oibaf drivers ppa
and also have compiled a custom rt kernel (for audio use), with no joy.
I have tried removing the hw xorg drivers reinstalling xorg-core, but again, no luck.
Comment 2 jamesstewartmiller 2018-07-22 07:17:52 UTC
I've changed the status to critical since I am unable to load the radeon driver at all.
However, I am getting a report from glxinfo that looks like the radeon driver is loaded, unless it is running in software.
Comment 3 jamesstewartmiller 2018-07-22 07:54:22 UTC
I've attached a separate screen via the displayport, and the radeon driver loads and I get the second monitor as a secondary screen, from which I can access kscreen through the settings dialog and then set as the primary.
Throughout this time, the secondary display is working but is dark in comparison to what I would expect, but the primary screen, the imac, is a black screen except for tear type artefacts like barely visible equidistant lines floating upwards.
I would guess that the edid is reported incorrectly, as the imac screen is reported in the settings dialog as 'laptop'.
I'm going to try obtaining and setting an edid etc now.
Comment 4 jamesstewartmiller 2018-07-22 08:13:29 UTC

*** This bug has been marked as a duplicate of bug 98046 ***
Comment 5 jamesstewartmiller 2018-07-22 14:46:04 UTC
I'm not sure if it is a duplicate or not as it happens of bug 98046
Comment 6 Christian König 2018-07-22 18:02:40 UTC
Please provide a full dmesg output as attachment.

"modprobe: ERROR: could not insert 'radeon': Invalid argument" either means that your hardware isn't supported for some reason or you manually provided an invalid setting.
Comment 7 jamesstewartmiller 2018-07-23 07:24:51 UTC
Created attachment 140775 [details]
dmesg output with radeon inserted via modprobe

dmesg output - I've attempted to modprobe the radeon module, but the module reports that there is no ums.  If I insert it with nomodeset, it fails.
Comment 8 jamesstewartmiller 2018-07-23 07:26:03 UTC
Created attachment 140776 [details]
results log from ubuntu firmware checking tool

This is the output from the ubuntu firmware inspection tool, which includes relevant snippets of kern.log etc
Comment 9 jamesstewartmiller 2018-07-23 07:37:06 UTC
Hey Christian Konig, thanks for all your hard work on the driver, I've been checking bug 98046 which details something similar, and have seen your work on improving the pll code, which I have been examining to see if I can understand more about this situation, but I'm a noob with graphics processing at this level.

James Cameron in discussion on bug 98046 has examined the pll issue and has resorted to forcing the install of kernel 3.13.0-117-generic.  He has traced the bad commit to 32167016076f714f0e35e287fbead7de0f1fb179

I'm afraid I haven't done any git bisecting of kernels etc and don't even know how, yet, to look up what this commit is - I have some reading to do; I'd like to learn.

This is affecting my imac 2009, which for me was some outlay, as I don't work, and with its virtually unchangeable graphics card is really getting my goat, as I'd really been looking forward to using wayland.
Comment 10 Michel Dänzer 2018-07-23 08:11:48 UTC
If the modprobe error happens only when nomodeset is on the kernel command line, that's expected, as the radeon driver cannot work with nomodeset. Sounds like the real issue here is the black screen without nomodeset, which is covered by bug 98046?
Comment 11 Christian König 2018-07-23 14:47:53 UTC
The issue with commit 32167016076f714f0e35e287fbead7de0f1fb179 is that it fixed things quite a bunch of people, but unfortunately also broke things for some other.

So far we tried to mitigate problems by avoiding known to be problematic configurations, but but it is really hard to find documentation for such old hardware.
Comment 12 jamesstewartmiller 2018-07-24 09:04:37 UTC
Is there any way to selectively swap out that portion of the driver for the inoffensive parts of code for the imac (and perhaps other problematic models) that I have?
Is there any point in me investing time to learn to bisect and learn the coding specifics of plls and calculations etc?
At the moment it is either do something like that, or put up with the vesa driver and cope with the memory loss (I use this machine for audio), or swap out the graphics card.
In the last instance, do you know Christian, if it is possible to find a list of affected cards?
I can exchange my radeon 4850 for a 6970M 2GB, increasing the ram, but there is no point at all, if it doesn't work with the radeon driver, and I will have to pick up my game, quite substantially as a programmer, if I want to edit that myself.
Comment 13 Martin Peres 2019-11-19 09:33:57 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/amd/issues/854.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.