Bug 107344 - [CI][BAT] igt@drv_selftest@mock_sanitycheck - dmesg-warn - WARNING: CPU: 1 PID: 4189 at drivers/gpu/drm/drm_mode_config.c:444 drm_mode_config_cleanup
Summary: [CI][BAT] igt@drv_selftest@mock_sanitycheck - dmesg-warn - WARNING: CPU: 1 PI...
Status: CLOSED DUPLICATE of bug 107425
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-23 14:52 UTC by Martin Peres
Modified: 2018-11-01 16:41 UTC (History)
1 user (show)

See Also:
i915 platform: GLK
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-07-23 14:52:02 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4526/fi-glk-j4005/igt@drv_selftest@mock_sanitycheck.html

[  463.780484] WARNING: CPU: 1 PID: 4189 at drivers/gpu/drm/drm_mode_config.c:444 drm_mode_config_cleanup+0x27a/0x2d0
[  463.780490] Modules linked in: i915(-) vgem snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic btusb btrtl btbcm btintel x86_pkg_temp_thermal coretemp bluetooth crct10dif_pclmul crc32_pclmul ghash_clmulni_intel ecdh_generic snd_hda_codec snd_hwdep r8169 snd_hda_core mii snd_pcm mei_me mei prime_numbers i2c_hid pinctrl_geminilake pinctrl_intel [last unloaded: snd_hda_intel]
[  463.780598] CPU: 1 PID: 4189 Comm: drv_selftest Tainted: G     U  W         4.18.0-rc5-CI-CI_DRM_4526+ #1
[  463.780602] Hardware name: Intel Corporation NUC7CJYH/NUC7JYB, BIOS JYGLKCPX.86A.0027.2018.0125.1347 01/25/2018
[  463.780607] RIP: 0010:drm_mode_config_cleanup+0x27a/0x2d0
[  463.780611] Code: 30 00 48 8b 45 00 48 39 c5 75 62 48 8b 44 24 28 65 48 33 04 25 28 00 00 00 75 56 48 83 c4 30 5b 5d 41 5c 41 5d 41 5e 41 5f c3 <0f> 0b 48 89 e6 48 89 ef 48 c7 c3 be f8 0f 82 e8 c2 91 ff ff eb 0c 
[  463.780798] RSP: 0018:ffffc9000049bd78 EFLAGS: 00010287
[  463.780804] RAX: ffff8802616453f0 RBX: ffff8802397008d8 RCX: 0000000000000000
[  463.780808] RDX: ffff880239700880 RSI: ffffffff821284db RDI: 00000000ffffffff
[  463.780811] RBP: ffff880239700000 R08: 00000000581395cb R09: 0000000000000000
[  463.780815] R10: 0000000000000000 R11: 0000000000000000 R12: ffff8802397008e0
[  463.780818] R13: ffffffffa042e8d0 R14: ffff880275daa5a8 R15: ffffffffa042e950
[  463.780823] FS:  00007f5383c22980(0000) GS:ffff88027fc80000(0000) knlGS:0000000000000000
[  463.780826] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  463.780830] CR2: 000055aeb060b840 CR3: 000000023fc34000 CR4: 0000000000340ee0
[  463.780833] Call Trace:
[  463.780944]  intel_modeset_cleanup+0xbf/0x140 [i915]
[  463.781010]  i915_driver_unload+0x98/0x110 [i915]
[  463.781074]  i915_pci_remove+0x19/0x30 [i915]
[  463.781082]  pci_device_remove+0x36/0xb0
[  463.781090]  device_release_driver_internal+0x185/0x250
[  463.781098]  driver_detach+0x35/0x70
[  463.781105]  bus_remove_driver+0x53/0xd0
[  463.781111]  pci_unregister_driver+0x25/0xa0
[  463.781123]  __se_sys_delete_module+0x162/0x210
[  463.781131]  ? do_syscall_64+0xd/0x190
[  463.781138]  do_syscall_64+0x55/0x190
[  463.781146]  entry_SYSCALL_64_after_hwframe+0x49/0xbe
[  463.781151] RIP: 0033:0x7f53834f51b7
[  463.781154] Code: 73 01 c3 48 8b 0d d1 8c 2c 00 f7 d8 64 89 01 48 83 c8 ff c3 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 44 00 00 b8 b0 00 00 00 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d a1 8c 2c 00 f7 d8 64 89 01 48 
[  463.781341] RSP: 002b:00007ffd8d919fb8 EFLAGS: 00000206 ORIG_RAX: 00000000000000b0
[  463.781348] RAX: ffffffffffffffda RBX: 0000000000000000 RCX: 00007f53834f51b7
[  463.781351] RDX: 0000000000000000 RSI: 0000000000000800 RDI: 000055bc47f39d58
[  463.781355] RBP: 000055bc47f39cf0 R08: 00007ffd8d918fb4 R09: 00007ffd8d919ff8
[  463.781358] R10: 00007ffd8d918fb4 R11: 0000000000000206 R12: 000055bc47099750
[  463.781362] R13: 00007ffd8d91a2f0 R14: 0000000000000000 R15: 0000000000000000
[  463.781378] irq event stamp: 119822
[  463.781384] hardirqs last  enabled at (119821): [<ffffffff8193f434>] _raw_spin_unlock_irq+0x24/0x50
[  463.781389] hardirqs last disabled at (119822): [<ffffffff81a0111c>] error_entry+0x7c/0x100
[  463.781395] softirqs last  enabled at (119366): [<ffffffff81c0034f>] __do_softirq+0x34f/0x505
[  463.781401] softirqs last disabled at (119345): [<ffffffff8108c7b9>] irq_exit+0xa9/0xc0
[  463.781406] WARNING: CPU: 1 PID: 4189 at drivers/gpu/drm/drm_mode_config.c:444 drm_mode_config_cleanup+0x27a/0x2d0
[  463.781409] ---[ end trace 874d628dd6f67915 ]---
[  463.781482] [drm:drm_mode_config_cleanup] *ERROR* connector HDMI-A-2 leaked!
Comment 1 Chris Wilson 2018-08-02 12:39:30 UTC

*** This bug has been marked as a duplicate of bug 107425 ***
Comment 2 Martin Peres 2018-11-01 16:41:01 UTC
Used to be seen once every 10 runs, not seen since CI_DRM_4545 (3 months, 1 week / 1319 runs ago).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.