Bug 107359 - [Regression] [bisected] [OpenGL CTS] [SKL,BDW] KHR-GL46.texture_barrier*-texels, GTF-GL46.gtf21.GL2FixedTests.buffer_corners.buffer_corners, and GTF-GL46.gtf21.GL2FixedTests.stencil_plane_corners.stencil_plane_corners fail with some configuration
Summary: [Regression] [bisected] [OpenGL CTS] [SKL,BDW] KHR-GL46.texture_barrier*-texe...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Nanley Chery
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks: mesa-18.2
  Show dependency treegraph
 
Reported: 2018-07-24 12:17 UTC by Andrés Gómez García
Modified: 2018-08-28 21:55 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrés Gómez García 2018-07-24 12:17:05 UTC
After:

--

commit 0288fe8d0417730bdd5b3477130dd1dc32bdbcd3
Author: Nanley Chery <nanley.g.chery@intel.com>
Date:   Wed May 30 16:32:07 2018 -0700

    i965/miptree: Use the correct BLT pitch

    Retile miptrees to a linear tiling less often. Retiling can cause issues
    with imported BOs.

    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=106738
    Suggested-by: Chris Wilson <chris@chris-wilson.co.uk>
    Cc: <mesa-stable@lists.freedesktop.org>
    Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>

--

KHR-GL46.texture_barrier_ARB.disjoint-texels
KHR-GL46.texture_barrier_ARB.overlapping-texels
KHR-GL46.texture_barrier.disjoint-texels
KHR-GL46.texture_barrier.overlapping-texels

Are failing for SKL with the config-gl46-master-cfg-1-run-3-width--1-height-64-seed-3. For example:

--

$ ./glcts --deqp-case=KHR-GL46.texture_barrier.disjoint-texels --deqp-screen-rotation=unspecified --deqp-surface-width=-1 --deqp-surface-height=64 -
-deqp-watchdog=disable --deqp-base-seed=3 --deqp-gl-config-name=rgba8888d24s8 --deqp-surface-type=fbo --deqp-gl-config-id=1 --deqp-gl-context-type=egl

...

Test case 'KHR-GL46.texture_barrier.disjoint-texels'..                                                                                                                                                               Fail (Failed to validate rendering results at gl4cTextureBarrierTests.cpp:468)                                                                                                                                  
                                     
DONE!                                                                         
                                   
Test run totals:                                                         
  Passed:        0/1 (0.0%)
  Failed:        1/1 (100.0%)                                                         
  Not supported: 0/1 (0.0%)           
  Warnings:      0/1 (0.0%)

--

Also:

GTF-GL46.gtf21.GL2FixedTests.buffer_corners.buffer_corners
GTF-GL46.gtf21.GL2FixedTests.stencil_plane_corners.stencil_plane_corners

Are failing for SKL *and BDW* with the config-gl46-gtf-master-cfg-1-run-47-width--1-height-64-seed-3 configuration. For example:

--

$ ./glcts --deqp-case=GTF-GL46.gtf21.GL2FixedTests.stencil_plane_corners.stencil_plane_corners --deqp-screen-rotation=unspecified --deqp-surface-width=-1 --deqp-surface-height=64 --deqp-watchdog=disable --deqp-base-seed=3 --deqp-gl-config-name=rgba8888d24s8 --deqp-surface-type=fbo --deqp-gl-config-id=1 --deqp-gl-context-type=egl                            

...

Test case 'GTF-GL46.gtf21.GL2FixedTests.stencil_plane_corners.stencil_plane_corners'..
#+ Mismatch at the lower right corner.
  Fail (Fail)

DONE!

Test run totals:
  Passed:        0/1 (0.0%)
  Failed:        1/1 (100.0%)
  Not supported: 0/1 (0.0%)
  Warnings:      0/1 (0.0%)

--
Comment 1 Andrés Gómez García 2018-07-24 12:22:15 UTC
Dylan already spotted other regressions at:

https://lists.freedesktop.org/archives/mesa-dev/2018-July/200703.html

And Nanley provided a fix at:

https://patchwork.freedesktop.org/patch/240418/

But I've, checked, and the regressions are still there.
Comment 2 Andrés Gómez García 2018-07-24 12:23:27 UTC
Forgot to mention, the regressions are tested against a docker image in which there is a running X server. I can provide the image in case it is needed.
Comment 3 Andrés Gómez García 2018-07-24 12:24:17 UTC
Also, forgot to mention that the tests are passing for all the other CTS configurations.
Comment 4 Mark Janes 2018-07-24 18:11:37 UTC
these tests pass for me on KBL.  This is surprising, because generally KBL/SKL have identical results on all test suites.
Comment 5 Nanley Chery 2018-07-24 19:01:06 UTC
The tests pass for me on SKL (with the patch on the list). Could you provide more information about your setup?
Comment 6 Andrés Gómez García 2018-07-26 09:34:07 UTC
(In reply to Nanley Chery from comment #5)
> The tests pass for me on SKL (with the patch on the list). Could you provide
> more information about your setup?

Ugh! This is getting tricky.

I've created an Ubuntu Xenial based docker image that you can use. You can try directly with:

--

$ docker run --privileged -t --rm -e DISPLAY=unix$DISPLAY -v /tmp/.X11-unix:/tmp/.X11-unix igalia/mesa:vk-gl-cts.opengl-cts-4.6.0.cl.nanley-fix-upstream /bin/bash -c "export MESA_GLSL_VERSION_OVERRIDE=460; export MESA_GL_VERSION_OVERRIDE=4.6; cd /home/local/vk-gl-cts/build/external/openglcts/modules; ./glcts --deqp-case=KHR-GL46.texture_barrier.disjoint-texels --deqp-screen-rotation=unspecified --deqp-surface-width=-1 --deqp-surface-height=64 --deqp-watchdog=disable --deqp-base-seed=3 --deqp-gl-config-name=rgba8888d24s8 --deqp-surface-type=fbo --deqp-gl-config-id=1 --deqp-gl-context-type=egl"

--

Or, if you want to get into the image and see what's going on ...

--

$ docker run --privileged --rm -it -v $HOME/.ccache:/home/local/.ccache:Z -e DISPLAY=unix$DISPLAY -v /tmp/.X11-unix:/tmp/.X11-unix igalia/mesa:vk-gl-cts.opengl-cts-4.6.0.cl.nanley-fix-upstream /bin/bash
local@81260a497ee5:~/vk-gl-cts/build$ export MESA_GLSL_VERSION_OVERRIDE=460; export MESA_GL_VERSION_OVERRIDE=4.6; cd /home/local/vk-gl-cts/build/external/openglcts/modules
local@81260a497ee5:~/vk-gl-cts/build/external/openglcts/modules$ ./glcts --deqp-case=KHR-GL46.texture_barrier.disjoint-texels --deqp-screen-rotation=unspecified --deqp-surface-width=-1 --deqp-surface-height=64 --deqp-watchdog=disable --deqp-base-seed=3 --deqp-gl-config-name=rgba8888d24s8 --deqp-surface-type=fbo --deqp-gl-config-id=1 --deqp-gl-context-type=egl

--

Mesa source code is at /home/local/mesa and is quite close to current master. Latest commit is "b3b170ade9cc3abe6b861a549292c9ec230844bc" and, then, your proposed fix on top.

VK-GL-CTS source code is at /home/local/vk-gl-cts, using the "opengl-cts-4.6.0" branch. Latest commit is "7e3cd2412d640ca8e8e1db9362c32e75a91d5235".

You will need a running X server in the host system. Mine is a Debian Testing with Linux kernel 4.16.0-2-amd64, xserver-xorg-core 2:1.20.0-3 and xserver-xorg-video-intel 2:2.99.917+git20171229-1+b1.

Notice that the "local" user inside the docker image has uid 1000. That is relevant, at least, for the mounted ccache directory in case you want to compile something.
Comment 7 Nanley Chery 2018-07-27 19:00:11 UTC
I was able to reproduce the issue in the docker image and on my BDW NUC running Arch. 

The issue is present for width sizes 16383px and 16384px specifically.
Comment 8 Nanley Chery 2018-07-27 23:05:02 UTC
A fix is on the list: https://patchwork.freedesktop.org/patch/241419/

This has been tested to work on BDW. Does this fix the issues on your SKL?
Comment 9 Andrés Gómez García 2018-07-30 16:27:11 UTC
(In reply to Nanley Chery from comment #8)
> A fix is on the list: https://patchwork.freedesktop.org/patch/241419/
> 
> This has been tested to work on BDW. Does this fix the issues on your SKL?

Tested, and I can confirm this patch fixes the problems listed for SKL and BDW.

Great job, Nanely! :)
Comment 10 Andrés Gómez García 2018-08-09 10:33:03 UTC
Ugh! Unfortunately this patch is causing other regressions in GTF tests in SKL:


---


$ ./glcts --deqp-case=GTF-GL46.gtf30.GL3Tests.framebuffer_blit.framebuffer_blit_error_blitframebuffer_multisampled_* --deqp-screen-rotation=unspecified --deqp-surface-width=-1 --deqp-surface-height=64 --deqp-watchdog=disable --deqp-base-seed=3 --deqp-gl-config-name=rgba8888d24s8 --deqp-surface-type=fbo --deqp-gl-config-id=1 --deqp-gl-context-type=egl

Writing test log into TestResults.qpa                                                                                                                                    dEQP Core git-50efa56946494c608d71333832e50cd9f519e371 (0x50efa569) starting..                                                                                          
  target implementation = 'X11 EGL'                                                                                                                                      ATTENTION: default value of option vblank_mode overridden by environment.                                                                                               
                                                                                                                                                                         Test case 'GTF-GL46.gtf30.GL3Tests.framebuffer_blit.framebuffer_blit_error_blitframebuffer_multisampled_read_buffer_different_sizes'..                                  
INFO:framebuffer_blit_error_blitframebuffer_multisampled_read_buffer_different_sizes:Default framebuffer is not multisampled, skip!                                      
ERROR:framebuffer_blit_error_blitframebuffer_multisampled_read_buffer_different_sizes:glCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF
/Source/GL3Tests/GTFTestFramebufferBlit.c:1785: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT                                            
ERROR:framebuffer_blit_error_blitframebuffer_multisampled_read_buffer_different_sizes:glBlitFramebuffer: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source
/GL3Tests/GTFTestFramebufferBlit.c:5292: expected GL_INVALID_OPERATION but got GL_INVALID_FRAMEBUFFER_OPERATION                                                          ERROR:framebuffer_blit_error_blitframebuffer_multisampled_read_buffer_different_sizes:glCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF
/Source/GL3Tests/GTFTestFramebufferBlit.c:1842: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT                                            ERROR:framebuffer_blit_error_blitframebuffer_multisampled_read_buffer_different_sizes:glBlitFramebuffer: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source
/GL3Tests/GTFTestFramebufferBlit.c:5292: expected GL_INVALID_OPERATION but got GL_INVALID_FRAMEBUFFER_OPERATION                                                            Fail (Fail)     


[...]



Test case 'GTF-GL46.gtf30.GL3Tests.framebuffer_blit.framebuffer_blit_error_blitframebuffer_multisampled_framebuffers_different_formats'..                               
INFO:framebuffer_blit_error_blitframebuffer_multisampled_framebuffers_different_formats:Default framebuffer is not multisampled, skip!                                  
ERROR:framebuffer_blit_error_blitframebuffer_multisampled_framebuffers_different_formats:glCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Tests/GTFTestFramebufferBlit.c:1785: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT                                        
ERROR:framebuffer_blit_error_blitframebuffer_multisampled_framebuffers_different_formats:glCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Tests/GTFTestFramebufferBlit.c:1785: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT                                        
ERROR:framebuffer_blit_error_blitframebuffer_multisampled_framebuffers_different_formats:glBlitFramebuffer: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Tests/GTFTestFramebufferBlit.c:5877: expected ZERO/GL_FALSE/GL_NO_ERROR but got GL_INVALID_FRAMEBUFFER_OPERATION                                                 
ERROR:framebuffer_blit_error_blitframebuffer_multisampled_framebuffers_different_formats:glCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Tests/GTFTestFramebufferBlit.c:1842: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT                                        
ERROR:framebuffer_blit_error_blitframebuffer_multisampled_framebuffers_different_formats:glCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Tests/GTFTestFramebufferBlit.c:1842: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT                                        
ERROR:framebuffer_blit_error_blitframebuffer_multisampled_framebuffers_different_formats:glBlitFramebuffer: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Tests/GTFTestFramebufferBlit.c:5877: expected ZERO/GL_FALSE/GL_NO_ERROR but got GL_INVALID_FRAMEBUFFER_OPERATION                                                 
  Fail (Fail)

DONE!

Test run totals:
  Passed:        0/7 (0.0%)
  Failed:        7/7 (100.0%)
  Not supported: 0/7 (0.0%)
  Warnings:      0/7 (0.0%)



---



$ ./glcts --deqp-case=GTF-GL46.gtf30.GL3Tests.framebuffer_blit.framebuffer_blit_functionality_m[7661/9337]
_to_singlesampled_blit --deqp-screen-rotation=unspecified --deqp-surface-width=-1 --deqp-surface-height=64 --deqp-watchdog=disable --deqp-base-seed=3 --deqp-gl-config-na
me=rgba8888d24s8 --deqp-surface-type=fbo --deqp-gl-config-id=1 --deqp-gl-context-type=egl                                                                                
Writing test log into TestResults.qpa                                                                                                                                    
dEQP Core git-50efa56946494c608d71333832e50cd9f519e371 (0x50efa569) starting..                                                                                           
  target implementation = 'X11 EGL'                                                                                                                                      
ATTENTION: default value of option vblank_mode overridden by environment.                                                                                                
                                                                                                                                                                         
Test case 'GTF-GL46.gtf30.GL3Tests.framebuffer_blit.framebuffer_blit_functionality_multisampled_to_singlesampled_blit'..                                                 
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:BEGIN ------------------------------------------------------------------                          
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:BLITTING in GL_COLOR_ATTACHMENT0 from GL_TEXTURE_2D to GL_TEXTURE_2D                              
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:[GL_R8] buffers                                                                                   
ERROR:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:glwCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Te
sts/GTFTestFramebufferBlit.c:639: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT                                                          
ERROR:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:glwCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Te
sts/GTFTestFramebufferBlit.c:639: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT                                                          
ERROR:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:glwCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Te
sts/GTFTestFramebufferBlit.c:639: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT                                                          
ERROR:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:glwCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Te
sts/GTFTestFramebufferBlit.c:639: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT                                                          
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:verifying initial texbuf2 color [0.000000,0.000000,0.000000,1.000000]                             
ERROR:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:glCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Tes
ts/GTFTestFramebufferBlit.c:6961: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT                                                          
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:BEGIN ------------------------------------------------------------------
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:BLITTING in GL_COLOR_ATTACHMENT0 from GL_TEXTURE_2D to GL_TEXTURE_2D
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:[GL_RG8] buffers
ERROR:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:glwCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Te
sts/GTFTestFramebufferBlit.c:639: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT
ERROR:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:glwCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Te
sts/GTFTestFramebufferBlit.c:639: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT
ERROR:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:glwCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Te
sts/GTFTestFramebufferBlit.c:639: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT
ERROR:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:glwCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Te
sts/GTFTestFramebufferBlit.c:639: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:verifying initial texbuf4 color [0.000000,0.000000,0.000000,1.000000]
ERROR:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:glCheckFramebufferStatus: /home/local/vk-gl-cts/external/kc-cts/src/GTF_ES/glsl/GTF/Source/GL3Tes
ts/GTFTestFramebufferBlit.c:6961: expected GL_FRAMEBUFFER_COMPLETE but got GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT



[...]



INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:BEGIN ------------------------------------------------------------------
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:[GL_DEPTH24_STENCIL8] buffers
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled texbuf1097
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled texbuf1097
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled texbuf1097
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled texbuf1097
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:verifying initial dfltbuf depth [0.000000]
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled texbuf1097
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled texbuf1097
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled texbuf1097
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled texbuf1097
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:verifying initial dfltbuf stencil [0]
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:BLITTING in GL_DEPTH_STENCIL_ATTACHMENT from GL_TEXTURE_2D to DEFAULT
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:BLIT -------------------------------------------------------------------
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:BLIT SRC_RECT=[0,0,16384,64] DST_RECT=[0,0,16384,64]
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:END --------------------------------------------------------------------
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:BEGIN ------------------------------------------------------------------
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:[GL_DEPTH24_STENCIL8] buffers
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled renbuf1101
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled renbuf1101
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled renbuf1101
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled renbuf1101
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:verifying initial dfltbuf depth [0.000000]
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled renbuf1101
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled renbuf1101
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled renbuf1101
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:no verification of multisampled renbuf1101
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:verifying initial dfltbuf stencil [0]
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:BLITTING in GL_DEPTH_STENCIL_ATTACHMENT from GL_RENDERBUFFER to DEFAULT
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:BLIT -------------------------------------------------------------------
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:BLIT SRC_RECT=[0,0,16384,64] DST_RECT=[0,0,16384,64]
INFO:framebuffer_blit_functionality_multisampled_to_singlesampled_blit:END --------------------------------------------------------------------
  Fail (Fail)

DONE!

Test run totals:
  Passed:        0/1 (0.0%)
  Failed:        1/1 (100.0%)
  Not supported: 0/1 (0.0%)
  Warnings:      0/1 (0.0%)
Comment 11 Nanley Chery 2018-08-17 21:29:13 UTC
A new series is on the list to fix the recently reported issue:
https://lists.freedesktop.org/archives/mesa-dev/2018-August/202275.html
Comment 12 Nanley Chery 2018-08-20 21:10:41 UTC
A v3 is now on the list which incorporates review feedback given on IRC: https://patchwork.freedesktop.org/series/48461/
Comment 13 Andrés Gómez García 2018-08-22 12:22:21 UTC
(In reply to Nanley Chery from comment #11)
> A new series is on the list to fix the recently reported issue:
> https://lists.freedesktop.org/archives/mesa-dev/2018-August/202275.html

I've been able to test this (v2) series and I can confirm the problems have gone away.

I hope to be able to check v3 by next week but, if there are not real changes from v2, it's good to go.
Comment 14 Nanley Chery 2018-08-22 20:57:22 UTC
The 3-patch series has been pushed upstream. The ending commit is:

commit 6d80b0b4bae53efbfa4b654a44c6279f5cc9402c
Author: Nanley Chery <nanley.g.chery@intel.com>
Date:   Fri Jul 27 15:34:05 2018 -0700

    intel/isl: Avoid tiling some 16K-wide render targets

[...]

Thank you for the bug report.
Comment 15 Andrés Gómez García 2018-08-28 21:55:54 UTC
Just FTR, I can confirm the landed v3 3 patches series has corrected the regression.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.