Bug 107603 - [CI][BAT] RIP: 0010:hsw_enable_pc8
Summary: [CI][BAT] RIP: 0010:hsw_enable_pc8
Status: CLOSED DUPLICATE of bug 106386
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-17 10:50 UTC by Tomi Sarvela
Modified: 2019-03-08 15:19 UTC (History)
1 user (show)

See Also:
i915 platform: BDW, HSW
i915 features: power/suspend-resume


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomi Sarvela 2018-08-17 10:50:40 UTC
Hosts: BDW, HSW

Test: igt@pm_rpm@module-reload

[  396.421895] ------------[ cut here ]------------
[  396.421901] PCH PWM1 enabled
[  396.422060] WARNING: CPU: 1 PID: 39 at drivers/gpu/drm/i915/intel_display.c:8988 hsw_enable_pc8+0x613/0x680 [i915]
[  396.422067] Modules linked in: snd_hda_intel i915 vgem snd_hda_codec_hdmi x86_pkg_temp_thermal coretemp crct10dif_pclmul crc32_pclmul ghash_clmulni_intel ax88179_178a usbnet mii snd_hda_codec snd_hwdep snd_hda_core snd_pcm mei_me mei prime_numbers lpc_ich btusb btrtl btbcm btintel bluetooth ecdh_generic [last unloaded: i915]
[  396.422213] CPU: 1 PID: 39 Comm: kworker/1:1 Tainted: G     U            4.18.0-CI-CI_DRM_4684+ #1
[  396.422219] Hardware name: GOOGLE Samus/Samus, BIOS MrChromebox 02/04/2018
[  396.422231] Workqueue: pm pm_runtime_work
[  396.422356] RIP: 0010:hsw_enable_pc8+0x613/0x680 [i915]
[  396.422361] Code: ff e8 51 c8 af e0 0f 0b e9 a1 fa ff ff e8 45 c8 af e0 0f 0b e9 f6 fb ff ff e8 39 c8 af e0 0f 0b e9 c9 fb ff ff e8 2d c8 af e0 <0f> 0b e9 9c fb ff ff e8 21 c8 af e0 0f 0b e9 df fb ff ff e8 15 c8 
[  396.422666] RSP: 0018:ffffc9000015fd00 EFLAGS: 00010286
[  396.422677] RAX: 0000000000000000 RBX: ffff880425810000 RCX: 0000000000000001
[  396.422683] RDX: 0000000080000001 RSI: ffffffff820c761c RDI: 00000000ffffffff
[  396.422689] RBP: ffff880425810900 R08: 000000001cb2d607 R09: 0000000000000000
[  396.422695] R10: 0000000000000000 R11: 0000000000000000 R12: ffff880425810910
[  396.422701] R13: ffff88046bcf8008 R14: 0000000000000000 R15: 0000000000000008
[  396.422709] FS:  0000000000000000(0000) GS:ffff88047ec80000(0000) knlGS:0000000000000000
[  396.422715] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  396.422722] CR2: 000056461e495eb0 CR3: 0000000005210005 CR4: 00000000003606e0
[  396.422727] Call Trace:
[  396.422817]  intel_runtime_suspend+0x114/0x230 [i915]
[  396.422832]  pci_pm_runtime_suspend+0x57/0x170
[  396.422845]  ? pci_pm_runtime_resume+0xa0/0xa0
[  396.422855]  __rpm_callback+0xb3/0x1b0
[  396.422865]  ? pci_pm_runtime_resume+0xa0/0xa0
[  396.422878]  rpm_callback+0x1a/0x70
[  396.422887]  ? pci_pm_runtime_resume+0xa0/0xa0
[  396.422897]  rpm_suspend+0x125/0x6d0
[  396.422919]  pm_runtime_work+0x9b/0xb0
[  396.422933]  process_one_work+0x248/0x6c0
[  396.422957]  worker_thread+0x37/0x380
[  396.422973]  ? process_one_work+0x6c0/0x6c0
[  396.422981]  kthread+0x119/0x130
[  396.422991]  ? kthread_flush_work_fn+0x10/0x10
[  396.423007]  ret_from_fork+0x3a/0x50
[  396.423036] irq event stamp: 7282716
[  396.423047] hardirqs last  enabled at (7282715): [<ffffffff810f8c5c>] console_unlock+0x3fc/0x600
[  396.423057] hardirqs last disabled at (7282716): [<ffffffff81a0111c>] error_entry+0x7c/0xf0
[  396.423066] softirqs last  enabled at (7282508): [<ffffffff81c0034f>] __do_softirq+0x34f/0x505
[  396.423076] softirqs last disabled at (7282491): [<ffffffff8108c8a5>] irq_exit+0xa5/0xc0
[  396.423200] WARNING: CPU: 1 PID: 39 at drivers/gpu/drm/i915/intel_display.c:8988 hsw_enable_pc8+0x613/0x680 [i915]
[  396.423206] ---[ end trace 2c05d3662d7824f1 ]---
[  401.706979] snd_hda_intel 0000:00:03.0: HSW/BDW HD-audio HDMI/DP requires binding with gfx driver
[  405.802843] ------------[ cut here ]------------
[  405.802852] PCH PWM1 enabled
[  405.803081] WARNING: CPU: 1 PID: 39 at drivers/gpu/drm/i915/intel_display.c:8988 hsw_enable_pc8+0x613/0x680 [i915]
[  405.803092] Modules linked in: snd_hda_intel i915 vgem snd_hda_codec_hdmi x86_pkg_temp_thermal coretemp crct10dif_pclmul crc32_pclmul ghash_clmulni_intel ax88179_178a usbnet mii snd_hda_codec snd_hwdep snd_hda_core snd_pcm mei_me mei prime_numbers lpc_ich btusb btrtl btbcm btintel bluetooth ecdh_generic [last unloaded: i915]
[  405.803290] CPU: 1 PID: 39 Comm: kworker/1:1 Tainted: G     U  W         4.18.0-CI-CI_DRM_4684+ #1
[  405.803296] Hardware name: GOOGLE Samus/Samus, BIOS MrChromebox 02/04/2018
[  405.803308] Workqueue: pm pm_runtime_work
[  405.803433] RIP: 0010:hsw_enable_pc8+0x613/0x680 [i915]
[  405.803440] Code: ff e8 51 58 e1 e0 0f 0b e9 a1 fa ff ff e8 45 58 e1 e0 0f 0b e9 f6 fb ff ff e8 39 58 e1 e0 0f 0b e9 c9 fb ff ff e8 2d 58 e1 e0 <0f> 0b e9 9c fb ff ff e8 21 58 e1 e0 0f 0b e9 df fb ff ff e8 15 58 
[  405.803777] RSP: 0018:ffffc9000015fd00 EFLAGS: 00010286
[  405.803788] RAX: 0000000000000000 RBX: ffff880420f10000 RCX: 0000000000000001
[  405.803795] RDX: 0000000080000001 RSI: ffffffff820c761c RDI: 00000000ffffffff
[  405.803801] RBP: ffff880420f10900 R08: 000000001cb2d607 R09: 0000000000000000
[  405.803808] R10: 0000000000000000 R11: 0000000000000000 R12: ffff880420f10910
[  405.803814] R13: ffffffffa031a95f R14: 0000000000000000 R15: 0000000000000008
[  405.803821] FS:  0000000000000000(0000) GS:ffff88047ec80000(0000) knlGS:0000000000000000
[  405.803828] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  405.803834] CR2: 000056461e495eb0 CR3: 0000000005210005 CR4: 00000000003606e0
[  405.803839] Call Trace:
[  405.803933]  intel_runtime_suspend+0x114/0x230 [i915]
[  405.803949]  pci_pm_runtime_suspend+0x57/0x170
[  405.803963]  ? pci_pm_runtime_resume+0xa0/0xa0
[  405.803972]  __rpm_callback+0xb3/0x1b0
[  405.803983]  ? pci_pm_runtime_resume+0xa0/0xa0
[  405.803996]  rpm_callback+0x1a/0x70
[  405.804005]  ? pci_pm_runtime_resume+0xa0/0xa0
[  405.804015]  rpm_suspend+0x125/0x6d0
[  405.804038]  pm_runtime_work+0x6e/0xb0
[  405.804052]  process_one_work+0x248/0x6c0
[  405.804076]  worker_thread+0x37/0x380
[  405.804092]  ? process_one_work+0x6c0/0x6c0
[  405.804100]  kthread+0x119/0x130
[  405.804111]  ? kthread_flush_work_fn+0x10/0x10
[  405.804127]  ret_from_fork+0x3a/0x50
[  405.804156] irq event stamp: 7292318
[  405.804168] hardirqs last  enabled at (7292317): [<ffffffff810f8c5c>] console_unlock+0x3fc/0x600
[  405.804178] hardirqs last disabled at (7292318): [<ffffffff81a0111c>] error_entry+0x7c/0xf0
[  405.804187] softirqs last  enabled at (7292240): [<ffffffff81c0034f>] __do_softirq+0x34f/0x505
[  405.804197] softirqs last disabled at (7292233): [<ffffffff8108c8a5>] irq_exit+0xa5/0xc0
[  405.804317] WARNING: CPU: 1 PID: 39 at drivers/gpu/drm/i915/intel_display.c:8988 hsw_enable_pc8+0x613/0x680 [i915]
[  405.804324] ---[ end trace 2c05d3662d7824f2 ]---


https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4606/fi-bdw-samus/igt@pm_rpm@module-reload.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4685/fi-hsw-4200u/igt@pm_rpm@module-reload.html
Comment 1 Chris Wilson 2018-08-31 14:05:24 UTC
Fwiw, Imre mentioned that this was likely from not setting up eDP (due to i915.disable_display=1).
Comment 2 Chris Wilson 2018-09-14 20:49:17 UTC

*** This bug has been marked as a duplicate of bug 106386 ***
Comment 3 CI Bug Log 2019-03-08 15:19:01 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.