Bug 107610 - Dolphin emulator mis-renders shadow overlay in Super Mario Sunshine
Summary: Dolphin emulator mis-renders shadow overlay in Super Mario Sunshine
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-18 12:01 UTC by Christopher Snowhill
Modified: 2018-08-22 11:58 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Snowhill 2018-08-18 12:01:06 UTC
Running Dolphin emulator from dolphin-emu-master PPA, (and the latest (201808170730) build from https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers, I encounter this issue with the shadow overlay on Delfino Plaza. I'm linking to both a video and an archived vktrace file.

https://youtu.be/A3QHuRbXtgI

https://f.losno.co/dolphin-emu-vktrace.7z

System:

Intel Core i7 3770
AMD Radeon RX480 8GB
Ubuntu 18.04.1
Cinnamon 3.6.7

kernel: 4.15.0-32.35-generic
dolphin-emu-master: 5.0+git-r201808180901-12a5fd8-33~ubuntu18.04.1
mesa-vulkan-drivers: 18.3~git1808170730.de3b34~oibaf~b
Comment 1 Samuel Pitoiset 2018-08-20 09:40:37 UTC
Can you record a renderdoc trace instead please?
Comment 2 Christopher Snowhill 2018-08-21 04:14:44 UTC
Would that depend on the GPU installed? I kind of pulled that one out after a 6GB memtestCL caused the whole GPU to lock up. I also experienced a Spotify rendering glitch:

https://imgur.com/a/TlCCio2

I can put it back in and perform the trace, if it’s necessary for this bug report.
Comment 3 Christopher Snowhill 2018-08-21 06:44:25 UTC
Here you go, but it's from a later point in the game, and I don't know if it still triggers the issue.

https://f.losno.co/delfino-plaza.rdc.xz
Comment 4 Samuel Pitoiset 2018-08-21 06:53:49 UTC
According to renderdoc logs you recorded the trace on NVIDIA, is that expected? The trace is incompatible.
Comment 5 Christopher Snowhill 2018-08-21 21:54:36 UTC
And I can't report it on AMD because I removed the card. I can reinstall it if it's absolutely necessary. I really hate constantly swapping my video card out.
Comment 6 Christopher Snowhill 2018-08-21 22:15:22 UTC
Okay, here you go, I was still able to reproduce the effect on AMD:

https://f.losno.co/delfino-plaza-amd.tar.xz
Comment 7 Samuel Pitoiset 2018-08-22 07:33:04 UTC
Thanks for trace, apparently the issue can't be reproduced with mesa 18.1.6 so it's likely a regression.
Comment 8 Samuel Pitoiset 2018-08-22 10:33:10 UTC
https://patchwork.freedesktop.org/series/48549/
Comment 9 Samuel Pitoiset 2018-08-22 11:58:12 UTC
Should be fixed with https://cgit.freedesktop.org/mesa/mesa/commit/?id=24ee53231da84a1be5ec08abebe8a2ff6aa019ca

Thanks for providing the trace!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.