Bug 107651 - Assertion in intel_batchbuffer.c aborts startup of xorg-server
Summary: Assertion in intel_batchbuffer.c aborts startup of xorg-server
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-21 20:29 UTC by ad PC
Modified: 2019-07-05 05:39 UTC (History)
1 user (show)

See Also:
i915 platform: BDW
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ad PC 2018-08-21 20:29:39 UTC
The following assertion aborts the startup of xorg-server:

Xorg: ../mesa-18.2.0-rc2/src/mesa/drivers/dri/i965/intel_batchbuffer.c:724: execbuffer: Assertion `!(bo->kflags & EXEC_OBJECT_PINNED)' failed.

Here the output of `lcpci -vv`:

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09) (prog-if 00 [VGA controller])
	DeviceName:  Onboard IGD
	Subsystem: Dell HD Graphics 5500
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 43
	Region 0: Memory at f6000000 (64-bit, non-prefetchable) [size=16M]
	Region 2: Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Region 4: I/O ports at f000 [size=64]
	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: i915

Please let me know, if you need further info.
Comment 1 Kenneth Graunke 2018-08-22 06:32:36 UTC
Yeah, that's pretty severely broken...what kernel are you using?
Comment 2 ad PC 2018-08-22 18:34:25 UTC
My kernel is 4.9.24-hardened. Should I try 4.18.0, for example?
Comment 3 Lionel Landwerlin 2018-12-12 11:54:36 UTC
(In reply to ad PC from comment #2)
> My kernel is 4.9.24-hardened. Should I try 4.18.0, for example?

Yes, if you can't reproduce on a more recent kernel, we can reassign to the i915 kernel driver. Thanks!
Comment 4 Lionel Landwerlin 2018-12-12 12:48:29 UTC
I could be wrong, but I think this issue might have been fixed by :

commit 172ae5b4c8c104af56804bf2406014849ed6fa37
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Mon Dec 5 14:29:37 2016 +0000

    drm/i915: Fix i915_gem_evict_for_vma (soft-pinning)


Unfortunately, this commit doesn't look like it made it to 4.9 :(

Could the i915 team look into whether this needs to happen?
Comment 5 ad PC 2019-05-26 15:20:03 UTC
I cannot reproduce it on a more recent kernel (e.g. 4.20.13 or 5.1.4). So it seems to be fixed there.
Comment 6 Lakshmi 2019-06-05 08:25:01 UTC
Reporter, if this issue is not seen on latest kernel, can I close this bug?
Comment 7 ad PC 2019-07-03 16:55:40 UTC
Yes We Can ;-)
Comment 8 Lakshmi 2019-07-05 05:39:16 UTC
Based on the feedback closing this issue as WORKSFORME.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.