Bug 107663 - APL: FIFO underrun observed when a 4k external monitor is connected through usb type-c to HDMI adapter
Summary: APL: FIFO underrun observed when a 4k external monitor is connected through u...
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged, ReadyForDev
Keywords:
Depends on:
Blocks: 105980
  Show dependency treegraph
 
Reported: 2018-08-23 11:44 UTC by Raviraj Sitaram
Modified: 2019-04-15 11:58 UTC (History)
2 users (show)

See Also:
i915 platform: BXT
i915 features: display/Other


Attachments
drm log (83.66 KB, text/x-log)
2018-08-23 11:44 UTC, Raviraj Sitaram
no flags Details
Hot plugging from boot up (569.26 KB, application/octet-stream)
2018-10-22 11:48 UTC, Sudarshan Srinivasan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Raviraj Sitaram 2018-08-23 11:44:37 UTC
Created attachment 141247 [details]
drm log

1. Boot APL device. 
2. Connect a 4k external monitor to the APL device through usb typeC to HDMI 
   adapter

Expected: No underrun errors to be observed

Observed: Underrun is observed during hotplug.

Attached is the captured drm log.

adapter used for the testing can be found from url: https://store.google.com/product/usb_type_c_to_hdmi_adapter
Comment 1 James Ausmus 2018-08-23 21:13:28 UTC
Hi Raviraj-

Please try to reproduce the error using drm-tip (https://cgit.freedesktop.org/drm-tip) and kernel parameters drm.debug=0x1e log_buf_len=4M, and if the problem persists attach the full dmesg from boot.
Comment 2 Lakshmi 2018-10-11 15:14:24 UTC
No feedback from more than a month.
closing as resolved works for me.

Please re-open if issue persists with latest drm-tip https://cgit.freedesktop.org/drm-tip 

Send dmesg from boot with kernel parameters drm.debug=0x1e log_buf_len=4M?
Comment 3 Sudarshan Srinivasan 2018-10-22 11:48:41 UTC
Created attachment 142136 [details]
Hot plugging from boot up

Logs captured with drm.debug=0x1e and log_buf_len = 4M 
kernel version :
Linux localhost 4.19.0-rc7-78904-ga9abc43bebfb #1 SMP PREEMPT Mon Oct 22 10:52:04 IST 2018 x86_64 Intel(R) Celeron(R) CPU N3450 @ 1.10GHz GenuineIntel GNU/Linux
Comment 4 Lakshmi 2019-02-26 08:52:44 UTC
(In reply to Sudarshan Srinivasan from comment #3)
> Created attachment 142136 [details]
> Hot plugging from boot up
> 
> Logs captured with drm.debug=0x1e and log_buf_len = 4M 
> kernel version :
> Linux localhost 4.19.0-rc7-78904-ga9abc43bebfb #1 SMP PREEMPT Mon Oct 22
> 10:52:04 IST 2018 x86_64 Intel(R) Celeron(R) CPU N3450 @ 1.10GHz
> GenuineIntel GNU/Linux

Can you verify this issue with latest drmtip?
Apart from the error in the log, is there any other issues you notice, asking this to understand the severity of this bug.
Comment 5 Lakshmi 2019-04-15 11:58:53 UTC
Dmesg from Latest drmtip is needed to investigate this issue further. 
If this issue occurs on drmtip, please also explain what is the impact apart from error in the log. Remember to attach dmesg from boot.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.