Bug 107668 - Blank screen (Cannot find any crtc or sizes) since Kernel 4.17 (AMDGPU.DC) on Amd Radeon RX460 on HDMI LG Ultrawidescreen Monitor
Summary: Blank screen (Cannot find any crtc or sizes) since Kernel 4.17 (AMDGPU.DC) on...
Status: NEW
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-23 23:11 UTC by Naheem Zaffar
Modified: 2019-02-23 16:35 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Dmesg from boot with Kernel 4.19 prerelease (77.35 KB, text/x-log)
2018-08-23 23:11 UTC, Naheem Zaffar
no flags Details
Dmesg output with amdgpu.dc=0 (82.27 KB, text/plain)
2018-08-23 23:12 UTC, Naheem Zaffar
no flags Details
Log messages from Gnome Logs for boot with blank screen (105.88 KB, text/plain)
2018-08-27 17:14 UTC, Naheem Zaffar
no flags Details
Dmesg outut with latest build from Kernel 4.21 pre-release series (81.74 KB, text/x-log)
2019-01-05 16:24 UTC, Naheem Zaffar
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Naheem Zaffar 2018-08-23 23:11:54 UTC
Created attachment 141265 [details]
Dmesg from boot with Kernel 4.19  prerelease

I have already reported this on Redhat Bugzilla, so if more information is needed, that may be a good place to look at comments: https://bugzilla.redhat.com/show_bug.cgi?id=1594488

Since the change to using dc in the kernel I am getting a blank screen with trying to boot my ultrawidescreen monitor.

As a workaround I can use amdgpu.dc=0, but this hits al earlier big where at native resolution the display output is garbled (links in Redhat Bugzilla attach to another big report, youtube video of the same).

I am attaching dmesg output from 4.19.0-0.rc0.git8.1.vanilla.knurd.1.fc28.x86_64 with and without amdgpu.dc=0

I have noticed a couple of entries in the dmesg without the amdgpu.dc=0:

kernel: [drm] add ip block number 4 <dm>

with amdgpu.dc=0 it is:

kernel: [drm] add ip block number 4 <dce_v11_0>

The other ip address block entries are identical.

with amdgpu.dc=0 I get this section:

Aug 22 23:46:22 kernel: [drm] PCIE GART of 256M enabled (table at 0x000000F400900000).
Aug 22 23:46:22 kernel: [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
Aug 22 23:46:22 kernel: [drm] Driver supports precise vblank timestamp query.
Aug 22 23:46:22 kernel: [drm] AMDGPU Display Connectors
Aug 22 23:46:22 kernel: [drm] Connector 0:
Aug 22 23:46:22 kernel: [drm]   DP-1
Aug 22 23:46:22 kernel: [drm]   HPD5
Aug 22 23:46:22 kernel: [drm]   DDC: 0x4868 0x4868 0x4869 0x4869 0x486a 0x486a 0x486b 0x486b
Aug 22 23:46:22 kernel: [drm]   Encoders:
Aug 22 23:46:22 kernel: [drm]     DFP1: INTERNAL_UNIPHY1
Aug 22 23:46:22 kernel: [drm] Connector 1:
Aug 22 23:46:22 kernel: [drm]   HDMI-A-1
Aug 22 23:46:22 kernel: [drm]   HPD3
Aug 22 23:46:22 kernel: [drm]   DDC: 0x4874 0x4874 0x4875 0x4875 0x4876 0x4876 0x4877 0x4877
Aug 22 23:46:22 kernel: [drm]   Encoders:
Aug 22 23:46:22 kernel: [drm]     DFP2: INTERNAL_UNIPHY1
Aug 22 23:46:22 kernel: [drm] Connector 2:
Aug 22 23:46:22 kernel: [drm]   DVI-D-1
Aug 22 23:46:22 kernel: [drm]   HPD4
Aug 22 23:46:22 kernel: [drm]   DDC: 0x4878 0x4878 0x4879 0x4879 0x487a 0x487a 0x487b 0x487b
Aug 22 23:46:22 kernel: [drm]   Encoders:
Aug 22 23:46:22 kernel: [drm]     DFP3: INTERNAL_UNIPHY
Aug 22 23:46:22 kernel: [drm] Chained IB support enabled!

but without amdgpu.dc=0 only the first and last line of that section appear.

Later down without the amdgpu.dc=0 I also get the following message:

kernel: [drm] Cannot find any crtc or sizes

This may also be similar to bug https://bugs.freedesktop.org/show_bug.cgi?id=105880 but that is for laptop panels on LVDS while this issue is with a discrete RX460 graphics card on HDMI
Comment 1 Naheem Zaffar 2018-08-23 23:12:58 UTC
Created attachment 141266 [details]
Dmesg output with amdgpu.dc=0

Taken when booting with Vanilla Mainline kernel 4.19.0-0.rc0.git8.1.vanilla.knurd.1.fc28.x86_64 with argument amdgpu.dc=0
Comment 2 Naheem Zaffar 2018-08-27 15:39:23 UTC
Having a look online I can see the same bug reported on Ubuntu where attempted triage has provided more results that may help track this issue down:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1761751
Comment 3 Naheem Zaffar 2018-08-27 17:14:04 UTC
Created attachment 141299 [details]
Log messages from Gnome Logs for boot with blank screen

Taken from kernel 4.19.0-0.rc0.git12.1.vanilla.knurd.1.fc28.x86_64
Comment 4 Naheem Zaffar 2019-01-05 16:24:28 UTC
Created attachment 142982 [details]
Dmesg outut with latest build from Kernel 4.21 pre-release series

The same error occurs with kernel 4.21 after the merging of the DRM feature updates. Dmesg output attached.
Comment 5 Naheem Zaffar 2019-02-23 16:35:36 UTC
I have just tried using an older 3m long HDMI cable I had at home that I presume cannot support the latest HDMI version and with that I got a display at full resolution.

The problem may be with HDMI handling, there seem to be others experiencing some problems with HDMI 2, which I dont think this card supports.

is there a way to confirm the HDMI versions I was using that failed and the version that succeeded?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.