Bug 107720 - [CI][DRMTIP] igt@kms_frontbuffer_tracking@* - dmesg-fail - Failed assertion: fbc_wait_for_compression()
Summary: [CI][DRMTIP] igt@kms_frontbuffer_tracking@* - dmesg-fail - Failed assertion: ...
Status: RESOLVED DUPLICATE of bug 107724
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-28 13:53 UTC by Martin Peres
Modified: 2019-04-04 12:09 UTC (History)
3 users (show)

See Also:
i915 platform: ICL
i915 features: display/watermark


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-08-28 13:53:23 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_95/fi-icl-u/igt@kms_frontbuffer_tracking@fbcpsr-modesetfrombusy.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_95/fi-icl-u/igt@kms_frontbuffer_tracking@fbc-1p-primscrn-pri-indfb-draw-blt.html

(kms_frontbuffer_tracking:2577) CRITICAL: Test assertion failure function do_status_assertions, file ../tests/kms_frontbuffer_tracking.c:1632:
(kms_frontbuffer_tracking:2577) CRITICAL: Failed assertion: fbc_wait_for_compression()
Subtest fbc-1p-primscrn-pri-indfb-draw-blt failed.
Comment 1 James Ausmus 2018-09-24 23:03:21 UTC
From the logs, the driver is automatically disabling FBC when we hit a FIFO underrun, so this is actually a duplicate of 107724.

*** This bug has been marked as a duplicate of bug 107724 ***
Comment 2 Lakshmi 2018-10-15 11:18:34 UTC
Closed as Duplicate.
Comment 3 Lakshmi 2018-12-18 11:59:18 UTC
(In reply to James Ausmus from comment #1)
> From the logs, the driver is automatically disabling FBC when we hit a FIFO
> underrun, so this is actually a duplicate of 107724.
> 
> *** This bug has been marked as a duplicate of bug 107724 ***

James do you think this failure is also part of bug 107724?
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_169/fi-icl-u3/igt@kms_frontbuffer_tracking@fbcpsr-1p-pri-indfb-multidraw.html
Comment 4 James Ausmus 2018-12-18 17:21:29 UTC
No, that looks like a separate issue - no FIFO underruns seen there
Comment 5 James Ausmus 2018-12-18 17:22:17 UTC
Jose - any thoughts from the logs in Comment 3?
Comment 6 Lakshmi 2018-12-18 17:35:20 UTC
To me it looks like I need to repoen this bug. If not, I need to file a new bug.
Comment 8 Lakshmi 2019-02-25 10:42:46 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_228/fi-icl-u2/igt@kms_frontbuffer_tracking@fbcpsr-1p-pri-indfb-multidraw.html

Starting subtest: fbcpsr-1p-pri-indfb-multidraw
(kms_frontbuffer_tracking:2241) CRITICAL: Test assertion failure function do_status_assertions, file ../tests/kms_frontbuffer_tracking.c:1619:
(kms_frontbuffer_tracking:2241) CRITICAL: Failed assertion: fbc_wait_for_compression()
Subtest fbcpsr-1p-pri-indfb-multidraw failed.
**** DEBUG ****
(kms_frontbuffer_tracking:2241) DEBUG: Used method mmap-cpu
(kms_frontbuffer_tracking:2241) igt_draw-DEBUG: Test requirement passed: gem_get_tiling(fd, buf->handle, &tiling, &swizzle)
(kms_frontbuffer_tracking:2241) igt_draw-DEBUG: Test requirement passed: intel_gen(intel_get_drm_devid(fd)) >= 5
(kms_frontbuffer_tracking:2241) igt_debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(kms_frontbuffer_tracking:2241) DEBUG: checking asserts in line 2070
(kms_frontbuffer_tracking:2241) igt_debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(kms_frontbuffer_tracking:2241) DEBUG: Calculated CRC: pipe:[0917ed60 00000000 00000000 00000000 00000000]
(kms_frontbuffer_tracking:2241) DEBUG: Test requirement passed: !fbc_not_enough_stolen()
(kms_frontbuffer_tracking:2241) DEBUG: Test requirement passed: !fbc_stride_not_supported()
(kms_frontbuffer_tracking:2241) DEBUG: Test requirement passed: !fbc_mode_too_large()
(kms_frontbuffer_tracking:2241) DEBUG: fbc_is_enabled()?
FBC enabled
Comment 9 CI Bug Log 2019-02-25 10:51:09 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@kms_frontbuffer_tracking@* - dmesg-fail / fail - Failed assertion: fbc_wait_for_compression() -}
{+ ICL: igt@kms_frontbuffer_tracking@* - dmesg-fail / fail - Failed assertion: fbc_wait_for_compression() +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_228/fi-icl-u2/igt@kms_frontbuffer_tracking@fbcpsr-1p-pri-indfb-multidraw.html
Comment 10 Arek Hiler 2019-04-04 11:59:36 UTC
We need to split this bug into two. This one should be marked as duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=107724 as the most errors we get are dmesg-fail with FIFO underruns in the dmesg which causes FBC to be disabled.

The other failure, also caught under this bug, haven't been seen in a while (1.5 months, drmtip_228) and had rather few reproduction prior to that (about once every three months): 

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_228/fi-icl-u2/igt@kms_frontbuffer_tracking@fbcpsr-1p-pri-indfb-multidraw.html

	
FBC last action not supported
Can't test DRRS: Not supported.
Starting subtest: fbcpsr-1p-pri-indfb-multidraw
Stack trace:
  #0 ../lib/igt_core.c:1474 __igt_fail_assert()
  #1 ../tests/kms_frontbuffer_tracking.c:1620 do_status_assertions()
  #2 ../tests/kms_frontbuffer_tracking.c:1659 __do_assertions()
  #3 ../tests/kms_frontbuffer_tracking.c:2048 multidraw_subtest()
  #4 ../tests/kms_frontbuffer_tracking.c:3397 main()
  #5 ../csu/libc-start.c:344 __libc_start_main()
  #6 [_start+0x2a]
Subtest fbcpsr-1p-pri-indfb-multidraw: FAIL (9.851s)

This one needs a separate filing.
Comment 11 Martin Peres 2019-04-04 12:09:31 UTC

*** This bug has been marked as a duplicate of bug 107724 ***
Comment 12 CI Bug Log 2019-04-04 12:09:45 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.