Bug 107791 - [CI][DRMTIP] igt@kms_draw_crc@draw-method-xrgb8888-*-(ytiled|xtiled) - fail - Failed assertion: !mismatch
Summary: [CI][DRMTIP] igt@kms_draw_crc@draw-method-xrgb8888-*-(ytiled|xtiled) - fail -...
Status: RESOLVED DUPLICATE of bug 103184
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Juha-Pekka Heikkilä
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-03 08:04 UTC by Martin Peres
Modified: 2019-04-15 08:40 UTC (History)
2 users (show)

See Also:
i915 platform: GLK, SKL
i915 features: display/Other, GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-09-03 08:04:42 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_99/fi-icl-u/igt@kms_draw_crc@draw-method-xrgb8888-mmap-gtt-xtiled.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_100/fi-icl-u/igt@kms_draw_crc@draw-method-xrgb8888-mmap-gtt-xtiled.html

(kms_draw_crc:1376) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:371:
(kms_draw_crc:1376) igt_debugfs-CRITICAL: Failed assertion: !mismatch
Subtest draw-method-xrgb8888-mmap-gtt-xtiled failed.
Comment 1 Martin Peres 2018-09-03 08:10:08 UTC
Oddly-enough, GLK started failing roughly at the same time:

https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4619/shard-glk9/igt@kms_draw_crc@draw-method-xrgb8888-mmap-gtt-xtiled.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4752/shard-glk8/igt@kms_draw_crc@draw-method-xrgb8888-mmap-gtt-xtiled.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4753/shard-glk3/igt@kms_draw_crc@draw-method-xrgb8888-mmap-gtt-xtiled.html

(kms_draw_crc:1228) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:371:
(kms_draw_crc:1228) igt_debugfs-CRITICAL: Failed assertion: !mismatch
Subtest draw-method-xrgb8888-mmap-gtt-xtiled failed.
Comment 2 Martin Peres 2018-09-04 07:35:01 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_101/fi-icl-u/igt@kms_draw_crc@draw-method-xrgb8888-mmap-cpu-xtiled.html

(kms_draw_crc:1690) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:371:
(kms_draw_crc:1690) igt_debugfs-CRITICAL: Failed assertion: !mismatch
Subtest draw-method-xrgb8888-mmap-cpu-xtiled failed.
Comment 3 Martin Peres 2018-09-17 07:26:29 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4825/shard-glk5/igt@kms_draw_crc@draw-method-xrgb8888-pwrite-xtiled.html

Starting subtest: draw-method-xrgb8888-pwrite-xtiled
(kms_draw_crc:1187) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:392:
(kms_draw_crc:1187) igt_debugfs-CRITICAL: Failed assertion: !mismatch
Subtest draw-method-xrgb8888-pwrite-xtiled failed.
Comment 4 Martin Peres 2018-09-17 12:22:30 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4645/shard-glk9/igt@kms_draw_crc@draw-method-xrgb8888-mmap-cpu-ytiled.html

Starting subtest: draw-method-xrgb8888-mmap-cpu-ytiled
(kms_draw_crc:1999) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:392:
(kms_draw_crc:1999) igt_debugfs-CRITICAL: Failed assertion: !mismatch
Subtest draw-method-xrgb8888-mmap-cpu-ytiled failed.
Comment 6 Martin Peres 2018-10-16 15:12:02 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4986/shard-skl7/igt@kms_draw_crc@draw-method-xrgb8888-render-xtiled.html

Starting subtest: draw-method-xrgb8888-render-xtiled
(kms_draw_crc:2132) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:392:
(kms_draw_crc:2132) igt_debugfs-CRITICAL: Failed assertion: !mismatch
Subtest draw-method-xrgb8888-render-xtiled failed.
Comment 7 Martin Peres 2018-10-29 09:41:16 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4698/shard-skl3/igt@kms_draw_crc@draw-method-xrgb8888-mmap-wc-xtiled.html

https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4697/shard-skl8/igt@kms_draw_crc@draw-method-xrgb8888-blt-xtiled.html

Starting subtest: draw-method-xrgb8888-blt-xtiled
(kms_draw_crc:2240) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:419:
(kms_draw_crc:2240) igt_debugfs-CRITICAL: Failed assertion: !mismatch
Subtest draw-method-xrgb8888-blt-xtiled failed.
Comment 8 Lakshmi 2018-11-26 15:46:41 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_144/fi-icl-u2/igt@kms_draw_crc@draw-method-xrgb8888-mmap-gtt-ytiled.html

Starting subtest: draw-method-xrgb8888-mmap-gtt-ytiled
(kms_draw_crc:977) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:419:
(kms_draw_crc:977) igt_debugfs-CRITICAL: Failed assertion: !mismatch
Subtest draw-method-xrgb8888-mmap-gtt-ytiled failed.
Comment 9 Martin Peres 2018-11-29 15:01:49 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_149/fi-cnl-u/igt@kms_draw_crc@draw-method-xrgb8888-mmap-wc-xtiled.html

Starting subtest: draw-method-xrgb8888-mmap-wc-xtiled
(kms_draw_crc:1125) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:419:
(kms_draw_crc:1125) igt_debugfs-CRITICAL: Failed assertion: !mismatch
Subtest draw-method-xrgb8888-mmap-wc-xtiled failed.
Comment 10 Daniel Vetter 2019-04-02 12:21:31 UTC
For ICL:

kms side of crc captureing has become a lot more reliable (we closed the ICL bugs on kms_pipe_crc_basic). Reproduction rate of this issue on ICL is very low, so keeping open on ICL to rule out gem vs kms coherency issues.
Comment 11 Arek Hiler 2019-04-02 12:39:35 UTC
We haven't got a simple CRC mismatch on ICL in what seems to be 2 months. All the other fails we have seen in that period are caused by FIFO underruns or suspicious CRC reads from what seems to be a powered down well.

Relevant bugs:
https://bugs.freedesktop.org/show_bug.cgi?id=108336
https://bugs.freedesktop.org/show_bug.cgi?id=107724
Comment 12 CI Bug Log 2019-04-15 08:24:40 UTC
A CI Bug Log filter associated to this bug has been updated:

{- SKL GLK CNL ICL: igt@kms_draw_crc@draw-method-xrgb8888-(pwrite|mmap-(cpu|gtt|wc)|render|blt)-xtiled - fail - Failed assertion: !mismatch -}
{+ SKL GLK: igt@kms_draw_crc@draw-method-xrgb8888-(pwrite|mmap-(cpu|gtt|wc)|render|blt)-xtiled - fail - Failed assertion: !mismatch +}

 No new failures caught with the new filter
Comment 13 CI Bug Log 2019-04-15 08:28:37 UTC
A CI Bug Log filter associated to this bug has been updated:

{- SKL GLK: igt@kms_draw_crc@draw-method-xrgb8888-(pwrite|mmap-(cpu|gtt|wc)|render|blt)-xtiled - fail - Failed assertion: !mismatch -}
{+ SKL GLK: igt@kms_draw_crc@draw-method-xrgb8888-(pwrite|mmap-(cpu|gtt|wc)|render|blt)-(xtiled|ytiled) - fail - Failed assertion: !mismatch +}

 No new failures caught with the new filter
Comment 14 Martin Peres 2019-04-15 08:40:48 UTC

*** This bug has been marked as a duplicate of bug 103184 ***
Comment 15 CI Bug Log 2019-04-15 08:40:54 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.