Bug 107795 - Tk entry widgets only allow the letter 'a'
Summary: Tk entry widgets only allow the letter 'a'
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 2.7.11 (xserver-1.18.4)
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
Depends on:
Reported: 2018-09-03 10:34 UTC by Daniel O'Connor
Modified: 2018-09-03 11:10 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Daniel O'Connor 2018-09-03 10:34:51 UTC
If I SSH to a FreeBSD or Linux (Ubuntu) system and run wish8.6 (tried 8.4, 8.5 and 8.7 on FreeBSD as well) then entry box widgets only allow the letter 'a' to go through.

This can be demonstrated with a trivial wish program, eg..
entry .foo
pack .foo

Then type into the box and see only 'a's go through.

Neither MobaTerm v10.9 build 3656 nor Xming v6.9.0.31 on Windows exhibit this issue.

I am pretty certain this is a regression as I am sure I would have noticed earlier but I don't (yet) have a handle on when it broke - I'll try that next.
Comment 1 Daniel O'Connor 2018-09-03 11:10:43 UTC
I installed 2.7.10 and it worked so I reinstalled 2.7.11 and that worked too so I have no idea!

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.