Bug 107822 - Just Cause 3 Flickering Textures with AMD RADV
Summary: Just Cause 3 Flickering Textures with AMD RADV
Status: REOPENED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: 18.3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-04 08:28 UTC by Alexander Vereeken
Modified: 2019-06-30 16:23 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Vereeken 2018-09-04 08:28:19 UTC
Hello i have in Just Cause 3 over Wine 3.14 with DXVK 0.70 and newer, texture flickering. 

Nvidia dont have this problem

Is this related to DXVK,Mesa,LLVM or Wine?

Its not possible to enter JC3 without DXVK.

I also have here Apitrace logs but unfortunately it was not possible to enter the game with Apitrace. I have maximum 3FPS and the game crashes in the loading screen.

### Software information
Just Cause 3 
{
    "DisplayFullscreen": 1,
    "DisplayFullscreenWidth": 1920,
    "DisplayFullscreenHeight": 1080,
    "DisplayWindowedWidth": 1280,
    "DisplayWindowedHeight": 720,
    "DisplayRefreshRate": 0,
    "DisplayVSync": 0,
    "DisplayGamma": 50,
    "GraphicsMotionBlur": 1,
    "GraphicsAniso": 16,
    "GraphicsLodFactor": 2,
    "GraphicsShadowsQuality": 2,
    "GraphicsPostEffects": 1,
    "GraphicsTextureQuality": 2,
    "GraphicsWaterDetail": 2,
    "GraphicsShadowsResolution": 1,
    "GraphicsSSAO": 0,
    "GraphicsEdgeFade": 1,
    "GraphicsGI": 1,
    "GraphicsAA": 4,
    "GraphicsSSReflection": 1,
    "GraphicsBokehDOF": 1,
    "GraphicsWaterTesselation": 1,
    "GraphicsAOITQuality": 0
}


### System information
- GPU: AMD RX 570
- OS: Manjaro GNOME-Edition
- Driver: AMD RADV POLARIS10 (LLVM 6.0.1) Mesa: 18.1.6 Vulkan: 1.1.70

See full specs here https://www.dropbox.com/sh/288sttvoxbu14x0/AAD2I5s0OfKbV_uBi31JEfJza?dl=0

- Wine version:  3.14 esync
- DXVK version: 0.70 / 0.71

### Log files
- [d3d11.log](https://www.dropbox.com/s/cerjagqka7srydy/JustCause3_d3d11.log?dl=0)
- [dxgi.log](https://www.dropbox.com/s/9msdya0g0tqthmj/JustCause3_dxgi.log?dl=0)
- [Video](https://www.dropbox.com/s/llxukrbid03b9ol/Preview.webm?dl=0)
- [Apitrace](https://www.dropbox.com/sh/xjra4xsn7ls4xr0/AAD5vvZPTmCQtmNwtxDsWf0Oa?dl=0)
Comment 1 Alexander Vereeken 2018-09-11 07:41:51 UTC
UPDATE : 

**----------------------------------------------------------German-------------------------------------------------------------**
Guten Tag

Mein Problem ist: In dem Spiel "Just Cause 3" fangen die Texturen an zu flackern wenn man näher an sie herannkommt.

Was ich schon ausprobiert habe:

- nvapi & nvapi64 ausgeschaltet.
- andere Grafikeinstellungen.

Systeminformationen:

GPU: Eine AMD RX 570 die aber irgendwie in manchen spielen auch als eine RX 480 erkannt wird.
GPU-Treiber: Mesa: 18.1.8 LLVM 6.0.1 
CPU: AMD FX 8350 8x 4GHz
Betriebsystem: Arch Linux 64Bit (Stable) mit dem Linux Kernel 4.18
Sonstiges: - Wine Staging 3.15 mit oder ohne esync beeinträchtigt das Problem nicht.

Apitrace: 

Hinweiß: Da "Just Cause 3" DXVK braucht, damit es überhaupt funktioniert, ist eine Aufnahame von Linux aus nicht möglich gewesen stattdessen habe ich die Apitrace/s über Windows 8.1 aufgenommen.

**----------------------------------------------------------English---------------------------------------------------------------**
Good day

My problem is: in the game  "Just cause 3 " The textures begin to flicker when you come closer to them.

What I have already tried:

- Nvapi & nvapi64 off.
- Other graphics settings.
System Information:

GPU: An AMD Rx 570 which is somehow detected in some games also as a RX 480.
GPU Drivers: Mesa: 18.1.8 LLVM 6.0.1 
CPU: AMD FX 8350 8x 4GHz
Operating system: Arch Linux 64bit (Stable) with the Linux kernel 4.18
Other: Wine staging 3.15 with or without esync does not affect the problem.

Clue: "Just cause 3 " needs DXVK to work at all, a record from Linux has not been possible instead I have recorded the Apitrace/s via Windows 8.1.
**-------------------------------------------------------Download--------------------------------------------------------------**

 [Apitrace](https://mega.nz/#!bsAkECxD!jekonqQDA6EU_XO6SaGCkKJ54VlCKEjL7jT_dtM2Qj4)
 [d3d11.log](https://mega.nz/#!6wZWgYDK!_thrND35oLnPyWt7dVG153Womsotfw5s4KwbLdW9-ck)
 [dxgi.log](https://mega.nz/#!2oRGjIjJ!g_uqNSQPVUMLGRO53321J2FtQOH1b7UohiWPmf63hFw)
[Video](https://www.youtube.com/embed/uBI9R3TEo58)
Comment 2 Timothy Arceri 2018-09-13 04:50:06 UTC
(In reply to Alexander from comment #1)
> GPU Drivers: Mesa: 18.1.8 LLVM 6.0.1

Hi,

This is a fairly old version of Mesa/RADV. Can you give the game a try on a more recent version, ideally directly from git or a least with the Arch mesa-git package. Thanks.
Comment 3 Alexander Vereeken 2018-09-13 09:41:39 UTC
Hello

Thanks for the answer. Old? but officially there are no new stable versions out and i like to wait for it that the new versions come to the stable repo.

But nevermind in the past i tested the game with Ubuntu and i had the same issue. i used Mesa 18.3 and LLVM 8.0.0.

And a guy from github have the same issue on Arch with llvm-svn and mesa-git

(I'm also having this issue. I'm running llvm-svn and mesa-git (both built 12/Sep/18) on Arch Linux. Hardware: RX 580, Ryzen 5 1600, 16GB RAM. I am using the amdgpu open source driver.)
Comment 4 Alexander Vereeken 2018-11-04 13:09:21 UTC
Update: This issue still happends. I try to Apitrace the game soon but i think its not possible.

Wine 3.19

OS: Ubuntu 18.10 64-Bit

Drivers: Mesa 18.2.2 + LLVM 7.0.0

Steam System Info :
https://gist.github.com/CrackedCrafterz/72c104e4d0f59898cc4ede2fce2de25a
Comment 5 fin4478 2018-11-10 08:29:36 UTC Comment hidden (spam)
Comment 6 Alexander Vereeken 2018-11-13 11:39:44 UTC
I already have tested that.
Comment 7 fin4478 2018-12-14 13:00:51 UTC Comment hidden (spam)
Comment 8 Alexander Vereeken 2019-01-22 19:04:21 UTC
I reopened this bug because someone reported this bug in wine-4.0-rc7-esync-staging-amd64 + dxvk 0.95, system kernel linux-5.0.0-rc3 + mesa 19.0 (git) +llvm 7.0
Comment 9 Alexander Vereeken 2019-06-25 23:29:26 UTC
I'm closing this bug now because I'm not interested in the game anymore and I'm sure nothing will change here.
Comment 10 Samuel Pitoiset 2019-06-26 06:26:59 UTC
Last time I tried to investigate the game crashed inside Proton. I will try again.
Comment 11 Jerrod Frost 2019-06-30 16:23:09 UTC
Is there some way I can help with this? If someone can give me some instructions on how to pull the necessary data, I'd be glad to help.

https://github.com/ValveSoftware/Proton/issues/1295#issuecomment-493051807

This flickering in this using Proton and playing "Tokyo Xanadu eX+" seems to be related to VEGA specifically and esync? Issue doesn't appear to be happening on RX500 series cards, but is reproducible on Vega56 and my Radeon VII. snippet from the bug posted above in relation to VEGA Cards.

Proton 4.2-9 + DXVK (git and the provided version) + esync - flickering
Proton 4.2-9 + DXVK + no esync - no flickering, slow
Proton 4.2-9 + WineD3D + esync - no flickering
Wine-staging 4.11 + DXVK + esync - no flickering
Wine-staging 4.11 + WineD3D + esync - no flickering

Is there something I can do to get the data necessary to help with finding the solution?

Thanks,
Frosty


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.