Bug 107823 - [amdgpu/displayport] Blackscreen on native resolution
Summary: [amdgpu/displayport] Blackscreen on native resolution
Status: NEW
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-04 14:40 UTC by Jan Burgmeier
Modified: 2018-12-05 17:13 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg with drm.debug=0x1e log_buf_len=1M (514.67 KB, text/plain)
2018-09-04 14:40 UTC, Jan Burgmeier
no flags Details
lspci -vv output (24.66 KB, text/plain)
2018-09-04 14:40 UTC, Jan Burgmeier
no flags Details
/proc/cpuinfo (5.29 KB, text/plain)
2018-09-04 14:41 UTC, Jan Burgmeier
no flags Details
xrandr output (1.05 KB, text/plain)
2018-09-04 14:51 UTC, Jan Burgmeier
no flags Details
dmesg after setting mode to 1400x1050 (33.86 KB, text/plain)
2018-09-04 14:52 UTC, Jan Burgmeier
no flags Details
dmesg after setting mode to auto (28.54 KB, text/plain)
2018-09-04 14:52 UTC, Jan Burgmeier
no flags Details
edid info from sysfs (256 bytes, application/octet-stream)
2018-10-16 08:37 UTC, Jan Burgmeier
no flags Details
setup pic 1 (2.37 MB, image/jpeg)
2018-11-15 15:08 UTC, Drexler
no flags Details
setup video (14.97 MB, video/mp4)
2018-11-15 15:09 UTC, Drexler
no flags Details
Change resolution for reproduction (43.50 MB, video/mp4)
2018-11-28 13:36 UTC, Jan Burgmeier
no flags Details
System information (6.54 MB, image/jpeg)
2018-11-28 13:37 UTC, Jan Burgmeier
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Burgmeier 2018-09-04 14:40:29 UTC
Created attachment 141442 [details]
dmesg with drm.debug=0x1e log_buf_len=1M

Hi,

there seems to be some monitor/graphics card combination which lead to a black screen.
In my case it is the native (1920x1080) resolution of a NEC EA223WM monitor and a [AMD/ATI] Carrizo (rev 88). Setting any other mode than the native one via xrandr turns the monitor on. Setting it back to the native one results in a black screen.
It seems unrelated to XOrg as there is also a black screen on the terminal and during boot.
I do not see any errors in dmesg or XOrg log

The error does not occur with module parameter dc=0

Environment:
Kernel: 4.19.0-rc2 (git master)
Mesa: 18.1.6
XOrg: 1.20.1
amdgpu-ddx: 18.0.99 (git master)
Comment 1 Jan Burgmeier 2018-09-04 14:40:46 UTC
Created attachment 141443 [details]
lspci -vv output
Comment 2 Jan Burgmeier 2018-09-04 14:41:01 UTC
Created attachment 141444 [details]
/proc/cpuinfo
Comment 3 Jan Burgmeier 2018-09-04 14:51:39 UTC
Created attachment 141445 [details]
xrandr output
Comment 4 Jan Burgmeier 2018-09-04 14:52:12 UTC
Created attachment 141446 [details]
dmesg after setting mode to 1400x1050
Comment 5 Jan Burgmeier 2018-09-04 14:52:30 UTC
Created attachment 141447 [details]
dmesg after setting mode to auto
Comment 6 Drexler 2018-10-15 18:31:59 UTC
Hi,
was wondering if you can share the EDID of this NEC EA223WM monitor?
Comment 7 Jan Burgmeier 2018-10-16 08:37:23 UTC
Created attachment 142042 [details]
edid info from sysfs

Here is the edid info extracted from sysfs:
/sys/devices/pci0000:00/0000:00:01.0/drm/card0/card0-DP-1/edid
Comment 8 raxondmc 2018-10-16 17:27:36 UTC
@Jan:

I was wondering can you see the issue with their staging branch? 

Here is what I can recommend you to try :

https://cgit.freedesktop.org/~agd5f/linux/log/?h=amd-staging-drm-next


If possible for you to try, give it a shot. I can help, but dont have same monitor as you do.
Comment 9 raxondmc 2018-10-16 20:08:29 UTC
@Jan:

Can you see if you get the black screen if you set amdgpu.dc=0 in the grub boot line?

I am interested to help and learn something new, if you do not mind :)

I dont have the monitor or else i would have tried it here!
Comment 10 Jan Burgmeier 2018-10-17 09:56:00 UTC
As mentioned in the description with dc=0 the error does not occur.

I've tested amd-staging-drm-next from current HEAD (efb7936df2efe1434f0d5e72ae9d256a4388965a) and the error still occurs. With this kernel I see following error in dmesg:

[drm:construct [amdgpu]] *ERROR* construct: Invalid Connector ObjectID from Adapter Service for connector index:2! type 0 expected 3
Comment 11 raxondmc 2018-10-17 16:03:19 UTC
Your correct, sorry i missed the dc=0 comment. 

Seems like you have Carrizo->DP2DVI(PASSIVE)->NEC monitor? 

Do you if other monitors show it as well? 

I will try with my 580x and a dongle and can let you know. (albeit different monitor).
Comment 12 raxondmc 2018-10-17 19:23:22 UTC
I've tried with a monitor I have with my 580x :

Here is the modeline your monitor has: 

[ 49.626518] [drm:drm_mode_debug_printmodeline [drm]] Modeline 64:"1680x1050" 60 146250 1680 1784 1960 2240 1050 1053 1059 1089 0x48 0x6


Here is mine: 

<div> [drm:drm_mode_debug_printmodeline [drm]] Modeline 68:"1680x1050" 60 146250 1680 1784 1960 2240 1050 1053 1059 1089 0x40 0x6

Now, the diff seems to be second last print on the lines. That said, my monitor is not 1680x1050 native, but it supports this mode. 

Clocks seems to be the same, now i am wondering if it's the panel (NEC) in your case that is picky or just Carrizo PLL's are not encoding at that modulated clock.

I'll try to find a CZ and try it.

Cheers.
Comment 13 raxondmc 2018-10-17 19:56:33 UTC
I've used your edid file and emulated it in my carrizo HW, I cannot see the issue.

I am thinking the panel on that NEC monitor may be not liking it.
Comment 14 Jan Burgmeier 2018-10-18 07:29:00 UTC
Thanks for your effort so far.

I have two monitors connected so I get a picture, but the error also occurs if only the NEC monitor is connected.

The NEC monitor is connected directly with DP and the second monitor is connected with a DP->DVI Adapter.

I think it has somehow to do with the NEC as other monitors work fine.
Comment 15 Drexler 2018-11-15 15:06:49 UTC
Hi Jan, 
i have exact same panel and tried it out, with thinpro 7, but unable to see the problem. The panel's native resolution is 1680x1050 @60 which is selected by default. I then set using xrandr, another resolution, 1024x768, then set it back to 1680x1050, and it seems to work on my side. Wanted to check if my procedure is correct? attached is a video and setup pictures.

thanks
Comment 16 Drexler 2018-11-15 15:08:06 UTC
Created attachment 142478 [details]
setup pic 1
Comment 17 Drexler 2018-11-15 15:09:09 UTC
Created attachment 142479 [details]
setup video
Comment 18 Drexler 2018-11-20 20:52:14 UTC
Hi Jan,
was wondering if you were able to review the video i uploaded?
thanks again
Comment 19 Jan Burgmeier 2018-11-22 08:19:21 UTC
Hi,

the video looks good. I don't know why you do not see the error. I am unable to get a picture after boot because the says "Frequency out of range".

At the start of next week I will retest and give more information.
Comment 20 Jan Burgmeier 2018-11-28 13:36:11 UTC
Created attachment 142644 [details]
Change resolution for reproduction
Comment 21 Jan Burgmeier 2018-11-28 13:37:07 UTC
Created attachment 142645 [details]
System information
Comment 22 Jan Burgmeier 2018-11-28 13:37:28 UTC
Let me know if you need more information
Comment 23 Drexler 2018-12-03 23:34:37 UTC
Hi Jan,
thanks for the video. 
just like to ask, were you also able to try on using another DP cable? short and or thicker DP cable?
Also, would just like to ask if you observe the issue on Ubuntu 18.10? I tested my setup, and also seems to be able to pass. 
unfortunately, the OSD of the panel doesnt actually say what the firmware version is so I couldnt compare against your panel. 
Do you have other EA223WM panels? do they also fail?

thanks for your feedback
Comment 24 Jan Burgmeier 2018-12-05 17:13:33 UTC
I tested with a shorter DP cable but the error still occurs. I don't think it is a cable/hardware problem as the same hardware with kernel parameter dc=0 works just fine.

I tried a Ubuntu 18.04 live stick but it didn't boot. Tomorrow I can try a 18.10 livestick.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.