Bug 10790 - Move becomes cpu intensive & sluggish after opening windows
Summary: Move becomes cpu intensive & sluggish after opening windows
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: App/compiz (show other bugs)
Version: 7.2 (2007.02)
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: David Reveman
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-28 00:35 UTC by Erkin Bahceci
Modified: 2007-05-30 19:28 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erkin Bahceci 2007-04-28 00:35:07 UTC
On compiz git version, I am experiencing very high cpu usage and sluggishness while moving windows. I have Wobbly off. When I have a few windows open (trying
with firefox windows) and I restart compiz, everything works fine
(fine being xgl cpu usage remaining under 25% while moving a 1300x800
window on a 1680x1050 screen). The problem starts when I open a new
(firefox) window (of the same size). While I move this new window, xgl
cpu usage goes up to 80%. The old windows again cause only 25% usage.
When I restart compiz again, xgl cpu usage while moving every window
is again 25%. But opening new windows causes the same problem again.
So something must be missing or being done wrong when opening new
windows, that is being done properly when initializing windows that
were already open before compiz started.

When I enable Wobbly, the problem gets even worse. When compiz is
restarted, xgl cpu usage is < 35% while moving windows. When I open a
new window, this time *every* window makes the cpu hit 100% while
moving it, rather than only the new window. Because of the high xgl
cpu usage, Wobbly makes windows make abrupt and big jumps, sometimes
even moving a little in the opposite direction, too.

Set to major because of this annoying regression that is always repeatable.

This is with a Mobility Radeon x300 using fglrx, on Xgl, Ubuntu 7.04. Let me know if anymore information is needed
Comment 1 Erkin Bahceci 2007-04-28 00:37:47 UTC
Problem was discussed in this thread btw:
http://lists.freedesktop.org/archives/compiz/2007-April/thread.html#1817
Comment 2 Erkin Bahceci 2007-04-30 18:35:45 UTC
This problem also exists with the --loose-binding option (again on Xgl). I haven't tried aiglx yet.

Plus the error is sometimes accompanied by (or preceded with) this error when using kde-window-decorator:

 X Error: BadWindow (invalid Window parameter) 3
 Major opcode:  2
 Minor opcode:  0
 Resource id:  0x1e0013a

and by errors like this when using gtk-window-decorator:

(gtk-window-decorator:26290): Wnck-WARNING **: Unhandled action type (nil)

I don't know how the decorators would be related to the issue, but they might.
Comment 3 Erkin Bahceci 2007-05-28 14:00:45 UTC
Apparently the major cause of the move/wobbly jerkiness on newly opened windows was the "BS" plugin (which allows adjusting brightness/saturation on windows) in the extra-plugins snapshot here:
http://forum.compiz.org/viewtopic.php?t=726&postdays=0&postorder=asc&start=0
(its CompPluginVTable should be adjusted to work with current git)

The BS plugin is doing something weird on newly opened windows (which also causes it to give the same brightness/saturation of the last changed window).

Disabling this plugin makes the problem go away. There is probably something wrong with the plugin itself. However, a problem in the core might also be causing this (when BS is active), so I haven't closed this bug yet.
Comment 4 Erkin Bahceci 2007-05-28 17:08:08 UTC
Latest bs plugin is here, which has the same problems:
git://people.freedesktop.org/~mike/bs
Comment 5 Erkin Bahceci 2007-05-30 19:28:02 UTC
Closing the bug as it's fixed in the BS git version.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.