Bug 107921 - [bdw] intel_iommu DMAR fault -> GPU hang
Summary: [bdw] intel_iommu DMAR fault -> GPU hang
Status: RESOLVED DUPLICATE of bug 89360
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-13 12:28 UTC by Niko Pavlinek
Modified: 2018-12-04 08:09 UTC (History)
2 users (show)

See Also:
i915 platform: BDW
i915 features: GPU hang


Attachments
crash dump with mesa-18.1.7 (35.58 KB, text/plain)
2018-09-13 12:28 UTC, Niko Pavlinek
no flags Details
crash dump with mesa-18.2.0 (27.31 KB, text/plain)
2018-09-13 12:28 UTC, Niko Pavlinek
no flags Details
system log (6.83 KB, text/plain)
2018-09-13 12:29 UTC, Niko Pavlinek
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Niko Pavlinek 2018-09-13 12:28:27 UTC
Created attachment 141543 [details]
crash dump with mesa-18.1.7

Bug description:

The bug causes the display to freeze either temporarily or permanently (reboot necessary). If it freezes only temporarily, graphical glitches occur (blank windows, black rectangles, ...).

System environment:
-- chipset:

00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
00:1c.2 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3)
00:1c.4 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #5 (rev e3)
00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
06:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)

-- system architecture: 64-bit
-- xf86-video-intel: 2.99.917.831_3
-- xserver: 1.20.1_7
-- mesa: 18.2.0_1
-- libdrm: 2.4.94_1
-- kernel: 4.18.7_2
-- Linux distribution: Void Linux
-- Machine or mobo model: Dell Inspiron 5558 / Dell 08V6CK
-- Display connector:

Reproducing steps:

This seems to be very random. Sometimes it'll happen when nothing is happening on the system, other times when watching a video. I haven't been able to figure out how to reproduce it consistently.

Additional info:

I've attached two crash dumps (one with mesa-18.1.7, the other with mesa-18.2.0) and a system log of when the bug appears.
Comment 1 Niko Pavlinek 2018-09-13 12:28:47 UTC
Created attachment 141544 [details]
crash dump with mesa-18.2.0
Comment 2 Niko Pavlinek 2018-09-13 12:29:04 UTC
Created attachment 141545 [details]
system log
Comment 3 Chris Wilson 2018-09-13 13:04:57 UTC
Your system requires intel_iommu=igfx_off
Comment 4 Francesco Balestrieri 2018-12-04 08:09:15 UTC
This looks like a duplicate of Bug 89360.

*** This bug has been marked as a duplicate of bug 89360 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.