Bug 107972 - [SKL] 64-bit integer support seems pretty broken
Summary: [SKL] 64-bit integer support seems pretty broken
Status: RESOLVED NOTOURBUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-18 08:51 UTC by Ian Romanick
Modified: 2018-09-18 09:22 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Test case. (510 bytes, text/plain)
2018-09-18 08:51 UTC, Ian Romanick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Romanick 2018-09-18 08:51:05 UTC
Created attachment 141627 [details]
Test case.

The very simple attached test fails.  GDB sure thinks 0x8000000000000000ll - 0x8000000000000001ll is -1ll. :(
Comment 1 Ian Romanick 2018-09-18 09:22:20 UTC
It seems the problem is that strtoll clamps to INT64_MAX.  This is very frustrating because strtol does not clamp.  It produces the raw bit pattern.

When I send out the test cases where I actually encountered this problem, I will send out a fix to tests/shaders/parser_utils.c.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.