Bug 108083 - eDP Blank screen on Wayland
Summary: eDP Blank screen on Wayland
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-27 07:36 UTC by Shun Terabayashi
Modified: 2018-11-02 09:32 UTC (History)
2 users (show)

See Also:
i915 platform: KBL
i915 features: display/eDP


Attachments
full dmesg (55.50 KB, text/x-log)
2018-09-27 07:36 UTC, Shun Terabayashi
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shun Terabayashi 2018-09-27 07:36:16 UTC
Created attachment 141757 [details]
full dmesg

Kernel is 4.18.8, 4.18.9(Arch), mainline(AUR), and drm/drm-intel(https://github.com/shunonymous/aur-linux-drm-intel-git).
My laptop displays nothing in builtin monitor when launching Wayland compositor.(weston, mutter)
It displays by connecting or disconnecting external monitor (by HDMI) (mutter. weston doesn't work).
startx works without any problem.

I tried to revert https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=399334708b4f07b107094e5db4a390f0f25d2d4f on mainline, this symptom was disappeared.


Machine: Razer Blade Stealth (2016 Later, UHD Model, w/o any eGPU)
External Display: LG 27UD88-W (3840x2160) connected with HDMI
OS: Arch Linux
Comment 1 Lakshmi 2018-10-02 05:58:02 UTC
Shun, Can you apply following path and test if the issue is still existing?
(https://bugs.freedesktop.org/attachment.cgi?id=141229).

If the issue persists, send dmesg from boot with kernel parameters drm.debug=0x1e log_buf_len=4M. This way we know more information about the bug.
Comment 2 Shun Terabayashi 2018-10-02 16:30:23 UTC
I re-tested on latest drm/drm-intel (without patch), this issue is not exist.
Comment 3 Lakshmi 2018-10-03 07:12:12 UTC
Thankyou for your feedback. I will resolve this bug as worksforme.
Comment 4 Karol Herbst 2018-10-20 19:35:42 UTC
this is actually an issue on the 4.18.8 and newer.

Those commits need to be applied to 4.18 to fix this regression:

9ebd8202393dde9d3678c9ec162c1aa63ba17eac
f24f6eb95807bca0dbd8dc5b2f3a4099000f4472

regression was caused by

399334708b4f07b107094e5db4a390f0f25d2d4f
Comment 5 Karol Herbst 2018-10-20 19:37:42 UTC
I think the same applies for the upcoming 4.19 as well.
Comment 6 Jani Nikula 2018-10-23 11:28:57 UTC
(In reply to Karol Herbst from comment #4)
> this is actually an issue on the 4.18.8 and newer.
> 
> Those commits need to be applied to 4.18 to fix this regression:
> 
> 9ebd8202393dde9d3678c9ec162c1aa63ba17eac

commit 9ebd8202393dde9d3678c9ec162c1aa63ba17eac
Author: Dhinakaran Pandiyan <dhinakaran.pandiyan@intel.com>
Date:   Thu Sep 27 13:57:30 2018 -0700

    drm/i915/dp: Fix link retraining comment in intel_dp_long_pulse()

> f24f6eb95807bca0dbd8dc5b2f3a4099000f4472

commit f24f6eb95807bca0dbd8dc5b2f3a4099000f4472
Author: Dhinakaran Pandiyan <dhinakaran.pandiyan@intel.com>
Date:   Thu Sep 27 13:57:31 2018 -0700

    drm/i915/dp: Restrict link retrain workaround to external monitors

> regression was caused by
> 
> 399334708b4f07b107094e5db4a390f0f25d2d4f

commit 399334708b4f07b107094e5db4a390f0f25d2d4f
Author: Jan-Marek Glogowski <glogow@fbihome.de>
Date:   Sat Aug 25 15:10:35 2018 -0400

    drm/i915: Re-apply "Perform link quality check, unconditionally during long pulse"
Comment 7 Jani Nikula 2018-11-02 09:31:48 UTC
The commits are headed upstream and tagged with appropriate tags to be backported to stable kernels. Please let us know if the fixes don't show up in v4.18 in a few weeks.

Thanks for the report, closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.