Bug 10809 - System freeze after pressing ctrl-alt-bs.
Summary: System freeze after pressing ctrl-alt-bs.
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: GLX (show other bugs)
Version: 6.5
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 11306 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-04-29 04:42 UTC by Raúl
Modified: 2007-09-07 18:32 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg log with the backtrace crash. (44.51 KB, text/x-log)
2007-04-29 04:43 UTC, Raúl
Details
Backtrace of the crash from the core dump. (1.13 KB, text/plain)
2007-04-29 04:44 UTC, Raúl
Details
Xorg configuration file (3.97 KB, text/plain)
2007-04-29 04:44 UTC, Raúl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Raúl 2007-04-29 04:42:53 UTC
After using Xorg for a while I decide to log out, then I go back to the kdm login screen. If I press ctrl-alt-bs to force a kill of the server the system will freeze.

I'm not sure if that always happens, but most cases it does. I have tried using ctrl-alt-del, alt-sysrq key combinations to reboot at least but I was unsuccessfull so all I could do it power off my machine.

I own a Dell inspirom 510m laptop with a 855GM video card running 2.6.21 and debian unstable right now.

I attach an Xorg log, a backtrace of the core dump and also my xorg configuration.
Comment 1 Raúl 2007-04-29 04:43:37 UTC
Created attachment 9793 [details]
Xorg log with the backtrace crash.
Comment 2 Raúl 2007-04-29 04:44:01 UTC
Created attachment 9794 [details]
Backtrace of the crash from the core dump.
Comment 3 Raúl 2007-04-29 04:44:20 UTC
Created attachment 9795 [details]
Xorg configuration file
Comment 4 Raúl 2007-04-29 04:54:26 UTC
Paying attention to the backtrace I think this is more possibly a Mesa bug. Sorry for the nuissances.
Comment 5 Lann Martin 2007-07-23 10:23:08 UTC
*** Bug 11306 has been marked as a duplicate of this bug. ***
Comment 6 Lann Martin 2007-07-23 10:27:30 UTC
I am getting similar behavior; suspect its related to fixed #10664. This MIGHT be a bug for i810 (but I won't reassign).
Comment 7 Conn 2007-07-26 16:58:06 UTC
Hardware: Dell Inspiron 510m laptop, 512mb RAM
Chipset: 00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
Software: Ubuntu Gutsy, xserver-xorg-core 2:1.3.0.0.dfsg-6ubuntu2, xserver-xorg-video-intel 2:2.1.0-1ubuntu1, libgl1-mesa-dri 7.0.0-0ubuntu2

I can confirm the same behaviour as Raul, and I too suspect it's a Mesa issue, directly or indirectly. Additionally, there is a way to make this freeze 100% reproducible:

Case a)
1. Start GDM/KDM session without running compiz (or other 3D applications)
2. Restart X by logging out or pressing Ctrl+Alt+Backspace

Case b)
1. Start session and enable compiz.
2. Restart X (with or without stopping compiz beforehand, it doesn't matter)

Results

Using the 2.1.0 (intel) driver:
Case a) will crash approximately 30% of the time, and with each successive X  restart the chances of a crash exponentially rise. Case b) crashes reproducibly 100% of the time.

Using the 1.7.4 (i810) driver:
Neither case causes a crash.

Perhaps this is related to my other bug #11432, in which X crashes 100% reproducibly when pressing the laptop lid switch (and I've isolated the commit that introduced the regression since driver 1.7.4, details are in that bug report).
Comment 8 Samuel Thibault 2007-08-21 06:45:34 UTC
Note: this really a problematic bug for computer rooms where students keep logging in & out...
Comment 9 Lukas Hejtmanek 2007-08-22 15:20:33 UTC
This patch fixes the problem.
http://lists.freedesktop.org/archives/xorg/2007-August/027467.html
Comment 10 Lukas Hejtmanek 2007-08-22 15:21:50 UTC
consider to report the solution to packages maintainers (debian, ubuntu) to get it fixed in the packages.
Comment 11 Samuel Thibault 2007-08-22 16:30:40 UTC
Seems to work fine for me. 
Comment 12 Raúl 2007-09-07 18:32:40 UTC
It's also working for me.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.