Bug 108106 - [snb] GPU HANG: ecode 6:0:0xff800fbf, in kwin_x11 & graphics corruption
Summary: [snb] GPU HANG: ecode 6:0:0xff800fbf, in kwin_x11 & graphics corruption
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-30 19:48 UTC by Laurent Bonnaud
Modified: 2019-05-10 03:59 UTC (History)
1 user (show)

See Also:
i915 platform: SNB
i915 features:


Attachments
Full dmesg (71.14 KB, text/plain)
2018-09-30 19:49 UTC, Laurent Bonnaud
Details
Content from /sys/class/drm/card0/error (38.19 KB, text/plain)
2018-09-30 19:51 UTC, Laurent Bonnaud
Details
Sample of corruption (397.06 KB, image/png)
2018-09-30 20:05 UTC, Laurent Bonnaud
Details
Other example of corruption (437.55 KB, image/png)
2018-10-01 17:10 UTC, Laurent Bonnaud
Details
Compositor settings (80.26 KB, image/png)
2018-10-12 20:30 UTC, Laurent Bonnaud
Details
More massive corruption (213.54 KB, image/png)
2018-10-12 20:35 UTC, Laurent Bonnaud
Details
Screenshot for Ubuntu 19.04 that shows text corruption in GTK3 applications (56.12 KB, image/png)
2019-04-11 08:29 UTC, Laurent Bonnaud
Details
Graphic corruption in Ubuntu 19.04 (57.91 KB, image/png)
2019-04-11 13:33 UTC, Laurent Bonnaud
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Bonnaud 2018-09-30 19:48:03 UTC
Hi,

my system is running Ubuntu and since around version 18.04 it is plagued with graphic corruption problems.

I use Plasma desktop with or without compositing and after a few minutes or hours, I start to see graphic corruptions.

I upgraded my system to Ubuntu 18.10 in the hope that newer Xorg and Mesa would help, but the problem remains.

And today I got a GPU hang:

[ 1746.029214] [drm] GPU HANG: ecode 6:0:0xff800fbf, in kwin_x11 [2686], reason: hang on rcs0, action: reset
[ 1746.029216] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 1746.029216] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 1746.029217] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 1746.029217] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 1746.029218] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 1746.029252] i915 0000:00:02.0: Resetting chip for hang on rcs0

so here is my report with the required info:

 - uname -a
Linux vougeot 4.18.11-041811-generic #201809290731 SMP Sat Sep 29 11:33:39 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

This is the mainline kernel provided by Ubuntu: http://kernel.ubuntu.com/~kernel-ppa/mainline/

 - Linux distribution: Ubuntu 18.10 
Xorg 1.20.1-1ubuntu2
Mesa 18.2.1-1ubuntu1

 - Machine or mother board model:
from dmidecode:
System Information
        Manufacturer: Dell Inc.
        Product Name: Latitude E6520
        Version: 01
BIOS Information
        Vendor: Dell Inc.
        Version: A19
        Release Date: 11/14/2013
Base Board Information
        Manufacturer: Dell Inc.
        Product Name: 0NVF5K
        Version: A01

from /proc/cpuinfo:
model name      : Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz

 - Display connector: internal LVDS panel

 - dmesg and other attachment to follow below...
Comment 1 Laurent Bonnaud 2018-09-30 19:49:16 UTC
Created attachment 141812 [details]
Full dmesg
Comment 2 Laurent Bonnaud 2018-09-30 19:51:08 UTC
Created attachment 141813 [details]
Content from /sys/class/drm/card0/error
Comment 3 Laurent Bonnaud 2018-09-30 19:56:17 UTC
Please note that during boot I see the following error message:

[    2.455186] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[    2.455228] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A                                                                                                         
[    2.455252] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun

I never bothered about it previously because it does not prevent the system from booting and from displaying graphics.

Do you think it is related to my main graphic problem?
Comment 4 Laurent Bonnaud 2018-09-30 20:05:13 UTC
Created attachment 141814 [details]
Sample of corruption
Comment 5 Laurent Bonnaud 2018-10-01 17:10:04 UTC
Created attachment 141823 [details]
Other example of corruption
Comment 6 Marina Chernish 2018-10-02 14:55:49 UTC
Hi Laurent,

Could you please describe actions after which you observed those hangs?
I've tried to reproduce this issue but couldn't catch anything like that for several hours using following environment:

SandyBridge; Intel® HD Graphics 3000; Intel Core i5-2520M;
Ubuntu 18.10 kernel 4.18.11-041811-generic; Plasma desktop;
Mesa-18.2.1;
X.Org 1.20.1
Comment 7 Marina Chernish 2018-10-12 14:31:01 UTC
Hi Laurent,

Is this issue still actual for you? 
If so, could you please provide some description of actions which lead to this hang since I still faced no issues while use mentioned environment for several days.
Comment 8 Laurent Bonnaud 2018-10-12 20:29:53 UTC
>Could you please describe actions after which you observed those hangs?

I am using plasma with many (12) virtual desktops.  As constantly running applications, I use thunderbird, firefox, akregator and many konsoles.
The crucial point to reproduce this bug is to run plasma with compositing activated.
I will attach a screenshot of my settings.

>I've tried to reproduce this issue but couldn't catch anything like that for several hours 

Thanks for trying so hard!
Comment 9 Laurent Bonnaud 2018-10-12 20:30:29 UTC
Created attachment 142006 [details]
Compositor settings
Comment 10 Laurent Bonnaud 2018-10-12 20:35:23 UTC
> Is this issue still actual for you? 

Yes, even with recent updates:

Linux kernel 4.18.13-041813-generic
Mesa 18.2.2-0ubuntu1
libdrm 2.4.95-1

I even recorded a screenshot with more massive corruption.
Comment 11 Laurent Bonnaud 2018-10-12 20:35:56 UTC
Created attachment 142007 [details]
More massive corruption
Comment 12 Laurent Bonnaud 2018-10-12 20:39:18 UTC
The problem seems to come from glamor acceleration, since the problem seems to disappear when I disable graphic acceleration with the following configuration:

    Driver      "modesetting"
    Option      "AccelMethod"    "none"  # (instead of "glamor")
Comment 13 Laurent Bonnaud 2019-04-08 07:30:09 UTC
For the record, I am still seeing graphic corruption in Ubuntu 18.10 with those software versions:

Linux kernel 5.0.7
Mesa 18.2.8-0ubuntu0~18.10.2
libdrm 2.4.95-1
Xorg 1.20.3-0ubuntu0.18.10.1

I am going to upgrade my system to Ubuntu 19.04...
Comment 14 Laurent Bonnaud 2019-04-08 07:31:53 UTC
I also tested Fedora 29 on the same laptop and I also see graphic corruption:
 - in GNOME/Wayland
 - in Plasma/Xorg
Comment 15 Denis 2019-04-08 14:59:20 UTC
hi, I also tried to load about 12 desktops with some apps (web gl in browser, a lot of cmd's, etc) - didn't see your's corruptions (few gpu hangs in web content, without any stable steps, that's all).
Config for Xorg is the same with your's - glamor enabled, driver is modesetting. 

I will try to work on this machine longer and update kernel.
Current setup is:

ubuntu 18.10
kernel 4.18
mesa 18.3.0
Comment 16 Laurent Bonnaud 2019-04-08 16:03:37 UTC
Thanks a lot for trying to reproduce this problem!

Sometimes it appears after a few minutes, sometimes it appears after a few hours.  One way to make it appear quicker is to enable compositing in Plasma.

Since I seem to be the only one to have this problem, do you think it may be caused by a defective CPU/GPU? (it is very old by now)
Comment 17 Laurent Bonnaud 2019-04-11 08:28:08 UTC
I upgraded my Ubuntu system and I still see graphic corruption.  Here is version info:

Ubuntu 19.04
Linux kernel 5.0.7
Mesa 19.0.1-1ubuntu2
libdrm 2.4.97-1ubuntu1
Xorg 1.20.4-1ubuntu3

I started to see transient corruption after a few hours of work.  After ~20 hours, I get corruption in text for all newly started GTK3 applications (see screenshot).  Qt5 applications still look fine or have occasional transient corruption.
Comment 18 Laurent Bonnaud 2019-04-11 08:29:06 UTC
Created attachment 143937 [details]
Screenshot for Ubuntu 19.04 that shows text corruption in GTK3 applications
Comment 19 Sergii Romantsov 2019-04-11 08:38:59 UTC
Hello, Laurent.
Could you, please, try to use Mesa with patch https://gitlab.freedesktop.org/mesa/mesa/merge_requests/520?

If it didn't help - please, provide an apitrace (https://apitrace.github.io/) of corrupted app
Comment 20 Laurent Bonnaud 2019-04-11 13:28:24 UTC
I upgraded my system with disco-proposed that contains a more recent Mesa version:

Mesa 19.0.2-1ubuntu1

I am still seeing graphic corruption.
Comment 21 Laurent Bonnaud 2019-04-11 13:33:47 UTC
Created attachment 143940 [details]
Graphic corruption in Ubuntu 19.04

Here is an example of corruption that I got only a few seconds after logging in.  It occurred both with Mesa 19.0.1 and 19.0.2.

OpenGL triangles are clearly visible.

Sometimes there is no corruption but when a rectangle is displayed it is decomposed into several triangles and there is enough delay between triangles to notice that the rectangle is not displayed atomically.
Comment 22 Laurent Bonnaud 2019-05-09 16:40:24 UTC
My SandyBridge laptop died and my new laptop with a more recent CPU/GPU does not suffer from the same problem.  Therefore, I will not be able to do further tests concerning this bug.
Should I close this bug?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.