Bug 108164 - [radv] VM faults since 5d6a560a2986c9ab421b3c7904d29bb7bc35e36f
Summary: [radv] VM faults since 5d6a560a2986c9ab421b3c7904d29bb7bc35e36f
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: git
Hardware: Other Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2018-10-03 13:06 UTC by Józef Kucia
Modified: 2018-10-04 08:58 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Józef Kucia 2018-10-03 13:06:32 UTC
The problem is reproducible with the vkmodelviewer demo: https://repo.or.cz/vkmodelviewer.git

 --- snip ---
[  367.911268] amdgpu 0000:03:00.0: [gfxhub] VMC page fault (src_id:0 ring:32 vm_id:5 pas_id:0)
[  367.911270] amdgpu 0000:03:00.0:   at page 0x0000000103b20000 from 27
[  367.911270] amdgpu 0000:03:00.0: VM_L2_PROTECTION_FAULT_STATUS:0x00540C40
 --- snip ---

This is a regression caused by the following commit:

commit 5d6a560a2986c9ab421b3c7904d29bb7bc35e36f
Author: Samuel Pitoiset <samuel.pitoiset@gmail.com>
Date:   Tue Sep 25 20:26:58 2018 +0200

    radv: do not use the availability bit for timestamp queries
Comment 1 Samuel Pitoiset 2018-10-04 07:54:31 UTC
What GPU? This looks like Vega?
Comment 2 Józef Kucia 2018-10-04 07:56:59 UTC
(In reply to Samuel Pitoiset from comment #1)
> What GPU? This looks like Vega?

Vega.

 --- snip ---
vendorID       = 0x1002
deviceID       = 0x687f
deviceType     = DISCRETE_GPU
deviceName     = AMD RADV VEGA10 (LLVM 6.0.1)
 --- snip ---
Comment 3 Samuel Pitoiset 2018-10-04 08:21:58 UTC
Polaris is affected as well. I'm looking.
Comment 4 Samuel Pitoiset 2018-10-04 08:42:33 UTC
Does this help https://patchwork.freedesktop.org/patch/254755/ ?
Comment 5 Samuel Pitoiset 2018-10-04 08:58:00 UTC
Should be fixed with https://cgit.freedesktop.org/mesa/mesa/commit/?id=2b34985d93e7914ead00227aa2842846df3c487f

Thanks for the report!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.