Bug 108279 - [Ubuntu 18.10] eDP resolution 640x360 failed on WHLU and ICL-U/Y.
Summary: [Ubuntu 18.10] eDP resolution 640x360 failed on WHLU and ICL-U/Y.
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: James Ausmus
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged, ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-09 01:43 UTC by qwang13
Modified: 2019-04-10 06:46 UTC (History)
1 user (show)

See Also:
i915 platform: CFL, ICL
i915 features: display/eDP


Attachments
gpu hang debug information (22.39 KB, text/plain)
2018-10-09 01:44 UTC, qwang13
no flags Details
kernel startup normally debug information (136.64 KB, text/plain)
2018-10-09 01:44 UTC, qwang13
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description qwang13 2018-10-09 01:43:00 UTC
System Environment
=======
Platform Info:
Label: WHLU01
Processor: Genuine Intel(R) CPU 0000 @ 1.60GHz
Bios: CNLSFWR1.R00.X137.B00.1803280218
OS: Ubuntu 18.10
Kernel: 4.18.0-9-generic

Regression?
=======
seems be

Bug detailed description
=======
Platform Info:
Label: WHLU01
Processor: Genuine Intel(R) CPU 0000 @ 1.60GHz
Bios: CNLSFWR1.R00.X137.B00.1803280218
OS: Ubuntu 18.10
Kernel: 4.17.0-9-generic

Details:
Execute the command "xrandr -s 640x360", the desktop would hang except the mouse can move. The keyboard cannot input anything. At this moment, the ssh is connected.

The dmesg log is null in collected dmesg log when bug occured, so just attach the journalctl log.

Reproduce Steps
==============
xrandr -s "640x360"

Expected Result
=============
work normally

Actual Result
===========
gpu hang

Analysis & Root Cause
===================
Other tens resolution are fine, only 640x360 has the issue. This should be some alignment issue? I will attach dmesg.log and journalctl.log for your analysis.
Comment 1 qwang13 2018-10-09 01:44:08 UTC
Created attachment 141945 [details]
gpu hang debug information
Comment 2 qwang13 2018-10-09 01:44:37 UTC
Created attachment 141946 [details]
kernel startup normally debug information
Comment 3 qwang13 2018-10-09 01:45:16 UTC
Update:
Checked this issue on WHLU01 with upstream kernel v4.19-rc5, this issue reproduced.

When execute xrandr -s 640x360, the desktop would hang. But ssh still works well.

root@WHLU01:~# cat /proc/cmdline 
BOOT_IMAGE=/boot/vmlinuz-4.19.0-rc5+ root=UUID=46ea8678-4edc-4015-8fea-f3f4449054d4 ro drm.debug=0xe quiet splash vt.handoff=1
The dmesg logs include startup of OS (WHL-U_4.19_rc5_dmesg.log ) and issue happened ( dmesg_640x360_4.19.0-rc5_WHLU01.log ) are attached.
Comment 4 Jani Nikula 2018-10-23 11:32:59 UTC
(In reply to qwang13 from comment #0)
> Details:
> Execute the command "xrandr -s 640x360", the desktop would hang except the
> mouse can move. The keyboard cannot input anything. At this moment, the ssh
> is connected.
> 
> The dmesg log is null in collected dmesg log when bug occured, so just
> attach the journalctl log.

There's nothing in the logs that indicate a hang. Please elaborate.
Comment 5 Jani Saarinen 2018-11-02 16:25:18 UTC
What are display connected on this, eDP only or something else too?
Comment 6 Lakshmi 2018-11-12 10:21:39 UTC
Reporter, any comments here?
Comment 7 qwang13 2018-12-12 07:04:05 UTC
(In reply to Jani Saarinen from comment #5)
> What are display connected on this, eDP only or something else too?

eDP(native screen) and DP/HDMI port connected(external monitor)
Comment 8 Jani Saarinen 2018-12-12 13:17:48 UTC
Can you test with eDP only? 
Tested on CI WHL-U http://gfx-ci.fi.intel.com/hardware.html
No issues seen on Ubuntu 18.04. Command worked and no hangs.
Comment 9 Mika Kahola 2018-12-13 12:43:44 UTC
This works on my setup. 

Platform: Intel Corporation Ice Lake Client Platform/IceLake Y LPDDR4x T4 RVP TLC, BIOS ICLSFWR1.R00.2454.A00.1811082216 11/08/2018
Kernel: drm-tip 4.20.0-rc6
OS: Ubuntu 18.04 LTS
Display: eDP (native)
Comment 10 Mika Kahola 2018-12-14 08:39:39 UTC
My setup:
Platform: Intel Corporation Ice Lake Client Platform/IceLake Y LPDDR4x T4 RVP TLC, BIOS ICLSFWR1.R00.2454.A00.1811082216 11/08/2018
Kernel: drm-tip 4.20.0-rc6
OS: Ubuntu 18.04 LTS
Display: eDP (native)
Command 
xrandr -s 640x360
works ok.

Command
xrandr -s 512x288
hangs up after couple of seconds (mouse cursor still works).


The X shows the following log when changing resolution 

[ 140.606] (II) modeset(0): EDID vendor "SHP", prod id 5225
[ 140.606] (II) modeset(0): Printing DDC gathered Modelines:
[ 140.606] (II) modeset(0): Modeline "3200x1800"x0.0 373.25 3200 3248 3280 3360 1800 1803 1808 1852 -hsync -vsync (111.1 kHz eP)
[ 140.894] (II) modeset(0): Allocate new frame buffer 512x288 stride
[ 141.826] (II) modeset(0): EDID vendor "SHP", prod id 5225
[ 141.826] (II) modeset(0): Printing DDC gathered Modelines:
[ 141.826] (II) modeset(0): Modeline "3200x1800"x0.0 373.25 3200 3248 3280 3360 1800 1803 1808 1852 -hsync -vsync (111.1 kHz eP)
Comment 11 Mika Kahola 2019-02-27 08:49:21 UTC
I cannot reproduce this bug with the following setup

My setup:
Platform: Intel Corporation Ice Lake Client Platform/IceLake Y LPDDR4x T4 RVP TLC, BIOS ICLSFWR1.R00.2454.A00.1811082216 11/08/2018
Kernel: drm-tip 5.0.0-rc8
OS: Ubuntu 18.04 LTS
Display: eDP (native)

'xrandr -s 640x360'
works ok.

'xrandr -s 512x288'
works ok
Comment 12 Martin Peres 2019-04-08 11:22:19 UTC
(In reply to Mika Kahola from comment #11)
> I cannot reproduce this bug with the following setup
> 
> My setup:
> Platform: Intel Corporation Ice Lake Client Platform/IceLake Y LPDDR4x T4
> RVP TLC, BIOS ICLSFWR1.R00.2454.A00.1811082216 11/08/2018
> Kernel: drm-tip 5.0.0-rc8
> OS: Ubuntu 18.04 LTS
> Display: eDP (native)
> 
> 'xrandr -s 640x360'
> works ok.
> 
> 'xrandr -s 512x288'
> works ok

Seems like the kernel has fixed the issue, and we have not heard from the bug reporter since December.

Closing the issue, feel free to re-open!
Comment 13 qwang13 2019-04-10 06:46:52 UTC
this bug is fixed on 19.04 (5.0.0)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.