Bug 108307 - Regression: Raven Ridge 2700U does not boot with 4.19-rc7
Summary: Regression: Raven Ridge 2700U does not boot with 4.19-rc7
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-09 22:48 UTC by Samantha McVey
Modified: 2018-10-10 23:50 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Booting with pci noacpi (3.20 MB, image/jpeg)
2018-10-09 23:21 UTC, Samantha McVey
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samantha McVey 2018-10-09 22:48:58 UTC
I have a Lenovo A485. Kernel 4.18.12 works fine for me, but I have tried almost all the RC's (1, 5, 6, 7) and the screen turns black when GRUB would normally be showing "loading initramfs" or it freezes when it's showing "loading initramfs".

lspci -nn
05:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] [1002:15dd] (rev d0)

I found this bug report which seemed similar to what I was experiencing, but my firmware is up to date https://bugs.freedesktop.org/show_bug.cgi?id=107880
[    2.814558] [drm] Found VCN firmware Version: 1.73 Family ID: 18

I tried:  modprobe.blacklist=amdgpu and that did not change anything.

Let me know how I can help troubleshoot this problem. Thanks.
Comment 1 Alex Deucher 2018-10-09 22:57:33 UTC
Can you bisect?  If you set modprobe.blacklist=amdgpu on the kernel command line in grub and you are still getting a problem, it's an issue outside of the graphics driver.  If so, does setting pci=noacpi help?
Comment 2 Samantha McVey 2018-10-09 23:21:05 UTC
Created attachment 141966 [details]
Booting with pci noacpi
Comment 3 Samantha McVey 2018-10-09 23:22:34 UTC
I was able to get something on the screen when I added "pci=noacpi" (this was without blacklisting amdgpu).

[Firmware Bug]: AMD-Vi: No southbridge IOAPIC fonud
AMD-Vi: Disabling interrupt remapping
platform USBC000:00 failed to claim resource 0: [mem ...]
acpi USBC000:00: platform device creation failed: -16
AMD-Vi: Unable to write to IOMMU perf counter.
...

I uploaded an attachment which shows the full output (I only typed out the first several lines).

I might be able to bisect if needed. Does the image I uploaded show you anything useful?
Comment 4 Samantha McVey 2018-10-10 01:50:50 UTC
I just tested on the latest git (v4.19-rc7-15-g64c5e530ac2c) and I didn't see any issues. So the issue has been either fixed between 4.19-rc7 and latest git or something in the kernel config is different.
Comment 5 Alex Deucher 2018-10-10 15:03:57 UTC
Sounds like it may be related to:
https://bugzilla.kernel.org/show_bug.cgi?id=200087
Comment 6 Samantha McVey 2018-10-10 23:50:37 UTC
It turns out it is config related, as I compiled the kernel with my old config instead of a minimal one, and I had the same boot issue. I posted about my issue here https://bugzilla.kernel.org/show_bug.cgi?id=200087 since that may be the same bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.