Bug 108318 - [Polaris] Glitches in New Super Mario Brothers U in Cemu on Polaris and Tahiti (maybe more)
Summary: [Polaris] Glitches in New Super Mario Brothers U in Cemu on Polaris and Tahit...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-10 15:25 UTC by John Galt
Modified: 2019-09-25 18:27 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg from boot to the issue (70.23 KB, text/plain)
2018-10-10 15:25 UTC, John Galt
Details
xorg log (58.26 KB, text/x-log)
2018-10-10 15:25 UTC, John Galt
Details
glxinfo (144.58 KB, text/plain)
2018-10-10 15:26 UTC, John Galt
Details
screenshot of the issue (2.21 MB, image/png)
2018-10-10 15:26 UTC, John Galt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Galt 2018-10-10 15:25:05 UTC
Created attachment 141980 [details]
dmesg from boot to the issue

This is a semi recent (within the last few months) bug on Polaris in NSMBU. Many polygons (maybe?) have major glitches across the screen, or don't show up at all. This doesn't occur on Tahiti or Pitcairn. I've gone back to 18.2.1 and verified it still exists, so it must be prior. It also exists on both linux 4.18.12 and the amdgpu-staging-drm-next branch. I'll continue attempting to bisect, unless someone else knows exactly what the issue is.

There are quite a few GPU faults listed in the attached dmesg, though I'm not sure if they're related to the issue. Glxinfo, Xorg.0.log, as well as a screenshot of the issue.
Comment 1 John Galt 2018-10-10 15:25:38 UTC
Created attachment 141981 [details]
xorg log
Comment 2 John Galt 2018-10-10 15:26:15 UTC
Created attachment 141982 [details]
glxinfo
Comment 3 John Galt 2018-10-10 15:26:56 UTC
Created attachment 141983 [details]
screenshot of the issue
Comment 4 John Galt 2018-10-10 15:29:22 UTC
I forgot to mention, if IRC works better for communication for anyone, I'm TheRealJohnGalt on Freenode #radeon.
Comment 5 John Galt 2018-10-10 20:04:39 UTC
I was incorrect, this also happens on Tahiti now.
Comment 6 Alex Deucher 2018-10-10 20:08:10 UTC
Seems more likely to be an LLVM or Mesa bug than a kernel one.
Comment 7 John Galt 2018-10-10 20:21:03 UTC
(In reply to Alex Deucher from comment #6)
> Seems more likely to be an LLVM or Mesa bug than a kernel one.

I went back to 4.18.7 and it persisted, so you're correct. It was okay early on at 18.2.0 with llvm svn. I'll go back to 18.2.0 to test, and if it's broken then we know it's llvm.
Comment 8 John Galt 2018-10-10 20:41:29 UTC
I attempted to bisect in Mesa, and found that I wasn't able to get rid of the glitch. The regression must be in LLVM.
Comment 9 John Galt 2018-10-25 14:46:35 UTC
R600_DEBUG=nir works around this issue. If requested, I can provide apidoc of this rendering issue.
Comment 10 Timothy Arceri 2019-07-03 00:39:06 UTC
Is this still an issue with the development version of LLVM 9.0 ? There have been many LLVM bug fixes since this issue was reported.
Comment 11 GitLab Migration User 2019-09-25 18:27:54 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1335.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.