Bug 108383 - [CI][DRMTIP] igt@kms_setmode@invalid-clone-exclusive-crtc - warn - no modes for connector 83
Summary: [CI][DRMTIP] igt@kms_setmode@invalid-clone-exclusive-crtc - warn - no modes f...
Status: NEW
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-16 08:06 UTC by Martin Peres
Modified: 2018-11-30 18:32 UTC (History)
1 user (show)

See Also:
i915 platform: ICL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-10-16 08:06:41 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_128/fi-icl-u2/igt@kms_setmode@invalid-clone-exclusive-crtc.html

Starting subtest: invalid-clone-exclusive-crtc
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
(kms_setmode:926) igt_kms-WARNING: no modes for connector 83
Subtest invalid-clone-exclusive-crtc: SUCCESS (0.001s)
Comment 2 Imre Deak 2018-11-30 18:32:49 UTC
Something fishy with framebuffer takeover from BIOS

<7>[   12.661656] [drm:drm_setup_crtcs] looking for preferred mode on connector 83 0
<7>[   12.661661] [drm:drm_setup_crtcs] found mode 3840x2160
<7>[   12.661666] [drm:drm_setup_crtcs] looking for cmdline mode on connector 101
<7>[   12.661671] [drm:drm_setup_crtcs] looking for preferred mode on connector 101 0
<7>[   12.661675] [drm:drm_setup_crtcs] found mode 1920x1080
<7>[   12.661681] [drm:drm_setup_crtcs] picking CRTCs for 8192x8192 config
<7>[   12.664943] [drm:drm_setup_crtcs] desired mode 3840x2160 set on crtc 45 (0,0)
<7>[   12.664965] [drm:drm_setup_crtcs] desired mode 1920x1080 set on crtc 63 (0,0)
<7>[   12.665080] [drm:intelfb_create [i915]] re-using BIOS fb
<7>[   12.665274] [drm:intelfb_create [i915]] allocated 1920x1080 fb: 0x00000000

instead of which we should throw away it and create a new one, followed by pruning the eDP mode during fbdev probing:

<7>[   12.691895] [drm:drm_mode_debug_printmodeline] Modeline 84:"3840x2160" 60 533250 3840 3888 3920 4000 2160 2163 2168 2222 0x48 0xa
<7>[   12.691901] [drm:drm_mode_prune_invalid] Not using 3840x2160 mode: VIRTUAL_X

which leads to no modes returned to the test. Looks like the test should do a full reprobe, but instead it gets the cached version of the previously pruned mode list.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.