Bug 108508 - Graphic glitches with stream output support on OLAND AMD GPU GCN 1.0
Summary: Graphic glitches with stream output support on OLAND AMD GPU GCN 1.0
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-21 22:38 UTC by Ahmed Elsayed
Modified: 2018-11-07 21:19 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
The Witcher 3 (958.01 KB, image/png)
2018-10-21 22:38 UTC, Ahmed Elsayed
Details
Mafia 3 (788.68 KB, image/png)
2018-10-21 22:42 UTC, Ahmed Elsayed
Details
Mafia III (963.57 KB, image/png)
2018-10-22 23:06 UTC, Ahmed Elsayed
Details
Mafia 3 after the last update (771.29 KB, image/png)
2018-10-30 06:05 UTC, Ahmed Elsayed
Details
GPU hang report for Mafia III. (5.15 KB, text/plain)
2018-11-05 11:12 UTC, Ahmed Elsayed
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ahmed Elsayed 2018-10-21 22:38:03 UTC
Created attachment 142123 [details]
The Witcher 3

System information:

CPU: Inter core I5 4200M
RAM: 6 GB
GPU: AMD HD 8750M
Driver: Mesa 18.3 with the RADV patches for VK_EXT_transform_feedback
https://aur.archlinux.org/packages/mesa-transform-feedback-git
Wine version: esync-staging-pba-3.18
DXVK version: 0.90

Games like The Witcher 3 and Mafia 3 produce weird graphic shapes after using Mesa 18.3 with the RADV patches for VK_EXT_transform_feedback.
Comment 1 Ahmed Elsayed 2018-10-21 22:42:11 UTC
Created attachment 142124 [details]
Mafia 3

The faces looks weird and the games is unplayable.
Comment 2 Timothy Arceri 2018-10-21 23:59:26 UTC
Thanks for testing, although its kind of strange to use bugzilla to report issues in patches that have not landed yet. You may wish to report this type of thing on the mailing list in future.

Anyway my guess is this could be due to us not keeping the xfb varyings in sync. I've made a few suggestions to Samuel in this area during review and hopefully it will fix these issues for you.

I'll leave this bug open for now but we expect a v2 of this series so keep an eye out.
Comment 3 Ahmed Elsayed 2018-10-22 09:37:24 UTC
Thanks. Where is the mailing list?
Comment 4 Ahmed Elsayed 2018-10-22 09:38:48 UTC
I am sorry. You mean mesa-dev@lists.freedesktop.org ?
Comment 5 Alex Deucher 2018-10-22 18:17:46 UTC
(In reply to Ahmed Elsayed from comment #4)
> I am sorry. You mean mesa-dev@lists.freedesktop.org ?

Correct.
Comment 6 Ahmed Elsayed 2018-10-22 23:06:55 UTC
Created attachment 142145 [details]
Mafia III

It gets better and better :D
Comment 7 Ahmed Elsayed 2018-10-24 11:31:24 UTC
Does Mesa 18.2.4 secdueled to release at the end of Oct will have VK_EXT_transform_feedback patches?
Comment 8 Samuel Pitoiset 2018-10-24 11:57:06 UTC
No, 18.2.X are bugfixes releases, we don't backport features. We might be able to merge it in time for 18.3.
Comment 9 Ahmed Elsayed 2018-10-24 13:45:43 UTC
(In reply to Samuel Pitoiset from comment #8)
> No, 18.2.X are bugfixes releases, we don't backport features. We might be
> able to merge it in time for 18.3.

So it will land on December or may be sooner than that?
Comment 10 Samuel Pitoiset 2018-10-29 16:14:41 UTC
VK_EXT_transform_feedback is upstream. Please rebase and try to reproduce your problem now. Thanks!
Comment 11 Ahmed Elsayed 2018-10-30 05:59:00 UTC
I made a system restore to roll back to the stable Mesa release, and installed the new Mesa 18.3 driver released yesterday.

The Witcher III: still the same.

Mafia III: the graphic glitches decreased but still exist.
Comment 12 Ahmed Elsayed 2018-10-30 06:05:49 UTC
Created attachment 142271 [details]
Mafia 3 after the last update

It looks better now, but still needs some improvements.
Comment 13 Samuel Pitoiset 2018-10-30 09:09:06 UTC
Can you please record a renderdoc capture of the problem?
Comment 14 Ahmed Elsayed 2018-10-30 15:44:54 UTC
I tried many times to record both games with DXVK on but it failed to run. But when I opened both games with DXVK off, the textures were very dark but there were no graphic glitches.
Comment 15 Ahmed Elsayed 2018-10-30 18:42:21 UTC
It crashes with DXVK because I use the Windows version of RenderDoc. I will use the Linux version of RenderDoc.
Comment 16 Vladimir 2018-10-31 04:22:24 UTC
renderdoccmd wine game.exe crashing too?
Comment 17 Ahmed Elsayed 2018-10-31 09:43:25 UTC
(In reply to Vladimir from comment #16)
> renderdoccmd wine game.exe crashing too?

The stable version (1.1) doesn't crash but it doesn't show the objects effected by VK_EXT_transform_feedback, so it doesn't help at all.

The last version in github crashes at the beginning of loading the game. I guess it is a problem between the last Vulkan version + renderdoc.

Can I just record in OpenGL mode instead of Vulkan? Would that helps in any way?
Comment 18 Samuel Pitoiset 2018-10-31 10:52:13 UTC
Yes, please use apitrace if renderdoc crashes.
Comment 19 Ahmed Elsayed 2018-10-31 20:19:21 UTC
RenderDoc (OpenGL) record of The Witcher 3

https://drive.google.com/open?id=19lmkh1v7LfkdMELU98DnituhF3Rj-Za7
Comment 20 Ahmed Elsayed 2018-11-01 13:41:21 UTC
Is this record enough or do you need something else? Please, tell me.
Comment 21 Ahmed Elsayed 2018-11-02 22:13:06 UTC
After updating Kernel to 4.19, the problem is fixed!
Comment 22 Ahmed Elsayed 2018-11-05 11:11:34 UTC
Actually, that fixed The Witcher III, but Mafia III doesn't start at all, I will upload GPU hand report.
Comment 23 Ahmed Elsayed 2018-11-05 11:12:31 UTC
Created attachment 142366 [details]
GPU hang report for Mafia III.
Comment 24 Samuel Pitoiset 2018-11-07 20:19:23 UTC
You closed the DXVK issue, what's the status of this bug report?
Comment 25 Ahmed Elsayed 2018-11-07 21:13:35 UTC
With kernel 4.19 all the games need transform_feedback work well except Mafia III which I don't have it any more. Sorry for bothering you and thanks for trying to help me. Have a good day.
Comment 26 Ahmed Elsayed 2018-11-07 21:19:53 UTC
One more thing that I forgot to add: All the games that I used with Wined3d, the textures are so dark. It is described in this issue:

https://bugs.winehq.org/show_bug.cgi?id=46073


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.