Bug 108528 - [CI][BAT] igt@* - dmesg-warn - Unclaimed read from register 0x138118
Summary: [CI][BAT] igt@* - dmesg-warn - Unclaimed read from register 0x138118
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Chris Wilson
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 109166 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-10-23 11:09 UTC by Martin Peres
Modified: 2019-03-08 10:34 UTC (History)
1 user (show)

See Also:
i915 platform: BYT
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-10-23 11:09:41 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_1974/fi-byt-j1900/igt@drv_selftest@live_coherency.html

<4> [369.598081] ------------[ cut here ]------------
<4> [369.598478] Unclaimed read from register 0x138118
<4> [369.598682] WARNING: CPU: 1 PID: 34 at drivers/gpu/drm/i915/intel_uncore.c:1093 __unclaimed_reg_debug+0x40/0x50 [i915]
<4> [369.598691] Modules linked in: i915(+) amdgpu chash gpu_sched ttm vgem snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic btusb btrtl btbcm btintel coretemp bluetooth crct10dif_pclmul crc32_pclmul ghash_clmulni_intel ecdh_generic r8169 lpc_ich snd_hda_codec snd_hwdep snd_hda_core i2c_hid snd_pcm prime_numbers [last unloaded: i915]
<4> [369.598905] CPU: 1 PID: 34 Comm: kworker/1:1 Tainted: G     U            4.19.0-rc8-CI-CI_DRM_5013+ #1
<4> [369.598913] Hardware name: GIGABYTE GB-BXBT-1900/MZBAYAB-00, BIOS F6 02/17/2015
<4> [369.599034] Workqueue: events gen6_pm_rps_work [i915]
<4> [369.599177] RIP: 0010:__unclaimed_reg_debug+0x40/0x50 [i915]
<4> [369.599188] Code: 74 05 5b 5d 41 5c c3 45 84 e4 48 c7 c0 b6 a0 c4 a0 48 c7 c6 ac a0 c4 a0 48 0f 44 f0 89 ea 48 c7 c7 bf a0 c4 a0 e8 00 91 51 e0 <0f> 0b 83 2d d7 70 19 00 01 5b 5d 41 5c c3 66 90 41 56 41 55 41 89
<4> [369.599196] RSP: 0018:ffffc9000013bdc8 EFLAGS: 00010086
<4> [369.599211] RAX: 0000000000000000 RBX: 0000000000000000 RCX: 0000000000000002
<4> [369.599219] RDX: 0000000080000002 RSI: ffffffff820c309e RDI: 00000000ffffffff
<4> [369.599227] RBP: 0000000000138118 R08: 0000000000000000 R09: 0000000000000001
<4> [369.599234] R10: ffffc9000013bd60 R11: 0000000000000000 R12: 0000000000000001
<4> [369.599242] R13: 0000000000000001 R14: 000000000054b987 R15: 0000000000000206
<4> [369.599251] FS:  0000000000000000(0000) GS:ffff88013ba80000(0000) knlGS:0000000000000000
<4> [369.599259] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4> [369.599267] CR2: 0000562de6800690 CR3: 0000000121638000 CR4: 00000000001006e0
<4> [369.599274] Call Trace:
<4> [369.599418]  fwtable_read32+0x1e8/0x250 [i915]
<4> [369.599551]  gen6_pm_rps_work+0x164/0x2f0 [i915]
<4> [369.599581]  process_one_work+0x245/0x610
<4> [369.599613]  worker_thread+0x37/0x380
<4> [369.599632]  ? process_one_work+0x610/0x610
<4> [369.599642]  kthread+0x119/0x130
<4> [369.599653]  ? kthread_park+0x80/0x80
<4> [369.599671]  ret_from_fork+0x3a/0x50
<4> [369.599712] irq event stamp: 1404740
<4> [369.599724] hardirqs last  enabled at (1404739): [<ffffffff81119240>] ktime_get_raw+0xd0/0xf0
<4> [369.599734] hardirqs last disabled at (1404740): [<ffffffff8194112d>] _raw_spin_lock_irqsave+0xd/0x50
<4> [369.599744] softirqs last  enabled at (1404326): [<ffffffff81c0031d>] __do_softirq+0x31d/0x483
<4> [369.599755] softirqs last disabled at (1404307): [<ffffffff8108c539>] irq_exit+0xa9/0xc0
<4> [369.599890] WARNING: CPU: 1 PID: 34 at drivers/gpu/drm/i915/intel_uncore.c:1093 __unclaimed_reg_debug+0x40/0x50 [i915]
<4> [369.599899] ---[ end trace 4e087b32183028b4 ]---
Comment 1 Chris Wilson 2018-10-23 11:11:45 UTC
https://patchwork.freedesktop.org/patch/256212/
Comment 2 Francesco Balestrieri 2018-10-29 08:46:23 UTC
If I'm reading things correctly, the fix for this is part of an unmerged series of 123 patches. Given that this is a highest priority bug, would it be possible to take the fix out of the series and submit it separately?
Comment 3 Francesco Balestrieri 2018-11-07 08:39:39 UTC
Should this be tagged as BYT-only?
Comment 4 Martin Peres 2018-11-07 09:31:24 UTC
(In reply to Francesco Balestrieri from comment #3)
> Should this be tagged as BYT-only?

It is. We agreed to only use the platform field. Some bugs also explicitely mention this will be only for a platform, but this is not the intent for this bug (it may start being visible on others).
Comment 5 Chris Wilson 2018-11-07 09:36:54 UTC
No, it affects all gen6+ platforms, it's just detectable on byt.
Comment 6 Francesco Balestrieri 2018-11-20 08:46:17 UTC
I'm looking at the CI logs and this hasn't occurred once in the last 429 runs (if I'm reading correctly). Is it still a valid issue? If yes, at least the priority doesn't seem right.
Comment 7 Francesco Balestrieri 2018-11-27 08:59:25 UTC
482 runs, no occurrence. Moving to high.
Comment 8 Francesco Balestrieri 2019-01-07 09:52:06 UTC
*** Bug 109166 has been marked as a duplicate of this bug. ***
Comment 9 Francesco Balestrieri 2019-03-01 11:57:18 UTC
Still no reported failure in CI. Resolving.
Comment 10 CI Bug Log 2019-03-08 10:34:26 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.