Bug 108557 - [skl] GPU HANG: ecode 9:0:0x84df7cfc, in Web Content [2207]
Summary: [skl] GPU HANG: ecode 9:0:0x84df7cfc, in Web Content [2207]
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-26 08:39 UTC by bugmenot
Modified: 2019-02-06 12:35 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error (42.38 KB, application/x-xz)
2018-10-26 08:39 UTC, bugmenot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugmenot 2018-10-26 08:39:31 UTC
Created attachment 142210 [details]
/sys/class/drm/card0/error

Interacting with a website in which a self-hosted potree.org visualisation is shown. I can reproduce it by zooming and panning around, it is not happening at a fixed location in the 3D space nor a specific interaction from what I can tell. Website was opened in Firefox, display hanged, then resumed.

-- system architecture: x86_64
-- kernel version: 4.18.14-arch1-1-ARCH
-- Linux distribution: Archlinux
-- Machine or mother board model: FUJITSU.LIFEBOOK S936
-- Display connector: 3 screens:
eDP1 connected primary 1280x720+1920+0
DP1-1 connected 1200x1920+3200+0 left
DP1-2 connected 1920x1080+0+0

The browser window was on DP1-2 every time I had this happen.


dmesg said:

[ 1041.334987] [drm] GPU HANG: ecode 9:0:0x84df7cfc, in Web Content [2207], reason: hang on rcs0, action: reset
[ 1041.334989] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 1041.334989] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 1041.334990] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 1041.334990] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 1041.334991] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 1041.335012] i915 0000:00:02.0: Resetting rcs0 for hang on rcs0

/sys/class/drm/card0/error is attached as error.xz to this report
Comment 1 Denis 2018-10-26 10:31:53 UTC
hi, I am not sure that I am reproducing completely the same hang, but I got a crash (stable, right away after opening first example, Animation Path) of my desktop env, using mesa 18.2.1 (in your case, I guess, you have 18.2.2)

Could you please compile or download latest mesa (18.3.0) and check?

Because the same site (and it's models) can be opened normally on 18.3.0-devel (from Padoka PPA)
Comment 2 Denis 2019-01-31 14:46:19 UTC
Hey, did you try what I suggested? Is this issue still actual for you?
Comment 3 bugmenot 2019-02-06 12:35:31 UTC
I tried to reproduce it now, mesa is 18.3.2. I could not reproduce it.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.