Bug 108560 - Mesa 32 is built without sse
Summary: Mesa 32 is built without sse
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
: 108610 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-10-26 09:56 UTC by Sergii Romantsov
Modified: 2018-11-05 12:35 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergii Romantsov 2018-10-26 09:56:55 UTC
While building of 32bit Mesa gcc doesn't specifies __SSE__ by default.
So it has to be done manually by flag '-msee'.

Additionally for autotools is missed library-dependency that causes impossibility to build
Comment 1 Sergii Romantsov 2018-10-26 10:06:45 UTC
Patch series for meson and autoconf: https://patchwork.freedesktop.org/series/51585/
Comment 2 Sergii Romantsov 2018-10-30 11:05:53 UTC
Seems series is not valid.
Only one patch may be used: https://patchwork.freedesktop.org/patch/259176/

It fixes error:
../../src/util/.libs/libmesautil.a(libmesautil_la-half_float.o): In function `_mesa_lroundevenf':
/home/test/Work/mesa/src/util/rounding.h:108: undefined reference to `lrintf'
collect2: error: ld returned 1 exit status
Comment 3 Sergii Romantsov 2018-11-01 07:42:01 UTC
*** Bug 108610 has been marked as a duplicate of this bug. ***
Comment 4 Sergii Romantsov 2018-11-05 12:35:43 UTC
commit ce837a537282f10bc48c4ac426fa9a31241beea2
Author: Sergii Romantsov <sergii.romantsov@gmail.com>
Date:   Thu Nov 1 13:02:43 2018 +0200

    autotools: library-dependency when no sse and 32-bit


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.