Bug 108578 - RADV reports wrong hardcoded Vulkan API Version
Summary: RADV reports wrong hardcoded Vulkan API Version
Status: RESOLVED NOTABUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: git
Hardware: Other All
: medium trivial
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-28 03:32 UTC by bmilreu
Modified: 2018-12-13 19:38 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
vulkaninfo output (98.65 KB, text/plain)
2018-10-28 03:32 UTC, bmilreu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bmilreu 2018-10-28 03:32:05 UTC
Created attachment 142240 [details]
vulkaninfo output

Apps that get additional info like DXVK HUD or vulkaninfo reports Vulkan=1.1.70 because it is hardcoded as so in https://gitlab.freedesktop.org/mesa/mesa/blob/master/src/amd/vulkan/radv_extensions.py#L34
Comment 1 Shmerl 2018-10-28 17:01:02 UTC
Generated ICD (radeon_icd.x86_64.json) looks like this for me (Mesa master):

    "ICD": {
            "api_version": "1.1.70",
            ...
Comment 2 Bas Nieuwenhuizen 2018-10-28 20:33:31 UTC
Why do you think it is wrong?

We hardcode it because every version bump we need to see if we have implemented the non-extension API changes+bugfixes in the driver, and apparently the last time we did that we did so for up to 1.1.70.
Comment 3 bmilreu 2018-10-29 00:51:35 UTC
I still don't understand the reasoning. The version referenced here https://gitlab.freedesktop.org/mesa/mesa/commit/13fd4e601c80b85317feac894c52bd24e4f98c09 for instance is different (1.1.88).

By non-extension you mean just the icd loader?
Comment 4 Samuel Pitoiset 2018-12-05 10:36:14 UTC
This is not a bug. We should be able to bump the patch version but that requires to look at the changelog since 1.1.70.
Comment 5 Shmerl 2018-12-09 19:50:55 UTC
(In reply to Samuel Pitoiset from comment #4)
> This is not a bug. We should be able to bump the patch version but that
> requires to look at the changelog since 1.1.70.

Do you mean it's a review issue, i.e. someone needs to go over it and confirm that all needed features are supported?
Comment 6 Samuel Pitoiset 2018-12-10 09:27:59 UTC
Yes, exactly.
Comment 7 Shmerl 2018-12-13 12:24:10 UTC
For those following this, reported API version should be now at 1.1.90:

https://gitlab.freedesktop.org/mesa/mesa/commit/2ac6d55f38c1665a16d8d02675df2e3a858a7fec
Comment 8 bmilreu 2018-12-13 19:38:20 UTC
@Samuel Pitoiset Still reports 1.1.70, this function wasn't updated.

line 292 of rad_extensions.py:

uint32_t
radv_physical_device_api_version(struct radv_physical_device *dev)
{
    if (!ANDROID && dev->rad_info.has_syncobj_wait_for_submit)
        return VK_MAKE_VERSION(1, 1, 70);
    return VK_MAKE_VERSION(1, 0, 68);
}
""")


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.