Bug 108587 - [CI][SHARDS] igt@perf@blocking - fail - Failed assertion: kernel_ns <= (test_duration_ns / 100ull)
Summary: [CI][SHARDS] igt@perf@blocking - fail - Failed assertion: kernel_ns <= (test_...
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords: regression
Depends on:
Blocks:
 
Reported: 2018-10-29 11:29 UTC by Martin Peres
Modified: 2019-04-26 12:05 UTC (History)
2 users (show)

See Also:
i915 platform: ICL
i915 features: Perf/OA


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-10-29 11:29:26 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_134/fi-icl-u2/igt@perf@blocking.html

Starting subtest: blocking
(perf:2260) CRITICAL: Test assertion failure function test_blocking, file ../tests/perf.c:2153:
(perf:2260) CRITICAL: Failed assertion: kernel_ns <= (test_duration_ns / 100ull)
Subtest blocking failed.
Comment 1 Martin Peres 2018-10-29 11:30:25 UTC
Also seen on the following run, which suggests a regression: https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_135/fi-icl-u2/igt@perf@blocking.html
Comment 2 Jani Saarinen 2019-01-18 22:55:09 UTC
Last seen on 135. Lionel, how do you see this?
Comment 3 Jani Saarinen 2019-01-18 22:56:01 UTC
I think this regression was fixed?
Comment 5 CI Bug Log 2019-03-12 10:24:42 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@perf@blocking - fail - Failed assertion: kernel_ns &lt;= (test_duration_ns / 100ull) -}
{+ ICL: igt@perf@blocking|polling - fail - Failed assertion: kernel_ns &lt;= (test_duration_ns / 100ull) +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5729/shard-iclb4/igt@perf@polling.html
Comment 6 Martin Peres 2019-04-23 12:56:33 UTC
Bumping the priority to high, since it also happens on shards!
Comment 7 Lakshmi 2019-04-25 13:02:59 UTC
On shards runs (CI_DRM) on an average this issue used to happen once in 6 runs. Last seen 96 runs ago. Where as in drmtip runs, this issue used to occur once in 4 drmtip runs and last seen 14 drmtip runs ago (drmtip_250).

Can we drop the priority to Medium?
Comment 8 Martin Peres 2019-04-26 12:04:51 UTC
This used to happen every other IGT run (every 1.7 runs), now not seen for 32 runs. Closing!
Comment 9 CI Bug Log 2019-04-26 12:05:01 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.