Bug 108614 - [snb] Random system freezes. GPU hang on rcs0
Summary: [snb] Random system freezes. GPU hang on rcs0
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 18.2
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-31 20:18 UTC by Gustavo
Modified: 2019-09-25 19:14 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
GPU Crash Dump (53.88 KB, text/plain)
2018-10-31 20:18 UTC, Gustavo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo 2018-10-31 20:18:03 UTC
Created attachment 142307 [details]
GPU Crash Dump

Using Kubuntu 18.10 on Kernel version: 4.18.0-10-generic

While using the system, random freezes are occuring, lasting from 5 to 20 seconds, mouse keeps working but everything else is unresponsive. KWin crashes and restarts, and the notification pops: "KWin: Desktop effects were restarted due to a graphics reset". I'm having around 5-6 crashes on a 10 minute period.

Running dmesg I get:

[  920.806022] [drm] GPU HANG: ecode 6:0:0x87e8effd, in chrome [4579], reason: hang on rcs0, action: reset
[  920.806024] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[  920.806024] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[  920.806025] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[  920.806025] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[  920.806026] [drm] GPU crash dump saved to /sys/class/drm/card0/error


and a bunch of:

[  920.806092] i915 0000:00:02.0: Resetting chip for hang on rcs0
[  976.832401] i915 0000:00:02.0: Resetting chip for hang on rcs0
[ 1049.792379] i915 0000:00:02.0: Resetting chip for hang on rcs0
[ 1085.792388] i915 0000:00:02.0: Resetting chip for hang on rcs0
[ 1093.792021] i915 0000:00:02.0: Resetting chip for hang on rcs0
[ 1101.792036] i915 0000:00:02.0: Resetting chip for hang on rcs0
[ 1171.840381] i915 0000:00:02.0: Resetting chip for hang on rcs0
[ 1198.784395] i915 0000:00:02.0: Resetting chip for hang on rcs0
[ 1213.824390] i915 0000:00:02.0: Resetting chip for hang on rcs0
[ 1227.808413] i915 0000:00:02.0: Resetting chip for hang on rcs0
[ 1235.808051] i915 0000:00:02.0: Resetting chip for hang on rcs0
[ 1243.808052] i915 0000:00:02.0: Resetting chip for hang on rcs0
[ 1293.792374] i915 0000:00:02.0: Resetting chip for hang on rcs0


Tried to upgrade from mesa 18.2.2 to 18.2.3 but didn't solve the problem.

The GPU Crash dump is attatched.
Comment 1 Chris Wilson 2018-10-31 21:02:17 UTC
One of those fun little snb bugs where the CS keeps on going but the GPU stops responding.
Comment 2 Georg 2018-12-10 09:51:47 UTC
I have a 'gpu hang' issue as well. May be a different or the same root cause. My investigation to my situation shows that this is directly or indirectly a kernel issue. See here: https://bugs.freedesktop.org/show_bug.cgi?id=107420.
Comment 3 GitLab Migration User 2019-09-25 19:14:57 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1768.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.