Bug 108650 - In some games cursor is either invisible or with artifacts
Summary: In some games cursor is either invisible or with artifacts
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/AMDgpu (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-04 11:18 UTC by Mariusz Ceier
Modified: 2018-11-15 15:54 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mariusz Ceier 2018-11-04 11:18:51 UTC
Cursor in Pathfinder:Kingmaker has artifacts, in Hands of Fate 2 is invisible, and in Gremlins is barely visible.

I have R9 Fury X with 2 monitors and I'm using mesa-19.0.0 from git ( 5c0cff868a48202df1ddb30d1dca848101063cb6 ), xorg-server 1.20.99.1 from git ( c901adc327bce4c0d19caf350cbcb0cd5254f306 ), libdrm from git ( 0be850441f24c55cf5a2f1ce3b33457add685b96 ), kernel-4.19.0 ( 5f21585384a4a69b8bfdd2cae7e3648ae805f57d ) and xf86-video-amdgpu from git ( 1cb338253af9c539fc1f13fc12b255ed6303f8b1 ).

I saw there was patch 2 weeks ago that tried to fix cursor in the Civilization VI ( ad6dfb0124860cf67730bde85867f81d9258c84d, "Detect and fix up non-premultiplied cursor data" ) and I tried to revert it but this didn't fix issue with the games mentioned above.
Comment 1 Michel Dänzer 2018-11-05 16:54:49 UTC
Does reverting https://gitlab.freedesktop.org/xorg/xserver/commit/b45c74f0f2868689e7ed695b33e8c60cd378df0b as well help?

Please attach the corresponding Xorg log file and the output of dmesg.
Comment 2 Mariusz Ceier 2018-11-05 22:36:11 UTC
Yes, reverting both patches fixes the issue in these 3 games.
Tomorrow I can also check Civilization VI (have to install it first, but its late today).
Comment 3 Mariusz Ceier 2018-11-05 22:38:54 UTC
Do you still need Xorg.log and dmesg ?
Comment 4 Michel Dänzer 2018-11-06 11:13:05 UTC
(In reply to Mariusz Ceier from comment #3)
> Do you still need Xorg.log and dmesg ?

No, thanks.

Merge requests addressing this issue:

https://gitlab.freedesktop.org/xorg/xserver/merge_requests/67
https://gitlab.freedesktop.org/xorg/driver/xf86-video-amdgpu/merge_requests/10
Comment 5 Mariusz Ceier 2018-11-06 15:05:43 UTC
So cursor in Civilization VI also doesn't have artifacts when both patches (ad6dfb0124860cf67730bde85867f81d9258c84d in xf86-video-amdgpu and b45c74f0f2868689e7ed695b33e8c60cd378df0b in xserver) are reverted.


I also tried patches from merge requests (that is revert of b45c74f0f2868689e7ed695b33e8c60cd378df0b in xserver and ad6dfb0124860cf67730bde85867f81d9258c84d with new patch in xf86-video-amdgpu) and cursor is displayed properly in these 4 games I tried - so these MRs fix the issue for me.
Comment 6 Michel Dänzer 2018-11-15 15:54:23 UTC
Thanks for the report, fixed in Git master:

commit 426f9a49655f01863cf4d898f525e5f95984e0c4
Author: Michel Dänzer <michel.daenzer@amd.com>
Date:   Tue Nov 6 12:06:20 2018 +0100

    Relax detection of non-premultiplied alpha cursor data


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.