Bug 108702 - Screen flickering in Ubuntu 18.04 on a 4k laptop screen.
Summary: Screen flickering in Ubuntu 18.04 on a 4k laptop screen.
Status: CLOSED DUPLICATE of bug 108132
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) All
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-09 19:45 UTC by Mridul
Modified: 2018-11-19 20:57 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mridul 2018-11-09 19:45:22 UTC
I have a lenovo ideapad 720s (4k screeen). I installed ubuntu on dual boot and with ubuntu there is a weird screen flickering which comes right after grub menu and persists. I have never faced this on Windows and therefore driver issues can be ruled out.

I have tried different os : fedora, mint, ubuntu and the issue persists with all. here is a video for the same : 

https://www.youtube.com/watch?v=Fz7JkVIMPlk

there is a similar bug on https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1785912 wherein it was asked to raise it here.

Kindly help me!
Comment 1 Mridul 2018-11-09 19:54:26 UTC
  *-display                 
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: iomemory:2f0-2ef iomemory:2f0-2ef irq:127 memory:2ff2000000-2ff2ffffff memory:2fc0000000-2fcfffffff ioport:3000(size=64) memory:c0000-dffff
Comment 2 Mridul 2018-11-09 19:55:22 UTC
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07)
	Subsystem: Lenovo UHD Graphics 620 [17aa:39af]
	Kernel driver in use: i915
	Kernel modules: i915
Comment 3 Mazin 2018-11-10 12:10:25 UTC
This bug is a duplicate of 108132,

*** This bug has been marked as a duplicate of bug 108132 ***
Comment 4 Mazin 2018-11-10 17:00:18 UTC
If you could post any findings or provide help on that bug, that would be great. I'm not a dev here.
Comment 5 Mridul 2018-11-10 19:08:33 UTC
Hi Mazin!

So the flickering only occurs for some time after the screen wakes (ie. either from hibernation, screen lock(when screen turns black) or a boot). I have seen that on battery, the flicker vanishes pretty quickly than when plugged in.

Also, once stabilized, the flicker is not observed in that session till the screen turns black (lock, hibernate, boot).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.