Bug 108723 - [CI][BAT] igt@gem_exec_suspend@basic-s4-devices - fail - Freezing of tasks failed after 20.002 seconds (3 tasks refusing to freeze, wq_busy=0)
Summary: [CI][BAT] igt@gem_exec_suspend@basic-s4-devices - fail - Freezing of tasks fa...
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: low normal
Assignee: Francesco Balestrieri
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-13 13:21 UTC by Martin Peres
Modified: 2019-11-05 10:34 UTC (History)
1 user (show)

See Also:
i915 platform: GLK, SKL
i915 features: power/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-11-13 13:21:09 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5127/fi-glk-dsi/igt@gem_exec_suspend@basic-s4-devices.html

Starting subtest: basic-S4-devices
(gem_exec_suspend:2312) igt_aux-CRITICAL: Test assertion failure function suspend_via_sysfs, file ../lib/igt_aux.c:794:
(gem_exec_suspend:2312) igt_aux-CRITICAL: Failed assertion: igt_sysfs_set(power_dir, "state", suspend_state_name[state])
(gem_exec_suspend:2312) igt_aux-CRITICAL: Last errno: 16, Device or resource busy
Subtest basic-S4-devices failed.

<3> [159.241661] Freezing of tasks failed after 20.002 seconds (3 tasks refusing to freeze, wq_busy=0):
<6> [159.241727] systemd-udevd   D12568   289    282 0x80000104
<4> [159.241816] Call Trace:
<4> [159.241856]  ? __schedule+0x364/0xb50
<4> [159.241949]  schedule+0x2d/0x90
<4> [159.241975]  __pm_runtime_barrier+0x9c/0x160
<4> [159.242009]  ? wait_woken+0xa0/0xa0
<4> [159.242038]  __pm_runtime_disable+0x84/0xe0
<4> [159.242087]  snd_hda_codec_cleanup_for_unbind+0x21e/0x230 [snd_hda_codec]
<4> [159.242142]  hda_codec_driver_probe+0xd0/0x140 [snd_hda_codec]
<4> [159.242183]  really_probe+0xf3/0x3e0
<4> [159.242214]  driver_probe_device+0x10a/0x120
<4> [159.242245]  __driver_attach+0xdb/0x100
<4> [159.242273]  ? driver_probe_device+0x120/0x120
<4> [159.242304]  ? driver_probe_device+0x120/0x120
<4> [159.242334]  bus_for_each_dev+0x74/0xc0
<4> [159.242367]  bus_add_driver+0x15f/0x250
<4> [159.242395]  ? 0xffffffffa0137000
<4> [159.242421]  driver_register+0x56/0xe0
<4> [159.242447]  ? 0xffffffffa0137000
<4> [159.242473]  do_one_initcall+0x58/0x2e0
<4> [159.242505]  ? do_init_module+0x1d/0x1ea
<4> [159.242535]  ? rcu_read_lock_sched_held+0x6f/0x80
<4> [159.242567]  ? kmem_cache_alloc_trace+0x264/0x290
<4> [159.242603]  do_init_module+0x56/0x1ea
<4> [159.242633]  load_module+0x2714/0x29f0
<4> [159.242688]  ? __se_sys_finit_module+0xd3/0xf0
<4> [159.242717]  __se_sys_finit_module+0xd3/0xf0
<4> [159.242760]  do_syscall_64+0x55/0x190
<4> [159.242850]  entry_SYSCALL_64_after_hwframe+0x49/0xbe
<4> [159.242919] RIP: 0033:0x7ff099eff839
<4> [159.242955] Code: Bad RIP value.
<4> [159.242978] RSP: 002b:00007ffc1707abb8 EFLAGS: 00000246 ORIG_RAX: 0000000000000139
<4> [159.243020] RAX: ffffffffffffffda RBX: 000055568e2f88f0 RCX: 00007ff099eff839
<4> [159.243057] RDX: 0000000000000000 RSI: 00007ff099bde0e5 RDI: 000000000000000f
<4> [159.243094] RBP: 00007ff099bde0e5 R08: 0000000000000000 R09: 00007ffc1707acd0
<4> [159.243131] R10: 000000000000000f R11: 0000000000000246 R12: 0000000000000000
<4> [159.243168] R13: 000055568e2f60a0 R14: 0000000000020000 R15: 000055568e2f88f0
<6> [159.243222] alsactl         D13000   395    290 0x80000106
<4> [159.243262] Call Trace:
<4> [159.243290]  ? __schedule+0x364/0xb50
<4> [159.243317]  ? rwsem_down_write_failed+0xa0/0x2d0
<4> [159.243352]  ? rwsem_down_write_failed+0x1c2/0x2d0
<4> [159.243385]  schedule+0x2d/0x90
<4> [159.243409]  rwsem_down_write_failed+0x1c7/0x2d0
<4> [159.243443]  ? lock_acquire+0xa6/0x1c0
<4> [159.243479]  ? call_rwsem_down_write_failed+0x13/0x20
<4> [159.243510]  call_rwsem_down_write_failed+0x13/0x20
<4> [159.243547]  ? snd_ctl_release+0x7e/0x120
<4> [159.243577]  down_write+0x4e/0x60
<4> [159.243603]  ? snd_ctl_release+0x7e/0x120
<4> [159.243631]  snd_ctl_release+0x7e/0x120
<4> [159.243663]  __fput+0xb9/0x1f0
<4> [159.243694]  task_work_run+0x82/0xb0
<4> [159.243726]  do_exit+0x34e/0xd10
<4> [159.243754]  ? ksys_ioctl+0x35/0x60
<4> [159.243809]  rewind_stack_do_exit+0x17/0x20
<6> [159.243852] alsactl         D14136   475      1 0x00000004
<4> [159.243893] Call Trace:
<4> [159.243920]  ? __schedule+0x364/0xb50
<4> [159.243946]  ? rwsem_down_write_failed+0xa0/0x2d0
<4> [159.243981]  ? rwsem_down_write_failed+0x1c2/0x2d0
<4> [159.244013]  schedule+0x2d/0x90
<4> [159.244038]  rwsem_down_write_failed+0x1c7/0x2d0
<4> [159.244080]  ? call_rwsem_down_write_failed+0x13/0x20
<4> [159.244110]  call_rwsem_down_write_failed+0x13/0x20
<4> [159.244145]  ? snd_ctl_release+0x7e/0x120
<4> [159.244174]  down_write+0x4e/0x60
<4> [159.244199]  ? snd_ctl_release+0x7e/0x120
<4> [159.244227]  snd_ctl_release+0x7e/0x120
<4> [159.244259]  __fput+0xb9/0x1f0
<4> [159.244287]  task_work_run+0x82/0xb0
<4> [159.244317]  exit_to_usermode_loop+0x93/0xa0
<4> [159.244346]  do_syscall_64+0x14c/0x190
<4> [159.244376]  entry_SYSCALL_64_after_hwframe+0x49/0xbe
<4> [159.244406] RIP: 0033:0x7f2228a45421
<4> [159.244435] Code: Bad RIP value.
<4> [159.244457] RSP: 002b:00007ffc95661ba8 EFLAGS: 00000246 ORIG_RAX: 0000000000000003
<4> [159.244498] RAX: 0000000000000000 RBX: 0000000000000003 RCX: 00007f2228a45421
<4> [159.244535] RDX: 00007ffc95661bb0 RSI: 0000000081785501 RDI: 0000000000000003
<4> [159.244572] RBP: 0000000000000000 R08: 0000000000000000 R09: 0000000000000000
<4> [159.244608] R10: 0000000000000000 R11: 0000000000000246 R12: 00007ffc95661e1c
<4> [159.244645] R13: 0000561fd501cd61 R14: 00007ffc95661e30 R15: 0000000000000001
<6> [159.244703] OOM killer enabled.
<6> [159.244724] Restarting tasks ... done.
<6> [159.271966] PM: hibernation exit
<5> [159.284716] Setting dangerous option reset - tainting kernel
<6> [159.285098] [IGT] gem_exec_suspend: exiting, ret=99
Comment 1 Francesco Balestrieri 2018-11-23 10:40:15 UTC
Is the assignment to display/audio correct?
Comment 2 Francesco Balestrieri 2018-11-23 10:53:33 UTC
Seen once so far. Maybe not "highest"?
Comment 3 Lakshmi 2018-11-29 07:50:48 UTC
This failure occurred only once CI_DRM_5127 (2 weeks, 2 days / 480 runs ago).
Setting the priority to Medium. I doubt if this is our bug.

Also, this could be same as https://bugs.freedesktop.org/show_bug.cgi?id=107918

Historically all the bugs related to this failure are closed as Notourbug.
Comment 4 Martin Peres 2018-12-03 13:22:04 UTC
Also seen on SKL: https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5239/fi-skl-6600u/igt@gem_exec_suspend@basic-s4-devices.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5238/fi-skl-6600u/igt@gem_exec_suspend@basic-s4-devices.html

Starting subtest: basic-S4-devices
(gem_exec_suspend:2412) igt_aux-CRITICAL: Test assertion failure function suspend_via_sysfs, file ../lib/igt_aux.c:794:
(gem_exec_suspend:2412) igt_aux-CRITICAL: Failed assertion: igt_sysfs_set(power_dir, "state", suspend_state_name[state])
(gem_exec_suspend:2412) igt_aux-CRITICAL: Last errno: 16, Device or resource busy
Subtest basic-S4-devices failed.

<3> [194.615048] Freezing of tasks failed after 20.004 seconds (0 tasks refusing to freeze, wq_busy=1):
Comment 5 Francesco Balestrieri 2019-02-11 08:24:54 UTC
Last seen 1119 runs ago. Before that, occurrences were every 1-10 runs. Closing.
Comment 7 sujaritha.sundaresan 2019-11-04 16:27:22 UTC
Bug Assessment :

Reproduction rate : 0.7% (from CI Bug Log). Seen 13/1916 runs.

Last seen 5 months back on SKL systems.

gem-exec-suspend@s4-devices – Basic subtest to check hibernate and resume.

In this case, the issue is the freezing of tasks after 20.004 seconds fails.

This bug has not been seen for 5 months now on either affected platform (SKL and GLK). Setting priority low.
Comment 8 Lakshmi 2019-11-05 10:33:58 UTC
This issue is seen once in 35.14 CI_DRM runs last seen CI_DRM_5619 (8 months, 2 weeks old). Current run is 7258, closing and archiving this issue.
Comment 9 CI Bug Log 2019-11-05 10:34:06 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.