Bug 108734 - Regression: [bisected] dEQP-GLES31.functional.tessellation.invariance.* start failing on r600
Summary: Regression: [bisected] dEQP-GLES31.functional.tessellation.invariance.* start...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-13 16:36 UTC by Gert Wollny
Modified: 2019-09-18 20:19 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gert Wollny 2018-11-13 16:36:06 UTC
The patch  

  5d517a599b1eabd1d5696bf31e26f16568d35770 
  st/mesa: Don't record garbage streamout information in the non-SSO case.

breaks dEQP-GLES31.functional.tessellation.invariance.* on r600. All the tests pass without this patch, but with the patch applied 

   glGetQueryObjectuiv(queryObject, GL_QUERY_RESULT, &result);

returns zero in result for all the tests from this set, which is not correct.
Comment 1 Gert Wollny 2018-11-14 17:44:57 UTC
A bit of digging showed that in these tests the driver only seems to write streamout data from the TES shader, but it somehow gets lost. My guess is that the driver at one point ignores the TF information attached at stages that are not the vertex shader, because before this patch the TES TF output information gets attached in each stage, and hence, also in the VS stage.
Comment 2 GitLab Migration User 2019-09-18 20:19:04 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/931.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.