Bug 108736 - GPU hang with both Cinnamon and MATE
Summary: GPU hang with both Cinnamon and MATE
Status: CLOSED WONTFIX
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-14 04:25 UTC by Brian Johnson
Modified: 2019-02-22 10:21 UTC (History)
1 user (show)

See Also:
i915 platform: BXT
i915 features: GPU hang


Attachments
dmesg output with debug (49.37 KB, application/x-bzip)
2018-11-14 04:25 UTC, Brian Johnson
no flags Details
batch buffer output (26.15 KB, application/x-bzip)
2018-11-14 04:25 UTC, Brian Johnson
no flags Details
dmesg w/ 4.19.2 (55.28 KB, application/x-bzip)
2018-11-15 01:02 UTC, Brian Johnson
no flags Details
batch buffer w/ 4.19.2 (38.48 KB, application/x-bzip)
2018-11-15 01:03 UTC, Brian Johnson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Johnson 2018-11-14 04:25:01 UTC
Created attachment 142459 [details]
dmesg output with debug

Symptoms:  Display freezes for several seconds; The mouse pointer is still movable, but nothing responds to click anymore; The display manager crashes and either goes into fallback mode (Cinnamon) or takes me back to the login screen (MATE).

Reproduce:  This issue seems most reproducible when watching a YouTube video in Firefox.  Though it has happened in many other scenarios as well.

System Information:
-- system architecture: x86_64
-- kernel version: 4.15.0-39-generic
-- Linux distribution: Linux Mint 19, both Cinnamon and MATE versions
-- Machine or mother board model:

    System:    Host: tokyo Kernel: 4.15.0-39-generic x86_64 bits: 64 gcc: 7.3.0
               Desktop: MATE 1.20.1 (Gtk 3.22.30-1ubuntu1) dm: lightdm Distro: Linux Mint 19 Tara
    Machine:   Device: desktop System: Compulab product: fitlet2 serial: N/A
               Mobo: Compulab model: fitlet2 v: 1.1 serial: N/A
               UEFI: American Megatrends v: FLT2.MBM2.0.46.01.00 date: 09/26/2018
               Chassis: type: 3 serial: N/A
    Battery    hidpp__2: charge: N/A condition: NA/NA Wh volts: NA
               model: Logitech Wireless Mouse M310/M310t serial: <filter>status: Discharging
               hidpp__3: charge: N/A condition: NA/NA Wh volts: NA
               model: Logitech K520 serial: <filter>status: Discharging
    CPU:       Quad core Intel Celeron J3455 (-MCP-) arch: N/A cache: 1024 KB
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11980
               clock speeds: min/max: 800/2300 MHz 1: 1776 MHz 2: 1666 MHz 3: 1560 MHz
               4: 1710 MHz
    Graphics:  Card: Intel Device 5a85 bus-ID: 00:02.0 chip-ID: 8086:5a85
               Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting (unloaded: fbdev,vesa)
               Resolution: 1920x1080@60.00hz
               OpenGL: renderer: Mesa DRI Intel HD Graphics 500 (Broxton 2x6)
               version: 4.5 Mesa 18.0.5 (compat-v: 3.0) Direct Render: Yes
    Audio:     Card Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster
               driver: snd_hda_intel bus-ID: 00:0e.0 chip-ID: 8086:5a98
               Sound: Advanced Linux Sound Architecture v: k4.15.0-39-generic
    Network:   Card-1: Intel Wireless 8260 driver: iwlwifi bus-ID: 01:00.0 chip-ID: 8086:24f3
               IF: wlp1s0 state: down mac: <filter>
               Card-2: Intel I211 Gigabit Network Connection
               driver: igb v: 5.4.0-k port: e000 bus-ID: 02:00.0 chip-ID: 8086:1539
               IF: enp2s0 state: down mac: <filter>
               Card-3: Intel I211 Gigabit Network Connection
               driver: igb v: 5.4.0-k port: d000 bus-ID: 03:00.0 chip-ID: 8086:1539
               IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
    Drives:    HDD Total Size: 63.4GB (14.6% used)
               ID-1: /dev/sda model: M2SCF size: 63.4GB serial: <filter>
    Partition: ID-1: / size: 58G used: 8.7G (16%) fs: ext4 dev: /dev/sda2
    RAID:      System: supported: N/A
               No RAID devices: /proc/mdstat, md_mod kernel module present
               Unused Devices: none
    Sensors:   System Temperatures: cpu: 37.0C mobo: N/A
               Fan Speeds (in rpm): cpu: N/A
    Info:      Processes: 180 Uptime: 15 min Memory: 482.9/3767.5MB
               Init: systemd v: 237 runlevel: 5 Gcc sys: 7.3.0
               Client: Shell (bash 4.4.191 running in mate-terminal) inxi: 2.3.56

-- Display connector: HDMI
-- dmesg with debug information: SEE ATTACHED
-- GPU crash dump: SEE ATTACHED
Comment 1 Brian Johnson 2018-11-14 04:25:47 UTC
Created attachment 142460 [details]
batch buffer output
Comment 2 Brian Johnson 2018-11-14 04:28:07 UTC
Also reported in Linux Mint forums:
https://forums.linuxmint.com/viewtopic.php?f=208&t=281354&sid=7e8e15b975115a6e7203511419853149
Comment 3 Chris Wilson 2018-11-14 09:57:04 UTC
The ring registers are more than a little peculiar, could you recapture the error on a more recent kernel?
Comment 4 Brian Johnson 2018-11-15 01:02:31 UTC
Sure thing.  Installed 4.19.2 and recaptured both logs, attached.
Comment 5 Brian Johnson 2018-11-15 01:02:57 UTC
Created attachment 142469 [details]
dmesg w/ 4.19.2
Comment 6 Brian Johnson 2018-11-15 01:03:27 UTC
Created attachment 142470 [details]
batch buffer w/ 4.19.2
Comment 7 Brian Johnson 2018-11-18 03:19:20 UTC
If there's any signs that this is actually a hardware issue I would appreciate knowing that so I can get this back to the manufacturer while it's still under warranty.  Thanks!
Comment 8 Lakshmi 2018-11-19 13:39:22 UTC
Since the hang happened on flush, I assume this is an Xorg bug. Setting the product as Xorg.
Comment 9 Chris Wilson 2018-11-19 13:59:23 UTC
The STATE_BASE_ADDRESS looks inconsistent, suggesting a relocation screw up.
Comment 10 Lakshmi 2019-02-07 11:17:10 UTC
Brian, do you still have this issue with latest drmtip?
(https://cgit.freedesktop.org/drm-tip).
If problem exists with latest drm-tip, set kernel parameters drm.debug=0x1e log_buf_len=4M and reboot.
Try to reproduce the issue and attach the dmesg log.
Comment 11 Brian Johnson 2019-02-07 14:58:34 UTC
Due to lack of activity in this bug report I had to RMA the system.  Couldn't wait any longer.  So I no longer have the system to test with.
Comment 12 Lakshmi 2019-02-22 10:21:49 UTC
Since the setup is no longer available to reproduce the issue with drmtip, Closing this bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.