Bug 108764 - The native screen(eDP) would be black when rotate the external screen to inverted from normal
Summary: The native screen(eDP) would be black when rotate the external screen to inve...
Status: RESOLVED DUPLICATE of bug 110375
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: high critical
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged, ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-16 08:33 UTC by qwang13
Modified: 2019-04-29 13:35 UTC (History)
3 users (show)

See Also:
i915 platform: ALL
i915 features: display/Other


Attachments
This is the general dmesg with 0xe in debug parameter (57.01 KB, text/plain)
2018-11-16 08:48 UTC, qwang13
no flags Details
this is the inverted action log with 0xe in debug parameter (102 bytes, text/plain)
2018-11-16 08:49 UTC, qwang13
no flags Details
FVWM test result (2.38 MB, image/jpeg)
2018-11-19 06:58 UTC, Lakshmi
no flags Details
drm.debug=0x1e log_buf_len=4M (1.22 MB, text/plain)
2019-04-11 03:10 UTC, qwang13
no flags Details
vian (1.21 KB, text/html)
2019-04-29 13:35 UTC, Vian
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description qwang13 2018-11-16 08:33:30 UTC
This bug happens on all OSVs and latest upstream code.

System Environment
=======
Platform Info: WHL-U(all platforms with eDP support)
Label: WHLU01
Processor: Genuine Intel(R) CPU 0000 @ 1.60GHz
Bios: CNLSFWR1.R00.X137.B00.1803280218
OS: ubuntu 18.10
Kernel: 4.18.0-9-generic


Bug detailed description
=======
Platform information:
Platform: WHLU
Label: WHLU01
Prcessor: Genuine Intel(R) CPU 0000 @ 1.60GHz
Bios: CNLSFWR1.R00.X137.B00.1803280218
OS: Ubuntu18.10(Cosmic Cuttlefish)
Kernel: 4.18.0-10-generic
Details:
1) Connect the SUT to an external screen with DP cable;
2) Power on and boot into the OS;
3) Rotate the DP screen with the command "xrandr --output xxx ("DP screen's name") --rotate left/right/inverted/normal";

Results:
1) The native and DP screen displayed well when rotate the HDMI/DP screen to left or right;
2) The native screen and HDMI/DP screen would display well if rotate the HDMI/DP screen to inverted from left or right;
3) The native screen would be black when rotate the HDMI/DP screen to inverted from normal, but the HDMI/DP screen displayed well.
No info in dmesg log, so just attach the journalctl log( journalctl_4.18.0-10_rotate_WHLU.log ).


Expected Result
=============
work normally

Actual Result
===========
eDP turns black. But when rotate normal, it changed back and works well.

Analysis & Root Cause
===================
Comment 1 qwang13 2018-11-16 08:35:46 UTC
Currently RH/SUSE/Ubuntu all reported this issue. We have tried latest upstream code, it is the same error.

This bug affects all Intel Platforms which have eDP supported.
Comment 2 qwang13 2018-11-16 08:48:10 UTC
Created attachment 142486 [details]
This is the general dmesg with 0xe in debug parameter
Comment 3 qwang13 2018-11-16 08:49:29 UTC
Created attachment 142487 [details]
this is the inverted action log with 0xe in debug parameter
Comment 4 qwang13 2018-11-16 08:50:07 UTC
The bug could be easily reproduced with the reproduce steps in the descrition.
Comment 5 Lakshmi 2018-11-19 06:57:06 UTC
I was able to reproduce the bug. Later I tried to reproduce the same issue in fvwm, unable to reproduce the issue. I would say the issue is in user space but not in kernel.
Attached the FVWM result.
Comment 6 Lakshmi 2018-11-19 06:58:00 UTC
Created attachment 142512 [details]
FVWM test result
Comment 7 Lakshmi 2018-11-27 09:06:06 UTC
Considering the issue is in userspace, closing this bug as NOTOURBUG.
Comment 8 qwang13 2018-12-12 07:09:38 UTC
(In reply to Lakshmi from comment #7)
> Considering the issue is in userspace, closing this bug as NOTOURBUG.

hi, Lakshmi

FVWM doesn't use linux kernel driver?
Comment 9 qwang13 2018-12-12 07:10:09 UTC
(In reply to Lakshmi from comment #7)
> Considering the issue is in userspace, closing this bug as NOTOURBUG.

hi, Lakshmi

FVWM doesn't use linux kernel driver?
Comment 10 qwang13 2018-12-12 07:34:44 UTC
So, you think it is window manager issue. Gnome or KDE?

my question is only eDP has this issue, without eDP, we can not reproduce it.

Which part should I file the bug for? or could you help me change to other part?
Comment 11 Jani Nikula 2018-12-12 08:23:03 UTC
Reopening, I don't think we have conclusive evidence the problem is in userspace, and even if the problem were in userspace, we'd need to identify where in the stack and reassign.

qwang13, please elaborate on the issue. So do I understand correctly that:

1) The *external* DP/HDMI display works fine with all rotation options.

2) The *embedded* eDP goes black on some *external* DP/HDMI rotation options.

The attached logs are insufficient. Please add drm.debug=0xf module parameter, probably also need log_buf_len=4M or similar because that debug option is going to be verbose, reboot, reproduce, attach dmesg all the way from boot.
Comment 12 Jani Nikula 2018-12-12 09:31:56 UTC
(In reply to Lakshmi from comment #5)
> I was able to reproduce the bug. Later I tried to reproduce the same issue
> in fvwm, unable to reproduce the issue. I would say the issue is in user
> space but not in kernel.
> Attached the FVWM result.

So I misunderstood this part. What's the difference with FVWM?
Comment 13 Jani Saarinen 2018-12-14 08:26:33 UTC
Using FVWM we could not see any issues. All just worked. 
Does this indicate issue on outside of kernel. 
This was tested on Lakshmi's laptop (KBL) with external monitor (HDMI)
Comment 14 Lakshmi 2019-02-12 12:24:05 UTC
(In reply to qwang13 from comment #10)
> So, you think it is window manager issue. Gnome or KDE?
> 
> my question is only eDP has this issue, without eDP, we can not reproduce it.
> 
> Which part should I file the bug for? or could you help me change to other
> part?

Can you add the full dmesg log from boot with kernel parameters drm.debug=0x1e log_buf_len=4M?
Comment 15 Lakshmi 2019-03-27 10:22:08 UTC
NO feedback from more then 3 months. Closing this bug.
Comment 16 qwang13 2019-04-10 07:17:34 UTC
(In reply to Lakshmi from comment #15)
> NO feedback from more then 3 months. Closing this bug.

sorry to be late. We tested it in 19.04 (v5.0), the bug is still reproduced.
Comment 17 qwang13 2019-04-11 03:10:24 UTC
Created attachment 143926 [details]
drm.debug=0x1e log_buf_len=4M

this is the latest log with kernel parameter you requested. Thanks for your support.
Comment 18 qwang13 2019-04-11 03:14:59 UTC
(In reply to Jani Nikula from comment #11)
> Reopening, I don't think we have conclusive evidence the problem is in
> userspace, and even if the problem were in userspace, we'd need to identify
> where in the stack and reassign.
> 
> qwang13, please elaborate on the issue. So do I understand correctly that:
> 
> 1) The *external* DP/HDMI display works fine with all rotation options.
> 
> 2) The *embedded* eDP goes black on some *external* DP/HDMI rotation options.
> 
> The attached logs are insufficient. Please add drm.debug=0xf module
> parameter, probably also need log_buf_len=4M or similar because that debug
> option is going to be verbose, reboot, reproduce, attach dmesg all the way
> from boot.

1) yes.
2) 
a.without external, eDP works fine
b.with external DP/HMDI, eDP will black on *external* DP/HDMI rotation options. -only inverted, others are fine.
Comment 19 Lakshmi 2019-04-12 07:31:05 UTC
I was able to reproduce this on my machine(KBL) running drmtip 5.1.0-rc4+.
I see the same behavior as qwang mentioned
" The native screen would be black when rotate the HDMI/DP screen to inverted from normal, but the HDMI/DP screen displayed well."

@Qwang, xrandr --output eDP-1 --off and xrandr --output eDP-1 --auto helped to turn on the native screen back. Have you tried that?
Comment 20 qwang13 2019-04-12 07:59:58 UTC
ok, I will have a try. Thank you.
Comment 21 qwang13 2019-04-15 06:22:30 UTC
only running "xrandr --output eDP-1 --off"
will make eDP-1 to be enabled.

I  have another way to make eDP-1 back. Crtl+ALt+Fx, and turn back, eDP-1 works.

Seems when refresh the screen, eDP-1 will work normal.

anyway, let's turn to the point why inverted make eDP-1 to be black.
Comment 22 Stanislav Lisovskiy 2019-04-24 11:52:18 UTC
Could this be a dup of that other bug(don't remember the number), where once we rotate another display we get NOFB for primary plane for eDP?

If that patch https://patchwork.freedesktop.org/patch/299515/ helps here as well, then it is the same thing and should be handled in user space.
Comment 23 Jani Saarinen 2019-04-24 14:00:06 UTC
Isn't this the bug you are talking here?
Comment 24 Stanislav Lisovskiy 2019-04-24 14:52:30 UTC
(In reply to Jani Saarinen from comment #23)
> Isn't this the bug you are talking here?

I guess no, at least here I didn't comment anything yet.
Comment 25 Jani Saarinen 2019-04-29 12:00:56 UTC

*** This bug has been marked as a duplicate of bug 110375 ***
Comment 26 Jani Saarinen 2019-04-29 12:01:16 UTC
Based on duplicate seems like same issue: https://bugs.freedesktop.org/show_bug.cgi?id=110375
Comment 27 Vian 2019-04-29 13:35:25 UTC
Created attachment 144108 [details]
vian

ngeod


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.