Bug 108771 - [amdgpu] hang with The Last Story on the Dolphin emulator
Summary: [amdgpu] hang with The Last Story on the Dolphin emulator
Status: NEW
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
Depends on:
Reported: 2018-11-16 18:59 UTC by John
Modified: 2019-01-02 19:41 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:

dmesg (72.80 KB, text/plain)
2018-11-16 18:59 UTC, John
xorg log (37.72 KB, text/x-log)
2018-11-16 19:00 UTC, John
dolphin save for the last story (1.29 MB, application/octet-stream)
2018-12-05 04:14 UTC, John
another dmesg (1.07 MB, text/x-log)
2019-01-01 02:23 UTC, Christopher Snowhill
another xorg log (85.52 KB, text/x-log)
2019-01-01 02:25 UTC, Christopher Snowhill

Note You need to log in before you can comment on or make changes to this bug.
Description John 2018-11-16 18:59:43 UTC
Created attachment 142492 [details]

Hello there,

I constantly get this issue with a RX 580 while playing a couple certain scenes of The Last Story on the Dolphin emulator.

To pass the first scenes I had to lower all graphics options and it worked with OpenGL or Vulkan with RADV.

To pass the 2nd one I had to use OGL only, which was super slow compared to VK, so I'm guessing it was not sending enough data to trigger the issue.

I've had other similar system crashes in this game in the past few days, but they were not sticking like this one, just restarting the machine would allow me to proceed, so I am not sure if it was related or not.

I've tried Linux 4.18.15, 4.18.17, 4.18.19 and 4.19.2 with no difference.
I've also tried a few LLVM/Mesa builds from the 29th October to the 13th November and no difference either.

I'm on Arch Linux 64b, Xorg 1.20.3, xf86-video-amdgpu 18.1.0, mesa 90d68858ed, llvm 346744, with an i7 4790k, a 580 and 16Gb of RAM.

I wasn't sure where to file this bug so I hope this is correct.

Thank you!
Comment 1 John 2018-11-16 19:00:05 UTC
Created attachment 142493 [details]
xorg log
Comment 2 John 2018-11-18 02:21:58 UTC
This may be a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=107991 .
Comment 3 John 2018-12-05 03:58:23 UTC
Here's a trace that crashes my system:


I don't know why the trace is all black and does not display anything, but the end result is the same, so I hope it's enough for debugging purposes.

Thank you!
Comment 4 John 2018-12-05 04:14:42 UTC
Created attachment 142730 [details]
dolphin save for the last story

This includes a save right before the crash (for the US version of the game).

Start the autosave, go through the door, a cinematic will start and the system should freeze when Zael turns around.

To freeze the system with OGL, the GPU settings must be pretty high, I last used 4x IR, Max Aniso and MSAA + FXAA, and also standard Ubershaders.
Comment 5 Christopher Snowhill 2019-01-01 02:18:03 UTC
I have reproduced the freeze with the linked apitrace log, also on an Arch Linux desktop. I had to install apitrace from git to replay the log, and it freezes a few "seconds" into the cut scene.

Arch Linux 64b, Xorg 1.20.3, xf86-video-amdgpu 18.1.0, mesa 18.3.1, llvm 7.0.1, with an i7 3770, a 480 and 32GB of RAM.

I've only tested with Linux 4.20, Arch default kernel.

Attaching the same two logs as OP.
Comment 6 Christopher Snowhill 2019-01-01 02:23:20 UTC
Created attachment 142930 [details]
another dmesg

Recovered from journalctl -b -1.
Comment 7 Christopher Snowhill 2019-01-01 02:25:11 UTC
Created attachment 142931 [details]
another xorg log

Xorg log for extra measure, not sure what help it will do.
Comment 8 John 2019-01-01 03:52:11 UTC
Thank you for testing this on another machine, and with newer software!

I hope we will get something nice next year. :)

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.