Bug 108835 - [CI][SHARDS]ICL: igt@kms_flip@blocking-absolute-wf_vblank-interruptible - incomplete - WARNING: CPU: \d+ PID: \d+ at drivers/gpu/drm/drm_vblank.c:\d+ drm_wait_one_vblank
Summary: [CI][SHARDS]ICL: igt@kms_flip@blocking-absolute-wf_vblank-interruptible - inc...
Status: CLOSED NOTOURBUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: low normal
Assignee: Mika Kahola
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-22 14:34 UTC by Lakshmi
Modified: 2018-12-05 12:45 UTC (History)
1 user (show)

See Also:
i915 platform: ICL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2018-11-22 14:34:53 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5178/shard-iclb7/igt@kms_flip@blocking-absolute-wf_vblank-interruptible.html


<4> [853.132618] vblank wait timed out on crtc 0
<4> [853.132651] WARNING: CPU: 2 PID: 189 at drivers/gpu/drm/drm_vblank.c:1084 drm_wait_one_vblank+0x19b/0x1b0
<4> [853.132658] Modules linked in: vgem snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic i915 x86_pkg_temp_thermal coretemp snd_hda_intel crct10dif_pclmul snd_hda_codec crc32_pclmul snd_hwdep snd_hda_core cdc_ether ghash_clmulni_intel usbnet snd_pcm mii e1000e i2c_i801 prime_numbers
<4> [853.132703] CPU: 2 PID: 189 Comm: kworker/2:2 Tainted: G     U            4.20.0-rc3-CI-CI_DRM_5178+ #1
<4> [853.132710] Hardware name: Intel Corporation Ice Lake Client Platform/IceLake U DDR4 SODIMM PD RVP, BIOS ICLSFWR1.R00.2402.AD3.1810170014 10/17/2018
<4> [853.132830] Workqueue: events i915_hotplug_work_func [i915]
<4> [853.132844] RIP: 0010:drm_wait_one_vblank+0x19b/0x1b0
<4> [853.132852] Code: fe ff ff e8 b7 4e a6 ff 48 89 e6 4c 89 ff e8 6c 5f ab ff 45 85 ed 0f 85 15 ff ff ff 89 ee 48 c7 c7 e8 03 10 82 e8 b5 4b a6 ff <0f> 0b e9 00 ff ff ff 0f 1f 40 00 66 2e 0f 1f 84 00 00 00 00 00 8b
<4> [853.132859] RSP: 0018:ffffc9000146bca0 EFLAGS: 00010286
<4> [853.132866] RAX: 0000000000000000 RBX: ffff88849ef00000 RCX: 0000000000000000
<4> [853.132873] RDX: 0000000000000007 RSI: ffffffff820c6f58 RDI: 00000000ffffffff
<4> [853.132879] RBP: 0000000000000000 R08: 000000007ffc637a R09: 0000000000000000
<4> [853.132884] R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000000000
<4> [853.132890] R13: 0000000000000000 R14: 000000000000d0c2 R15: ffff8884a491e680
<4> [853.132897] FS:  0000000000000000(0000) GS:ffff8884afe80000(0000) knlGS:0000000000000000
<4> [853.132904] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4> [853.132910] CR2: 00007f63bf0df000 CR3: 0000000005210006 CR4: 0000000000760ee0
<4> [853.132916] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
<4> [853.132922] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
<4> [853.132927] PKRU: 55555554
<4> [853.132932] Call Trace:
<4> [853.132949]  ? wait_woken+0xa0/0xa0
<4> [853.133068]  intel_dp_retrain_link+0x130/0x190 [i915]
<4> [853.133176]  intel_ddi_hotplug+0x54/0x2e0 [i915]
<4> [853.133298]  i915_hotplug_work_func+0x1a9/0x240 [i915]
<4> [853.133324]  process_one_work+0x262/0x630
<4> [853.133349]  worker_thread+0x37/0x380
<4> [853.133365]  ? process_one_work+0x630/0x630
<4> [853.133373]  kthread+0x119/0x130
<4> [853.133383]  ? kthread_park+0x80/0x80
<4> [853.133400]  ret_from_fork+0x3a/0x50
<4> [853.133433] irq event stamp: 1426928
<4> [853.133443] hardirqs last  enabled at (1426927): [<ffffffff810fa529>] console_unlock+0x3f9/0x5f0
<4> [853.133454] hardirqs last disabled at (1426928): [<ffffffff810019b0>] trace_hardirqs_off_thunk+0x1a/0x1c
<4> [853.133463] softirqs last  enabled at (1426898): [<ffffffff81c0033a>] __do_softirq+0x33a/0x4b9
Comment 1 Mika Kahola 2018-11-29 13:57:52 UTC
Trying a patch on a bot.

https://patchwork.freedesktop.org/series/53245/
Comment 2 Mika Kahola 2018-12-04 09:48:37 UTC
I sent a patch on mailing list for a review. In the patch I propose to wait one vblank event before sending out hotplug event to user space for DP link reprobing.

https://patchwork.freedesktop.org/series/53463/
Comment 3 Mika Kahola 2018-12-05 11:39:12 UTC
This bug hasn't been seen in CI for quite some time now. Based on the CI logs it seems that the bug was caused by a hiccup in a system

[21/79] ( 873s left) kms_flip (blocking-absolute-wf_vblank-interruptible)
FATAL: command execution failed
java.io.EOFException
at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2681)
at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:3156)
at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:862)
at java.io.ObjectInputStream.<init>(ObjectInputStream.java:358)
at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:49)
at hudson.remoting.Command.readFrom(Command.java:140)
at hudson.remoting.Command.readFrom(Command.java:126)
at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:36)
at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:63)
Caused: java.io.IOException: Unexpected termination of the channel
at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:77)
Caused: java.io.IOException: Backing channel 'shard-iclb7' is disconnected.
at hudson.remoting.RemoteInvocationHandler.channelOrFail(RemoteInvocationHandler.java:214)
at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:283)
at com.sun.proxy.$Proxy64.isAlive(Unknown Source)
at hudson.Launcher$RemoteLauncher$ProcImpl.isAlive(Launcher.java:1144)
at hudson.Launcher$RemoteLauncher$ProcImpl.join(Launcher.java:1136)
at hudson.tasks.CommandInterpreter.join(CommandInterpreter.java:155)
at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:109)
at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:66)
at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:744)
at hudson.model.Build$BuildExecution.build(Build.java:206)
at hudson.model.Build$BuildExecution.doRun(Build.java:163)
at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:504)
at hudson.model.Run.execute(Run.java:1810)
at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
at hudson.model.ResourceController.execute(ResourceController.java:97)
at hudson.model.Executor.run(Executor.java:429)
FATAL: Unable to delete script file /tmp/jenkins9130735500847889838.sh
java.io.EOFException
at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2681)
at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:3156)
at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:862)
at java.io.ObjectInputStream.<init>(ObjectInputStream.java:358)
at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:49)
at hudson.remoting.Command.readFrom(Command.java:140)
at hudson.remoting.Command.readFrom(Command.java:126)
at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:36)
at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:63)
Caused: java.io.IOException: Unexpected termination of the channel
at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:77)
Caused: hudson.remoting.ChannelClosedException: Channel "unknown": Remote call on shard-iclb7 failed. The channel is closing down or has closed down
at hudson.remoting.Channel.call(Channel.java:948)
at hudson.FilePath.act(FilePath.java:1070)
at hudson.FilePath.act(FilePath.java:1059)
at hudson.FilePath.delete(FilePath.java:1563)
at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:123)
at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:66)
at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:744)
at hudson.model.Build$BuildExecution.build(Build.java:206)
at hudson.model.Build$BuildExecution.doRun(Build.java:163)
at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:504)
at hudson.model.Run.execute(Run.java:1810)
at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
at hudson.model.ResourceController.execute(ResourceController.java:97)
at hudson.model.Executor.run(Executor.java:429)
Build step 'Execute shell' marked build as failure

Therefore, I propose that we close this bug.
Comment 4 Lakshmi 2018-12-05 12:45:16 UTC
Closing this bug considering this is caused CI side (Jenkins). Reopen this bug if the issue is due to kernel.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.